aboutsummaryrefslogtreecommitdiff
path: root/news/xpn/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-01-14 21:55:30 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-01-14 21:55:30 +0000
commitd53e5f01e3aa146eaba3949fa6a8122ac505baa0 (patch)
tree310662e7535b028d95ee2a5922d55a9df35eaee9 /news/xpn/Makefile
parent68a53746441da50077f32c4e82eb886a607ab2a5 (diff)
Notes
Diffstat (limited to 'news/xpn/Makefile')
-rw-r--r--news/xpn/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/news/xpn/Makefile b/news/xpn/Makefile
new file mode 100644
index 000000000000..8f28498be8e1
--- /dev/null
+++ b/news/xpn/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: xpn
+# Date created: 2007-01-14
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xpn
+PORTVERSION= 0.7.0
+CATEGORIES= news python
+MASTER_SITES= http://xpn.altervista.org/codice/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= X Python Newsreader
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:${PORTSDIR}/x11-toolkits/py-gtk2
+
+NO_BUILD= yes
+
+USE_PYTHON= 2.4+
+
+FIND_DIRS= -type d
+FIND_DATA= -type f -mindepth 2
+
+SUB_FILES= ${PORTNAME}
+SUB_LIST= PYTHON_CMD=${PYTHON_CMD} XPN=${XPN}
+
+USE_GETTEXT= yes
+
+XPN= ${PORTNAME}.py
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${XPN} ${DATADIR}/${XPN}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ cd ${WRKSRC} && ${FIND} . ${FIND_DIRS} -exec ${MKDIR} ${DATADIR}/{} ";"
+ cd ${WRKSRC} && ${FIND} . ${FIND_DATA} -exec ${INSTALL_DATA} {} ${DATADIR}/{} ";"
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>