aboutsummaryrefslogtreecommitdiff
path: root/news/xrn/Makefile
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2001-09-14 13:50:58 +0000
committerMark Pulford <markp@FreeBSD.org>2001-09-14 13:50:58 +0000
commitd4edef4bb42074005f57cf5487b481d098e24ad5 (patch)
tree126942abf2258f852a0cac873a27b6e5352fc262 /news/xrn/Makefile
parentb135d533e0e70920b7523ff25054a7ad92a01156 (diff)
downloadports-d4edef4bb42074005f57cf5487b481d098e24ad5.tar.gz
ports-d4edef4bb42074005f57cf5487b481d098e24ad5.zip
Notes
Diffstat (limited to 'news/xrn/Makefile')
-rw-r--r--news/xrn/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/news/xrn/Makefile b/news/xrn/Makefile
new file mode 100644
index 000000000000..2cf9a2819d22
--- /dev/null
+++ b/news/xrn/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: xrn
+# Date created: 13 September 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xrn
+PORTVERSION= 9.02
+CATEGORIES= news
+MASTER_SITES= ftp://sipb.mit.edu/pub/xrn/ \
+ ftp://ftp.nuug.no/pub/anders/distfiles/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= anders@fix.no
+
+USE_IMAKE= yes
+MAN1= xrn.1
+MANCOMPRESSED= no
+
+DOCS= COMMON-PROBLMS COPYRIGHT CREDITS ChangeLog
+
+post-patch:
+ @${PERL} -pi -e "s|^#error.+||g; \
+ s|/usr/lib/sendmail|/usr/sbin/sendmail|g;" ${WRKSRC}/config.h
+
+do-install:
+ ${INSTALL_MAN} ${WRKSRC}/xrn.man ${PREFIX}/man/man1/xrn.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/xrn ${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/XRn.ad ${PREFIX}/lib/X11/app-defaults/XRn
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>