aboutsummaryrefslogtreecommitdiff
path: root/news/yencode
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-25 07:35:57 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-25 07:35:57 +0000
commitc1e9288f2ec263932f8f08d4216b6d796f6b43a2 (patch)
treecb32610213fcf8bf43604a7ba0642744ede6e480 /news/yencode
parent415a8391e67153e75b1e5850b6336588ce7c8eb0 (diff)
downloadports-c1e9288f2ec263932f8f08d4216b6d796f6b43a2.tar.gz
ports-c1e9288f2ec263932f8f08d4216b6d796f6b43a2.zip
Notes
Diffstat (limited to 'news/yencode')
-rw-r--r--news/yencode/Makefile29
-rw-r--r--news/yencode/distinfo1
-rw-r--r--news/yencode/pkg-comment1
-rw-r--r--news/yencode/pkg-descr19
-rw-r--r--news/yencode/pkg-plist3
5 files changed, 53 insertions, 0 deletions
diff --git a/news/yencode/Makefile b/news/yencode/Makefile
new file mode 100644
index 000000000000..c6c9b1b41b0b
--- /dev/null
+++ b/news/yencode/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: yencode
+# Date created: Mar 24, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= yencode
+PORTVERSION= 0.46
+CATEGORIES= news
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt \
+ iconv:${PORTSDIR}/converters/libiconv \
+ intl:${PORTSDIR}/devel/gettext
+
+USE_BISON= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lgnugetopt"
+
+MAN1= ydecode.1 yencode.1 ypost.1
+MAN5= ypostrc.5
+
+.include <bsd.port.mk>
diff --git a/news/yencode/distinfo b/news/yencode/distinfo
new file mode 100644
index 000000000000..9336dd33d13d
--- /dev/null
+++ b/news/yencode/distinfo
@@ -0,0 +1 @@
+MD5 (yencode-0.46.tar.gz) = 6af054f69c781cafa620063878a831ea
diff --git a/news/yencode/pkg-comment b/news/yencode/pkg-comment
new file mode 100644
index 000000000000..8eae33462ef3
--- /dev/null
+++ b/news/yencode/pkg-comment
@@ -0,0 +1 @@
+A free (GPL) encoder and decoder for the yEnc Usenet file format
diff --git a/news/yencode/pkg-descr b/news/yencode/pkg-descr
new file mode 100644
index 000000000000..818f0525cd70
--- /dev/null
+++ b/news/yencode/pkg-descr
@@ -0,0 +1,19 @@
+yencode is an encoder/decoder package for the Usenet yEnc encoding format.
+
+The source code is freely available under the GNU General Public License and
+should work on most modern Unix-like operating systems.
+
+Features:
+ - Full internationalization (multilingual) support provided by GNU gettext.
+ - Encoder can output single part or multipart encoded archives of any size.
+ - Smart decoder can handle multiple files, including files specified out of
+ order or with nonsense file names.
+ - Included Usenet posting software posts files to Usenet quickly and
+ easily, including automatic creation of encoded multipart archives and
+ SFV/CRC checksum files, if desired.
+ - Optional scan mode: automatically locate and decode single or multipart
+ encoded archives in specified directories or recursively.
+ - Supports SFV file creation for multiple-file archives.
+ - Fully compliant with the current yEnc specifications.
+
+WWW: http://www.yencode.org/
diff --git a/news/yencode/pkg-plist b/news/yencode/pkg-plist
new file mode 100644
index 000000000000..4f3862ac1ca8
--- /dev/null
+++ b/news/yencode/pkg-plist
@@ -0,0 +1,3 @@
+bin/ydecode
+bin/yencode
+bin/ypost