aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-05-04 15:37:10 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-05-04 15:37:10 +0000
commit3bf624d4b931aa39c39b70452cd78c44a7512b23 (patch)
tree8eb46333fc0254018027b73290e8c9ac63d473d0 /news
parent5ddc422f456715b886085333ac6cb2309c46da8b (diff)
downloadports-3bf624d4b931aa39c39b70452cd78c44a7512b23.tar.gz
ports-3bf624d4b931aa39c39b70452cd78c44a7512b23.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/Makefile1
-rw-r--r--news/newscache/Makefile25
-rw-r--r--news/newscache/distinfo1
-rw-r--r--news/newscache/files/patch-NewsCache.cc10
-rw-r--r--news/newscache/files/patch-NewsCache.info13
-rw-r--r--news/newscache/pkg-comment1
-rw-r--r--news/newscache/pkg-descr17
-rw-r--r--news/newscache/pkg-plist11
8 files changed, 79 insertions, 0 deletions
diff --git a/news/Makefile b/news/Makefile
index d8df9bebe122..c1b2ed7e4059 100644
--- a/news/Makefile
+++ b/news/Makefile
@@ -24,6 +24,7 @@
SUBDIR += knews
SUBDIR += leafnode
SUBDIR += leafnode+
+ SUBDIR += newscache
SUBDIR += newsfetch
SUBDIR += newsfish
SUBDIR += newsgrab
diff --git a/news/newscache/Makefile b/news/newscache/Makefile
new file mode 100644
index 000000000000..e078a7d7a14d
--- /dev/null
+++ b/news/newscache/Makefile
@@ -0,0 +1,25 @@
+# New ports collection Makefile for: newscache
+# Date created: 23 February 2002
+# Whom: Tilman Linneweh <freebsdports@arved.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= newscache
+PORTVERSION= 0.99.22
+CATEGORIES= news
+MASTER_SITES= http://www.infosys.tuwien.ac.at/NewsCache/download/ \
+ http://members.aon.at/hstraub/linux/
+DISTNAME= NewsCache-${PORTVERSION}
+
+MAINTAINER= freebsdports@arved.de
+
+WRKSRC= ${WRKDIR}/NewsCache
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+MAN5= newscache.conf.5
+MAN8= NewsCache.8 NewsCacheClean.8 updatenews.8
+
+.include <bsd.port.mk>
diff --git a/news/newscache/distinfo b/news/newscache/distinfo
new file mode 100644
index 000000000000..ca52fd1830dd
--- /dev/null
+++ b/news/newscache/distinfo
@@ -0,0 +1 @@
+MD5 (NewsCache-0.99.22.tar.gz) = 5ac4bed16dfaa506d207fabd6d7daef0
diff --git a/news/newscache/files/patch-NewsCache.cc b/news/newscache/files/patch-NewsCache.cc
new file mode 100644
index 000000000000..445cffccb6be
--- /dev/null
+++ b/news/newscache/files/patch-NewsCache.cc
@@ -0,0 +1,10 @@
+--- src/NewsCache.cc.orig Sat Feb 23 18:06:38 2002
++++ src/NewsCache.cc Sat Feb 23 18:06:48 2002
+@@ -18,7 +18,6 @@
+ */
+ #include "config.h"
+
+-#include <crypt.h>
+ #include <ctype.h>
+ #include <unistd.h>
+ #include <string.h>
diff --git a/news/newscache/files/patch-NewsCache.info b/news/newscache/files/patch-NewsCache.info
new file mode 100644
index 000000000000..ce49d420a1cb
--- /dev/null
+++ b/news/newscache/files/patch-NewsCache.info
@@ -0,0 +1,13 @@
+--- doc/NewsCache.info.orig Tue Feb 5 10:07:28 2002
++++ doc/NewsCache.info Sat May 4 15:28:28 2002
+@@ -1,6 +1,10 @@
+ This is Info file NewsCache.info, produced by Makeinfo version 1.68
+ from the input file NewsCache.texinfo.
+
++START-INFO-DIR-ENTRY
++* NewsCache: (newscache). Cache for Network News Transport Protocol.
++END-INFO-DIR-ENTRY
++
+ This is the NewsCache Reference Manual.
+
+ Copyright (C) 1998 Thomas Gschwind <tom@infosys.tuwien.ac.at>
diff --git a/news/newscache/pkg-comment b/news/newscache/pkg-comment
new file mode 100644
index 000000000000..e7fe60fb9c8b
--- /dev/null
+++ b/news/newscache/pkg-comment
@@ -0,0 +1 @@
+NewsCache is a free cache server for USENET News
diff --git a/news/newscache/pkg-descr b/news/newscache/pkg-descr
new file mode 100644
index 000000000000..831cff1282d3
--- /dev/null
+++ b/news/newscache/pkg-descr
@@ -0,0 +1,17 @@
+What is NewsCache?
+
+NewsCache is a free cache server for USENET News available under the GNU
+General Public License. NewsCache can be plugged in between your news
+reader(s) and your news server. NewsCache acts to news readers like a news
+server and retrieves news articles from the news server like a news
+reader. Whenever, a client requests an article from NewsCache, NewsCache
+checks whether the article has already been stored in the cache area. If
+this is the case, the article is sent directly to its client. Otherwise,
+the article is requested from the upstream news server, stored in the
+cache area and sent back to the client.
+
+Author: Thomas Gschwind
+WWW: http://www.infosys.tuwien.ac.at/NewsCache/
+
+- arved
+freebsdports@arved.de
diff --git a/news/newscache/pkg-plist b/news/newscache/pkg-plist
new file mode 100644
index 000000000000..15aa10d5ff3d
--- /dev/null
+++ b/news/newscache/pkg-plist
@@ -0,0 +1,11 @@
+bin/updatenews
+etc/newscache.conf-dist
+sbin/NewsCache
+sbin/NewsCacheClean
+sbin/accesslog
+sbin/cachestat
+sbin/hostlog
+sbin/hoststat
+@unexec install-info --delete %D/info/NewsCache.info %D/info/dir
+info/NewsCache.info
+@exec install-info %D/info/NewsCache.info %D/info/dir