aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-06-20 17:05:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-06-20 17:05:41 +0000
commit4376dbbb58dab5a7bf7a8240ca39b562de78343b (patch)
tree8997a738fc5162cf5f1383dd3c61c0423454979b /news
parent6cb7ca00bb0a9a3aa67008824300ee8d16203a1b (diff)
downloadports-4376dbbb58dab5a7bf7a8240ca39b562de78343b.tar.gz
ports-4376dbbb58dab5a7bf7a8240ca39b562de78343b.zip
Use PY_FLAVOR for dependencies.
FLAVOR is the current port's flavor, it should not be used outside of this scope. Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=472884
Diffstat (limited to 'news')
-rw-r--r--news/hellanzb/Makefile4
-rw-r--r--news/py-pynzb/Makefile2
-rw-r--r--news/rawdog/Makefile2
3 files changed, 4 insertions, 4 deletions
diff --git a/news/hellanzb/Makefile b/news/hellanzb/Makefile
index c17f62b78216..bae722f3bc71 100644
--- a/news/hellanzb/Makefile
+++ b/news/hellanzb/Makefile
@@ -15,8 +15,8 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= par2:archivers/par2cmdline \
flac:audio/flac \
shorten:audio/shorten \
- ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}yenc>=0:news/py-yenc@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yenc>=0:news/py-yenc@${PY_FLAVOR} \
mac:audio/mac
USE_PYTHON= distutils
diff --git a/news/py-pynzb/Makefile b/news/py-pynzb/Makefile
index d85577767537..ef6f1f0fd233 100644
--- a/news/py-pynzb/Makefile
+++ b/news/py-pynzb/Makefile
@@ -18,6 +18,6 @@ USE_PYTHON= distutils autoplist
OPTIONS_DEFINE= LXML
LXML_DESC= Add support for py-lxml
-LXML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=2.2.1:devel/py-lxml@${FLAVOR}
+LXML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=2.2.1:devel/py-lxml@${PY_FLAVOR}
.include <bsd.port.mk>
diff --git a/news/rawdog/Makefile b/news/rawdog/Makefile
index 2c2c2715570c..06286aa5271f 100644
--- a/news/rawdog/Makefile
+++ b/news/rawdog/Makefile
@@ -12,7 +12,7 @@ COMMENT= Simple RSS aggregator
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/feedparser.py:textproc/py-feedparser@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/feedparser.py:textproc/py-feedparser@${PY_FLAVOR}
USES= python:2.7
USE_PYTHON= distutils