aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /news
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'news')
-rw-r--r--news/hellanzb/Makefile4
-rw-r--r--news/py-pynzb/Makefile2
-rw-r--r--news/py-yenc/Makefile2
-rw-r--r--news/rawdog/Makefile4
-rw-r--r--news/sabnzbdplus/Makefile12
-rw-r--r--news/xpn/Makefile4
6 files changed, 14 insertions, 14 deletions
diff --git a/news/hellanzb/Makefile b/news/hellanzb/Makefile
index 3476341ec175..f3c65ef2fd03 100644
--- a/news/hellanzb/Makefile
+++ b/news/hellanzb/Makefile
@@ -15,8 +15,8 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= par2:archivers/par2cmdline \
flac:audio/flac \
shorten:audio/shorten \
- ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted \
- ${PYTHON_PKGNAMEPREFIX}yenc>=0:news/py-yenc \
+ ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yenc>=0:news/py-yenc@${FLAVOR} \
mac:audio/mac
USE_PYTHON= distutils
diff --git a/news/py-pynzb/Makefile b/news/py-pynzb/Makefile
index da515918bf07..d85577767537 100644
--- a/news/py-pynzb/Makefile
+++ b/news/py-pynzb/Makefile
@@ -18,6 +18,6 @@ USE_PYTHON= distutils autoplist
OPTIONS_DEFINE= LXML
LXML_DESC= Add support for py-lxml
-LXML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=2.2.1:devel/py-lxml
+LXML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=2.2.1:devel/py-lxml@${FLAVOR}
.include <bsd.port.mk>
diff --git a/news/py-yenc/Makefile b/news/py-yenc/Makefile
index d92939a57aab..bf2de8e9ff12 100644
--- a/news/py-yenc/Makefile
+++ b/news/py-yenc/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= jlaffaye@FreeBSD.org
COMMENT= yenc decoding module for Python in C
-USES= python
+USES= python:2.7
USE_PYTHON= distutils
.include <bsd.port.mk>
diff --git a/news/rawdog/Makefile b/news/rawdog/Makefile
index a46c27933e62..2c2c2715570c 100644
--- a/news/rawdog/Makefile
+++ b/news/rawdog/Makefile
@@ -12,9 +12,9 @@ COMMENT= Simple RSS aggregator
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/feedparser.py:textproc/py-feedparser
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/feedparser.py:textproc/py-feedparser@${FLAVOR}
-USES= python
+USES= python:2.7
USE_PYTHON= distutils
NO_ARCH= yes
diff --git a/news/sabnzbdplus/Makefile b/news/sabnzbdplus/Makefile
index 17234765ebc7..d79a3a495e02 100644
--- a/news/sabnzbdplus/Makefile
+++ b/news/sabnzbdplus/Makefile
@@ -10,9 +10,9 @@ COMMENT= Web-interface based binary newsgrabber in python, with nzb support
LICENSE= BSD2CLAUSE BSD3CLAUSE GPLv2+ ISCL MIT PSFL
LICENSE_COMB= multi
-RUN_DEPENDS= cheetah:devel/py-cheetah \
- ${PYTHON_SITELIBDIR}/pythonutils/configobj.py:devel/py-utils \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
+RUN_DEPENDS= cheetah:devel/py-cheetah@${PY_FLAVOR} \
+ ${PYTHON_SITELIBDIR}/pythonutils/configobj.py:devel/py-utils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
USE_GITHUB= yes
GH_ACCOUNT= sabnzbd
@@ -43,9 +43,9 @@ FEEDPARSER_DESC= rss-feed support
YENC_DESC= yenc support
PAR2CMDLINE_RUN_DEPENDS= par2repair:archivers/par2cmdline-tbb
-FEEDPARSER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=0:textproc/py-feedparser
-YENC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sabyenc>=0:news/py-sabyenc
-SSL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0:security/py-cryptography
+FEEDPARSER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=0:textproc/py-feedparser@${PY_FLAVOR}
+YENC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sabyenc>=0:news/py-sabyenc@${PY_FLAVOR}
+SSL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0:security/py-cryptography@${PY_FLAVOR}
UNRAR_RUN_DEPENDS= unrar:archivers/unrar
7ZIP_RUN_DEPENDS= 7za:archivers/p7zip
diff --git a/news/xpn/Makefile b/news/xpn/Makefile
index cc71fb851338..6ad91e8fdfb8 100644
--- a/news/xpn/Makefile
+++ b/news/xpn/Makefile
@@ -12,8 +12,8 @@ COMMENT= X Python Newsreader
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gtk2>=2.24.0:x11-toolkits/py-gtk2 \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.7.9:databases/py-sqlite3
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gtk2>=2.24.0:x11-toolkits/py-gtk2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.7.9:databases/py-sqlite3@${PY_FLAVOR}
NO_BUILD= yes