aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-04-21 01:14:53 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-04-21 01:14:53 +0000
commit23a1cad535b32b0d14d5a4bad50ad02cd9e7df03 (patch)
tree29c21ef4643c2e80bbb495e2ef81216309e740b4 /news
parentd38144f7f944a10a92d3dedeb7ac91002e02cbd9 (diff)
downloadports-23a1cad535b32b0d14d5a4bad50ad02cd9e7df03.tar.gz
ports-23a1cad535b32b0d14d5a4bad50ad02cd9e7df03.zip
- Fix plist to have proper 'rmdir DIR' ordering.
Pkgng will not detect the directory otherwise. This was due to incorrectly advise in the check-stagedir.sh script, fixed in r351587 With hat: portmgr
Notes
Notes: svn path=/head/; revision=351663
Diffstat (limited to 'news')
-rw-r--r--news/fidogate-ds/Makefile2
-rw-r--r--news/fidogate-ds/pkg-plist48
2 files changed, 25 insertions, 25 deletions
diff --git a/news/fidogate-ds/Makefile b/news/fidogate-ds/Makefile
index c8f4b9cdad61..55decd429f5f 100644
--- a/news/fidogate-ds/Makefile
+++ b/news/fidogate-ds/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fidogate
PORTVERSION= 5.1.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= news mail
MASTER_SITES= SF/rus${PORTNAME}/${PORTNAME}-stable/${PORTNAME}%20${PORTVERSION}ds
PKGNAMESUFFIX= -ds
diff --git a/news/fidogate-ds/pkg-plist b/news/fidogate-ds/pkg-plist
index a9cb7dcf4c54..b7dc4edf3124 100644
--- a/news/fidogate-ds/pkg-plist
+++ b/news/fidogate-ds/pkg-plist
@@ -129,27 +129,27 @@ var/fidogate/fareas.bbs.sample
@dirrm etc/fido
@dirrm libexec/fidogate
@dirrm lib/fidogate
-@unexec rmdir >/dev/null 2>&1 %%SPOOLDIR%%/toss/toss || true
-@unexec rmdir >/dev/null 2>&1 %%SPOOLDIR%%/toss/route || true
-@unexec rmdir >/dev/null 2>&1 %%SPOOLDIR%%/toss/pack || true
-@unexec rmdir >/dev/null 2>&1 %%SPOOLDIR%%/toss/bad || true
-@unexec rmdir >/dev/null 2>&1 %%SPOOLDIR%%/toss || true
-@unexec rmdir >/dev/null 2>&1 %%SPOOLDIR%%/outrfc/news || true
-@unexec rmdir >/dev/null 2>&1 %%SPOOLDIR%%/outrfc/mail || true
-@unexec rmdir >/dev/null 2>&1 %%SPOOLDIR%%/outrfc || true
-@unexec rmdir >/dev/null 2>&1 %%SPOOLDIR%%/outpkt/news || true
-@unexec rmdir >/dev/null 2>&1 %%SPOOLDIR%%/outpkt/mail || true
-@unexec rmdir >/dev/null 2>&1 %%SPOOLDIR%%/outpkt || true
-@unexec rmdir >/dev/null 2>&1 %%SPOOLDIR%% || true
-@unexec rmdir >/dev/null 2>&1 %%BTBASEDIR%%/tick || true
-@unexec rmdir >/dev/null 2>&1 %%BTBASEDIR%%/pin/tmpunpack || true
-@unexec rmdir >/dev/null 2>&1 %%BTBASEDIR%%/pin/bad || true
-@unexec rmdir >/dev/null 2>&1 %%BTBASEDIR%%/pin || true
-@unexec rmdir >/dev/null 2>&1 %%BTBASEDIR%%/in/tmpunpack || true
-@unexec rmdir >/dev/null 2>&1 %%BTBASEDIR%%/in/bad || true
-@unexec rmdir >/dev/null 2>&1 %%BTBASEDIR%%/in || true
-@unexec rmdir >/dev/null 2>&1 %%BTBASEDIR%% || true
-@unexec rmdir >/dev/null 2>&1 /var/spool/fido || true
-@unexec rmdir >/dev/null 2>&1 %%LOCKDIR%% || true
-@unexec rmdir >/dev/null 2>&1 %%LOGDIR%% || true
-@unexec rmdir >/dev/null 2>&1 /var/log/fido || true
+@unexec rmdir "%%SPOOLDIR%%/toss/toss" >/dev/null 2>&1 || :
+@unexec rmdir "%%SPOOLDIR%%/toss/route" >/dev/null 2>&1 || :
+@unexec rmdir "%%SPOOLDIR%%/toss/pack" >/dev/null 2>&1 || :
+@unexec rmdir "%%SPOOLDIR%%/toss/bad" >/dev/null 2>&1 || :
+@unexec rmdir "%%SPOOLDIR%%/toss" >/dev/null 2>&1 || :
+@unexec rmdir "%%SPOOLDIR%%/outrfc/news" >/dev/null 2>&1 || :
+@unexec rmdir "%%SPOOLDIR%%/outrfc/mail" >/dev/null 2>&1 || :
+@unexec rmdir "%%SPOOLDIR%%/outrfc" >/dev/null 2>&1 || :
+@unexec rmdir "%%SPOOLDIR%%/outpkt/news" >/dev/null 2>&1 || :
+@unexec rmdir "%%SPOOLDIR%%/outpkt/mail" >/dev/null 2>&1 || :
+@unexec rmdir "%%SPOOLDIR%%/outpkt" >/dev/null 2>&1 || :
+@unexec rmdir "%%SPOOLDIR%%" >/dev/null 2>&1 || :
+@unexec rmdir "%%BTBASEDIR%%/tick" >/dev/null 2>&1 || :
+@unexec rmdir "%%BTBASEDIR%%/pin/tmpunpack" >/dev/null 2>&1 || :
+@unexec rmdir "%%BTBASEDIR%%/pin/bad" >/dev/null 2>&1 || :
+@unexec rmdir "%%BTBASEDIR%%/pin" >/dev/null 2>&1 || :
+@unexec rmdir "%%BTBASEDIR%%/in/tmpunpack" >/dev/null 2>&1 || :
+@unexec rmdir "%%BTBASEDIR%%/in/bad" >/dev/null 2>&1 || :
+@unexec rmdir "%%BTBASEDIR%%/in" >/dev/null 2>&1 || :
+@unexec rmdir "%%BTBASEDIR%%" >/dev/null 2>&1 || :
+@unexec rmdir "/var/spool/fido" >/dev/null 2>&1 || :
+@unexec rmdir "%%LOCKDIR%%" >/dev/null 2>&1 || :
+@unexec rmdir "%%LOGDIR%%" >/dev/null 2>&1 || :
+@unexec rmdir "/var/log/fido" >/dev/null 2>&1 || :