aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-10-16 01:31:58 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-10-16 01:31:58 +0000
commitefd3830f38faa0eca31dabfbd2ce708b6c45263a (patch)
tree21a9b604b8e8633c1a971091f247a7384581af5e /news
parentee35d188a209aa8ccacf3f483fb7c0bd1d5e84c2 (diff)
downloadports-efd3830f38faa0eca31dabfbd2ce708b6c45263a.tar.gz
ports-efd3830f38faa0eca31dabfbd2ce708b6c45263a.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/newsfetch/Makefile8
-rw-r--r--news/nn/Makefile10
2 files changed, 16 insertions, 2 deletions
diff --git a/news/newsfetch/Makefile b/news/newsfetch/Makefile
index 0eac93810f6e..d0c3f040535a 100644
--- a/news/newsfetch/Makefile
+++ b/news/newsfetch/Makefile
@@ -20,6 +20,12 @@ MAKE_ENV= BINDIR="${PREFIX}/bin" MANDIR="${PREFIX}/man/man"
MAN1= newsfetch.1
MANCOMPRESSED= maybe
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
do-configure:
cd ${WRKSRC} && ( \
${ECHO_CMD} "PROG= newsfetch"; \
@@ -27,4 +33,4 @@ do-configure:
${ECHO_CMD} ".include <bsd.prog.mk>"; \
) > Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/news/nn/Makefile b/news/nn/Makefile
index 881d1fd9c0e4..3e33c1b09b30 100644
--- a/news/nn/Makefile
+++ b/news/nn/Makefile
@@ -16,10 +16,18 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= jooji@nickelkid.com
COMMENT= Newsreader
+USE_GMAKE= yes
+
MAN1= nn.1 nncheck.1 nngoback.1 nngrab.1 nngrep.1 nnpost.1 \
nntidy.1 nnview.1 nnacct.1m nnadmin.1m nnstats.1m nnusage.1m
MAN8= nnmaster.8 nnspew.8
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
pre-patch:
@${CP} ${WRKSRC}/config.h-dist ${WRKSRC}/config.h.unparsed
@@ -30,4 +38,4 @@ pre-build:
post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${DISTNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>