aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-27 11:12:27 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-27 11:12:27 +0000
commitd451e40da1f65e894b3b821623b673caf6938792 (patch)
treeb7bfaeb300850741dd1570dbd8121af8d9d9c300 /news
parent47fe60af4d088ae8795ca45fc194ce80638ac985 (diff)
downloadports-d451e40da1f65e894b3b821623b673caf6938792.tar.gz
ports-d451e40da1f65e894b3b821623b673caf6938792.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/newspost/Makefile37
-rw-r--r--news/newspost/pkg-descr5
-rw-r--r--news/newspost/pkg-plist3
3 files changed, 24 insertions, 21 deletions
diff --git a/news/newspost/Makefile b/news/newspost/Makefile
index 54875ae7a63c..6443872c8b2d 100644
--- a/news/newspost/Makefile
+++ b/news/newspost/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: newspost
-# Date created: Tue Jul 23, 2002
-# Whom: Michael L. Hostbaek (mich@freebsdcluster.org)
-#
+# Created by: Michael L. Hostbaek <mich@freebsdcluster.org>
# $FreeBSD$
-#
PORTNAME= newspost
PORTVERSION= 2.1.1
@@ -13,20 +8,32 @@ CATEGORIES= news
MASTER_SITES= http://newspost.unixcab.org/download/
MAINTAINER= mich@FreeBSD.org
-COMMENT= Newspost is a full-featured USEnet binary autoposter
+COMMENT= Full-featured Usenet binary autoposter
+
+LICENSE= GPLv2
ALL_TARGET= main
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
- ${INSTALL_MAN} ${WRKSRC}/man/man1/newspost.1 ${PREFIX}/man/man1
+MAN1= ${PORTNAME}.1
+PORTDOCS= README
+PLIST_FILES= bin/${PORTNAME}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
-.endif
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
-MAN1= newspost.1
+# Change "cd foo; $(MAKE)" into "$(MAKE) -C foo" to unbreak parallel builds
+post-patch:
+ @${REINPLACE_CMD} -E 's|cd(.+) ; (\$$\(MAKE\))|\2 -C\1|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/man1/${MAN1} ${MANPREFIX}/man/man1
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/news/newspost/pkg-descr b/news/newspost/pkg-descr
index 935a6bf586c2..babd0e8fca25 100644
--- a/news/newspost/pkg-descr
+++ b/news/newspost/pkg-descr
@@ -1,6 +1,5 @@
-Newspost is a full-featured USEnet binary autoposter. It is meant as
-an all-in-one posting solution. In addition to posting files, it can
+Newspost is a full-featured Usenet binary autoposter. It is meant as
+an all-in-one posting solution. In addition to posting files, it can
post text prefixes, and generate and post .SFV files and .PAR volumes.
-Author: Jim Faulkner <newspost@unixcab.org>
WWW: http://newspost.unixcab.org/
diff --git a/news/newspost/pkg-plist b/news/newspost/pkg-plist
deleted file mode 100644
index 68af27ea4bb4..000000000000
--- a/news/newspost/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/newspost
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%