aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-04-18 10:28:54 +0000
committerJohn Marino <marino@FreeBSD.org>2015-04-18 10:28:54 +0000
commit48c90ce9d46613fd731beac381f11dc7c530914b (patch)
tree949410edc53adfac4f2f04d8ae91510d643ae56a /news
parent572692c9f68b6db8ec3c587b6cdc5acdc6d12400 (diff)
downloadports-48c90ce9d46613fd731beac381f11dc7c530914b.tar.gz
ports-48c90ce9d46613fd731beac381f11dc7c530914b.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/husky-fidoconf/Makefile19
-rw-r--r--news/husky-fidoconf/pkg-plist34
-rw-r--r--news/husky/Makefile.local5
3 files changed, 35 insertions, 23 deletions
diff --git a/news/husky-fidoconf/Makefile b/news/husky-fidoconf/Makefile
index a0abd5bf530b..de2b8139e516 100644
--- a/news/husky-fidoconf/Makefile
+++ b/news/husky-fidoconf/Makefile
@@ -8,7 +8,7 @@ COMMENT= Husky FTN configuration library
LIB_DEPENDS= libsmapi.so:${PORTSDIR}/news/husky-smapi
-USES+= perl5 shebangfix makeinfo
+USES+= perl5 shebangfix
SHEBANG_FILES= util/fconf2areasbbs.pl util/fconf2na.pl util/sq2fc.pl
USE_LDCONFIG= yes
INSTALL_TARGET= install install-man
@@ -16,10 +16,25 @@ INSTALL_TARGET= install install-man
MASTERDIR= ${.CURDIR}/../husky
COMPONENT_SUBDIR= fidoconf
+.include <bsd.port.pre.mk>
+
post-patch:
${REINPLACE_CMD} -e 's^/path/to/config^${PREFIX}/etc/fido/config^' \
${WRKSRC}/man/linkedto.1
+# The texi files are too old for the ports texinfo
+# The correct fix is to update the texi file so modern texinfo can use it
+# Until then, disable installation of info page on FreeBSD 11 and DragonFly
+# to unbreak the build on those platforms.
+.if ${OPSYS} == DragonFly || (${OPSYS} == FreeBSD && ${OSVERSION} > 1100000)
+ ${REINPLACE_CMD} -e '/cd doc /d' ${WRKSRC}/Makefile
+.else
+USES+= makeinfo
+PORTDOCS= fidoconfig.html
+DOCSDIR= ${PREFIX}/share/doc/husky
+INFO= fidoconfig
+.endif
+
post-install:
${LN} -sf fconf2.1 ${STAGEDIR}${PREFIX}/man/man1/fconf2aquaed.1
${LN} -sf fconf2.1 ${STAGEDIR}${PREFIX}/man/man1/fconf2areasbbs.1
@@ -33,4 +48,4 @@ post-install:
${LN} -sf fconf2.1 ${STAGEDIR}${PREFIX}/man/man1/fconf2tornado.1
${LN} -sf fconf2.1 ${STAGEDIR}${PREFIX}/man/man1/fecfg2fconf.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/news/husky-fidoconf/pkg-plist b/news/husky-fidoconf/pkg-plist
index 9149ff6fe2e8..309cffae4c5d 100644
--- a/news/husky-fidoconf/pkg-plist
+++ b/news/husky-fidoconf/pkg-plist
@@ -22,24 +22,22 @@ include/fidoconf/findtok.h
include/fidoconf/grptree.h
include/fidoconf/stat.h
include/fidoconf/version.h
-%%PORTDOCS%%info/fidoconfig.info
lib/libfidoconfig.a
lib/libfidoconfig.so
lib/libfidoconfig.so.1
-%%PORTDOCS%%man/man1/dumpfcfg.1.gz
-%%PORTDOCS%%man/man1/fconf2.1.gz
-%%PORTDOCS%%man/man1/fconf2aquaed.1.gz
-%%PORTDOCS%%man/man1/fconf2areasbbs.1.gz
-%%PORTDOCS%%man/man1/fconf2binkd.1.gz
-%%PORTDOCS%%man/man1/fconf2dir.1.gz
-%%PORTDOCS%%man/man1/fconf2fidogate.1.gz
-%%PORTDOCS%%man/man1/fconf2golded.1.gz
-%%PORTDOCS%%man/man1/fconf2msged.1.gz
-%%PORTDOCS%%man/man1/fconf2na.pl.1.gz
-%%PORTDOCS%%man/man1/fconf2squish.1.gz
-%%PORTDOCS%%man/man1/fconf2tornado.1.gz
-%%PORTDOCS%%man/man1/fecfg2fconf.1.gz
-%%PORTDOCS%%man/man1/linked.1.gz
-%%PORTDOCS%%man/man1/linkedto.1.gz
-%%PORTDOCS%%man/man1/tparser.1.gz
-%%PORTDOCS%%share/doc/husky/fidoconfig.html
+man/man1/dumpfcfg.1.gz
+man/man1/fconf2.1.gz
+man/man1/fconf2aquaed.1.gz
+man/man1/fconf2areasbbs.1.gz
+man/man1/fconf2binkd.1.gz
+man/man1/fconf2dir.1.gz
+man/man1/fconf2fidogate.1.gz
+man/man1/fconf2golded.1.gz
+man/man1/fconf2msged.1.gz
+man/man1/fconf2na.pl.1.gz
+man/man1/fconf2squish.1.gz
+man/man1/fconf2tornado.1.gz
+man/man1/fecfg2fconf.1.gz
+man/man1/linked.1.gz
+man/man1/linkedto.1.gz
+man/man1/tparser.1.gz
diff --git a/news/husky/Makefile.local b/news/husky/Makefile.local
index 785edfb828fe..1901131c9361 100644
--- a/news/husky/Makefile.local
+++ b/news/husky/Makefile.local
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTVERSION= 1.9.20140519
+PORTREVISION= 1
CATEGORIES= news mail
-PKGNAMESUFFIX= -devel
.if ${PORTNAME} == "husky-smapi"
PORTEPOCH= 1
@@ -14,7 +14,6 @@ MAINTAINER= osharoiko@gmail.com
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= husky/husky/1.9-current/2014.05.19
DISTNAME= husky-all-1.9-source-20140519
-EXTRACT_SUFX= .tgz
HUSKY_ROOTDIR= ${WRKDIR}/husky
PATCH_WRKSRC= ${HUSKY_ROOTDIR}
@@ -26,7 +25,7 @@ CONFLICTS= ${PORTNAME}-[0-9]*
USERS= fido
GROUPS= fido
-USES+= alias gmake
+USES+= alias gmake tar:tgz
pre-build:
${LN} -sf ${HUSKY_ROOTDIR}/huskybse/huskymak.cfg ${HUSKY_ROOTDIR}