aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /news
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/grn/Makefile7
-rw-r--r--news/klibido/Makefile6
-rw-r--r--news/newscache/Makefile4
-rw-r--r--news/newsstar/Makefile4
-rw-r--r--news/newsx/Makefile2
-rw-r--r--news/nntpcache/Makefile1
-rw-r--r--news/noffle/Makefile4
-rw-r--r--news/nzbget/Makefile7
-rw-r--r--news/pan/Makefile2
-rw-r--r--news/s-news/Makefile4
-rw-r--r--news/suck/Makefile1
-rw-r--r--news/tin/Makefile2
-rw-r--r--news/yencode/Makefile5
13 files changed, 24 insertions, 25 deletions
diff --git a/news/grn/Makefile b/news/grn/Makefile
index 91c959984101..1cd3b1a1d4bd 100644
--- a/news/grn/Makefile
+++ b/news/grn/Makefile
@@ -20,9 +20,10 @@ USE_GNOME= gnomehack gnomelibs gnomeprefix
USE_GMAKE= yes
GNU_CONFIGURE= yes
LIBTOOLFILES= configure libmutt/configure
-CONFIGURE_ENV= glibpath="${GLIB_CONFIG}" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= glibpath="${GLIB_CONFIG}"
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
diff --git a/news/klibido/Makefile b/news/klibido/Makefile
index 93a4f55cd8f2..b36a8eb6bc65 100644
--- a/news/klibido/Makefile
+++ b/news/klibido/Makefile
@@ -23,9 +23,9 @@ USE_AUTOTOOLS= libtool
INSTALLS_ICONS= yes
USE_GETTEXT= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include/db44 ${PTHREAD_CFLAGS}" \
- CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include/db44" \
- LDFLAGS="-L${LOCALBASE}/lib/db44 ${PTHREAD_LIBS}"
+LDFLAGS+= -L${LOCALBASE}/lib/db44 ${PTHREAD_LIBS}
+CFLAGS+= -I${LOCALBASE}/include/db44 ${PTHREAD_CFLAGS}
+CXXFLAGS+= -I${LOCALBASE}/include/db44
post-install:
.if defined(NOPORTDOCS)
diff --git a/news/newscache/Makefile b/news/newscache/Makefile
index e52315b52704..c8b1b0413830 100644
--- a/news/newscache/Makefile
+++ b/news/newscache/Makefile
@@ -19,8 +19,8 @@ LIB_DEPENDS= socket[+][+].1:${PORTSDIR}/net/libsocket++
USE_AUTOTOOLS= automake autoheader autoconf
AUTOMAKE_ARGS= --add-missing
-CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CPPFLAGS+= ${CFLAGS} -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc
USE_RC_SUBR= ${PORTNAME}.sh
diff --git a/news/newsstar/Makefile b/news/newsstar/Makefile
index f94781a2e5a5..cfe52f6f4ff8 100644
--- a/news/newsstar/Makefile
+++ b/news/newsstar/Makefile
@@ -30,8 +30,8 @@ CONFIGURE_ARGS+=--prefix=${PREFIX} \
--with-rc-dir=/var/spool/newsstar/lib \
--with-incoming-dir=/var/spool/newsstar/incoming
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
.if defined(NOPORTDOCS)
INSTALL_TARGET= install-am
diff --git a/news/newsx/Makefile b/news/newsx/Makefile
index 57bf1fb90338..c79fe136cb8c 100644
--- a/news/newsx/Makefile
+++ b/news/newsx/Makefile
@@ -30,7 +30,7 @@ CONFLICTS= leafnode-1.9.*
.if !defined(WITH_CNEWS)
.if !defined(WITHOUT_INN_2-X)
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/news/include"
+CPPFLAGS+= -I${LOCALBASE}/news/include
.endif
.endif
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index 23f772c242eb..fbb01f6fbe6d 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -45,7 +45,6 @@ CONFIGURE_ARGS+= --with-authinfo-ldap
CPPFLAGS+= -I${PREFIX}/include -I${LOCALBASE}/include
LDFLAGS+= -L${PREFIX}/lib -L${LOCALBASE}/lib
AUTHINFO_EXT+= authinfo_ldap.ext
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.endif
CONFIGURE_ARGS+= --program-transform-name=''
diff --git a/news/noffle/Makefile b/news/noffle/Makefile
index 8b624e38505b..821593515152 100644
--- a/news/noffle/Makefile
+++ b/news/noffle/Makefile
@@ -20,8 +20,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-configfile=${LOCALBASE}/etc/noffle.conf \
--with-usersfile=${LOCALBASE}/etc/noffle.users
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
SPOOL_DIR= /var/spool/noffle
PLIST_SUB+= SPOOL_DIR=${SPOOL_DIR}
diff --git a/news/nzbget/Makefile b/news/nzbget/Makefile
index 91ef8271b29f..9891cc999918 100644
--- a/news/nzbget/Makefile
+++ b/news/nzbget/Makefile
@@ -21,9 +21,10 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
sigc-2:${PORTSDIR}/devel/libsigc++20
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}" \
- LOCALBASE="${LOCALBASE}"
+CONFIGURE_ENV= LOCALBASE="${LOCALBASE}"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= ${PTHREAD_LIBS}
+CFLAGS+= ${PTHREAD_CFLAGS}
USE_GMAKE= yes
OPTIONS= PARCHECK "Enable autopar/parcheck (Requires libpar2)" On
diff --git a/news/pan/Makefile b/news/pan/Makefile
index 394e79896abd..514c37dce260 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -26,7 +26,7 @@ USE_GNOME= gnomehack intlhack
USE_GETTEXT= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lgnuregex"
+LDFLAGS+= -L${LOCALBASE}/lib -lgnuregex
OPTIONS= GTKSPELL "Enable spell checking support (gtk+2 only)" on \
GTK3 "Build with gtk+3 based UI instead of gtk+2" off
diff --git a/news/s-news/Makefile b/news/s-news/Makefile
index 267f868b8b45..77833b2b5079 100644
--- a/news/s-news/Makefile
+++ b/news/s-news/Makefile
@@ -21,8 +21,8 @@ CONFLICTS= nntp-[0-9]*
CONFIGURE_ARGS= --prefix=${PREFIX} \
--with-confdir=${PREFIX}/etc/s-news \
--with-spooldir=/var/spool/s-news
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
USE_GMAKE= yes
HAS_CONFIGURE= yes
diff --git a/news/suck/Makefile b/news/suck/Makefile
index aa7bf9c5f2e1..d44085e96879 100644
--- a/news/suck/Makefile
+++ b/news/suck/Makefile
@@ -26,7 +26,6 @@ EX_SCRIPTS= get.news.generic get.news.inn perl_kill.pl perl_xover.pl \
post_filter.pl put.news put.news.pl put.news.sm put.news.sm.pl
EX_DATA= suckkillfile.sample sucknewsrc.sample suckothermsgs.sample
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
MAKE_ENV+= CHKHISTORY=chkhistory_db.o
.if defined(NEWSBIN) && !defined(SUCK_WITH_INN)
diff --git a/news/tin/Makefile b/news/tin/Makefile
index 348a01668b1d..27b20e679f5e 100644
--- a/news/tin/Makefile
+++ b/news/tin/Makefile
@@ -65,7 +65,7 @@ CONFIGURE_ARGS+=--with-nntp-default-server=news \
MAKE_ARGS+= MAKE=${GMAKE}
CFLAGS+= -DNNTP_SERVER_FILE=\\\"${PREFIX}/etc/nntpserver\\\"
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV= LDFLAGS='${LDFLAGS} -L${LOCALBASE}/lib'
+LDFLAGS+= -L${LOCALBASE}/lib
ALL_TARGET= build
MAN1= tin.1 w2r.pl.1 opt-case.pl.1 tinews.pl.1 tinurl_handler.pl.1
MAN5= tin.5 tin_mbox.5 tin_mmdf.5
diff --git a/news/yencode/Makefile b/news/yencode/Makefile
index 8496462fc5f2..7e5d2a8b3204 100644
--- a/news/yencode/Makefile
+++ b/news/yencode/Makefile
@@ -17,12 +17,11 @@ COMMENT= A free (GPL) encoder and decoder for the yEnc Usenet file format
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= ydecode.1 yencode.1 ypost.1
MAN5= ypostrc.5
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.mk>