aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-06-13 22:59:07 +0000
committerAde Lovett <ade@FreeBSD.org>2000-06-13 22:59:07 +0000
commit4e5bcedf20fd2605ca371da020895676a0eb992a (patch)
tree16856594535903d87774f41c842264db8184e4db /news
parent6ab55061a774747ae8a4470fa9530fc5179c55f7 (diff)
downloadports-4e5bcedf20fd2605ca371da020895676a0eb992a.tar.gz
ports-4e5bcedf20fd2605ca371da020895676a0eb992a.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/pan/Makefile6
-rw-r--r--news/pan/files/patch-ag13
-rw-r--r--news/pan/files/patch-ah26
-rw-r--r--news/pan2/Makefile6
-rw-r--r--news/pan2/files/patch-ag13
-rw-r--r--news/pan2/files/patch-ah26
6 files changed, 70 insertions, 20 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index 144afe9f17da..57ba8ad139e9 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -12,7 +12,9 @@ MASTER_SITES= ftp://source.rebelbase.com/pub/pan/${PORTVERSION}/
MAINTAINER= ade@FreeBSD.org
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ gnomeprint.9:${PORTSDIR}/print/gnomeprint \
+ uu.1:${PORTSDIR}/converters/uulib
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
@@ -25,6 +27,6 @@ CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GLIB_CONFIG="${GLIB_CONFIG}" \
GTK_CONFIG="${GTK_CONFIG}" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib -luu"
.include <bsd.port.mk>
diff --git a/news/pan/files/patch-ag b/news/pan/files/patch-ag
index a66ebdeae8fe..2da6709bc5d3 100644
--- a/news/pan/files/patch-ag
+++ b/news/pan/files/patch-ag
@@ -1,8 +1,13 @@
---- Makefile.in.orig Mon May 1 22:44:54 2000
-+++ Makefile.in Wed May 3 14:44:53 2000
-@@ -110,7 +110,7 @@
+--- Makefile.in.orig Thu May 18 02:27:35 2000
++++ Makefile.in Tue Jun 13 17:15:02 2000
+@@ -111,11 +111,11 @@
+ cxxflags_set = @cxxflags_set@
+ l = @l@
- EXTRA_DIST = autogen.sh CREDITS ChangeLog pan.desktop pan.spec pan.png
+-SUBDIRS = macros po intl uulib pan docs
++SUBDIRS = macros po intl pan docs
+
+ EXTRA_DIST = CREDITS ChangeLog pan.desktop pan.spec pan.png
-Productivitydir = $(datadir)/gnome/apps/Internet
+Productivitydir = $(datadir)/apps/Internet
diff --git a/news/pan/files/patch-ah b/news/pan/files/patch-ah
index 7cef68e0faa7..30528e35151a 100644
--- a/news/pan/files/patch-ah
+++ b/news/pan/files/patch-ah
@@ -1,11 +1,29 @@
---- pan/Makefile.in.orig Tue May 9 13:27:56 2000
-+++ pan/Makefile.in Tue May 16 17:44:07 2000
-@@ -116,7 +116,7 @@
+--- pan/Makefile.in.orig Thu May 18 02:27:48 2000
++++ pan/Makefile.in Tue Jun 13 17:07:18 2000
+@@ -115,7 +115,7 @@
SUBDIRS = dialogs xpm
-INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/uulib -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -DLOCALEDIR=\"$(datadir)/locale\" $(GNOME_INCLUDEDIR) $(GLIB_CFLAGS) @CPPFLAGS@
-+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/uulib -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DLOCALEDIR=\"$(prefix)/share/locale\" $(GNOME_INCLUDEDIR) $(GLIB_CFLAGS) @CPPFLAGS@
++INCLUDES = -I$(top_srcdir) -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DLOCALEDIR=\"$(prefix)/share/locale\" $(GNOME_INCLUDEDIR) $(GLIB_CFLAGS) @CPPFLAGS@
bin_PROGRAMS = pan
+@@ -123,7 +123,7 @@
+ pan_SOURCES = acache.c acache.h article.c article.h article-toolbar.c article-toolbar.h article-find.c article-find.h article-db.c article-db.h article-thread.c article-thread.h articlelist.c articlelist.h date.c date.h debug.c debug.h decode.c decode.h folder.c folder.h folderlist.c folderlist.h fnmatch.c fnmatch.h globals.h group.c group.h grouplist.c grouplist.h gui.c gui.h gui-notebook.c gui-notebook.h gui-paned.c gui-paned.h log.c log.h message.c message.h message-filter.c message-filter.h message-send.c message-send.h message-window.c message-window.h msort.c nntp.c nntp.h pan.c pan.h pan-callback.c pan-callback.h pan-db.c pan-db.h pan-object.c pan-object.h prefs.c prefs.h print.c print.h queue.c queue.h task.c task.h task-bodies.c task-bodies.h task-body.c task-body.h task-decode.c task-decode.h task-grouplist.c task-grouplist.h task-headers.c task-headers.h task-send.c task-send.h task-manager.c task-manager.h rfc822.c rfc822.h save.c save.h server.c server.h smtp.c smtp.h sockets.c sockets.h status-item.c status-item.h status-item-view.c status-item-view.h text.c text.h util.c util.h
+
+
+-pan_LDADD = dialogs/libdialogs.a $(INTLLIBS) $(GNOMEUI_LIBS) $(GNOME_LIBDIR) $(GLIB_LIBS) $(top_builddir)/uulib/libuu.a
++pan_LDADD = dialogs/libdialogs.a $(INTLLIBS) $(GNOMEUI_LIBS) $(GNOME_LIBDIR) $(GLIB_LIBS)
+
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+@@ -144,7 +144,7 @@
+ task-body.o task-decode.o task-grouplist.o task-headers.o task-send.o \
+ task-manager.o rfc822.o save.o server.o smtp.o sockets.o status-item.o \
+ status-item-view.o text.o util.o
+-pan_DEPENDENCIES = dialogs/libdialogs.a $(top_builddir)/uulib/libuu.a
++pan_DEPENDENCIES = dialogs/libdialogs.a
+ pan_LDFLAGS =
+ CFLAGS = @CFLAGS@
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
diff --git a/news/pan2/Makefile b/news/pan2/Makefile
index 144afe9f17da..57ba8ad139e9 100644
--- a/news/pan2/Makefile
+++ b/news/pan2/Makefile
@@ -12,7 +12,9 @@ MASTER_SITES= ftp://source.rebelbase.com/pub/pan/${PORTVERSION}/
MAINTAINER= ade@FreeBSD.org
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ gnomeprint.9:${PORTSDIR}/print/gnomeprint \
+ uu.1:${PORTSDIR}/converters/uulib
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
@@ -25,6 +27,6 @@ CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GLIB_CONFIG="${GLIB_CONFIG}" \
GTK_CONFIG="${GTK_CONFIG}" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib -luu"
.include <bsd.port.mk>
diff --git a/news/pan2/files/patch-ag b/news/pan2/files/patch-ag
index a66ebdeae8fe..2da6709bc5d3 100644
--- a/news/pan2/files/patch-ag
+++ b/news/pan2/files/patch-ag
@@ -1,8 +1,13 @@
---- Makefile.in.orig Mon May 1 22:44:54 2000
-+++ Makefile.in Wed May 3 14:44:53 2000
-@@ -110,7 +110,7 @@
+--- Makefile.in.orig Thu May 18 02:27:35 2000
++++ Makefile.in Tue Jun 13 17:15:02 2000
+@@ -111,11 +111,11 @@
+ cxxflags_set = @cxxflags_set@
+ l = @l@
- EXTRA_DIST = autogen.sh CREDITS ChangeLog pan.desktop pan.spec pan.png
+-SUBDIRS = macros po intl uulib pan docs
++SUBDIRS = macros po intl pan docs
+
+ EXTRA_DIST = CREDITS ChangeLog pan.desktop pan.spec pan.png
-Productivitydir = $(datadir)/gnome/apps/Internet
+Productivitydir = $(datadir)/apps/Internet
diff --git a/news/pan2/files/patch-ah b/news/pan2/files/patch-ah
index 7cef68e0faa7..30528e35151a 100644
--- a/news/pan2/files/patch-ah
+++ b/news/pan2/files/patch-ah
@@ -1,11 +1,29 @@
---- pan/Makefile.in.orig Tue May 9 13:27:56 2000
-+++ pan/Makefile.in Tue May 16 17:44:07 2000
-@@ -116,7 +116,7 @@
+--- pan/Makefile.in.orig Thu May 18 02:27:48 2000
++++ pan/Makefile.in Tue Jun 13 17:07:18 2000
+@@ -115,7 +115,7 @@
SUBDIRS = dialogs xpm
-INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/uulib -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -DLOCALEDIR=\"$(datadir)/locale\" $(GNOME_INCLUDEDIR) $(GLIB_CFLAGS) @CPPFLAGS@
-+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/uulib -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DLOCALEDIR=\"$(prefix)/share/locale\" $(GNOME_INCLUDEDIR) $(GLIB_CFLAGS) @CPPFLAGS@
++INCLUDES = -I$(top_srcdir) -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DLOCALEDIR=\"$(prefix)/share/locale\" $(GNOME_INCLUDEDIR) $(GLIB_CFLAGS) @CPPFLAGS@
bin_PROGRAMS = pan
+@@ -123,7 +123,7 @@
+ pan_SOURCES = acache.c acache.h article.c article.h article-toolbar.c article-toolbar.h article-find.c article-find.h article-db.c article-db.h article-thread.c article-thread.h articlelist.c articlelist.h date.c date.h debug.c debug.h decode.c decode.h folder.c folder.h folderlist.c folderlist.h fnmatch.c fnmatch.h globals.h group.c group.h grouplist.c grouplist.h gui.c gui.h gui-notebook.c gui-notebook.h gui-paned.c gui-paned.h log.c log.h message.c message.h message-filter.c message-filter.h message-send.c message-send.h message-window.c message-window.h msort.c nntp.c nntp.h pan.c pan.h pan-callback.c pan-callback.h pan-db.c pan-db.h pan-object.c pan-object.h prefs.c prefs.h print.c print.h queue.c queue.h task.c task.h task-bodies.c task-bodies.h task-body.c task-body.h task-decode.c task-decode.h task-grouplist.c task-grouplist.h task-headers.c task-headers.h task-send.c task-send.h task-manager.c task-manager.h rfc822.c rfc822.h save.c save.h server.c server.h smtp.c smtp.h sockets.c sockets.h status-item.c status-item.h status-item-view.c status-item-view.h text.c text.h util.c util.h
+
+
+-pan_LDADD = dialogs/libdialogs.a $(INTLLIBS) $(GNOMEUI_LIBS) $(GNOME_LIBDIR) $(GLIB_LIBS) $(top_builddir)/uulib/libuu.a
++pan_LDADD = dialogs/libdialogs.a $(INTLLIBS) $(GNOMEUI_LIBS) $(GNOME_LIBDIR) $(GLIB_LIBS)
+
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+@@ -144,7 +144,7 @@
+ task-body.o task-decode.o task-grouplist.o task-headers.o task-send.o \
+ task-manager.o rfc822.o save.o server.o smtp.o sockets.o status-item.o \
+ status-item-view.o text.o util.o
+-pan_DEPENDENCIES = dialogs/libdialogs.a $(top_builddir)/uulib/libuu.a
++pan_DEPENDENCIES = dialogs/libdialogs.a
+ pan_LDFLAGS =
+ CFLAGS = @CFLAGS@
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)