aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-10 16:24:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-10 16:24:05 +0000
commitdf06cc9690fefe6987fa3ef8767f3c5bfd31c2a7 (patch)
tree8bc85a5a06d17ce9235fd4d3a71f8fd15e83e613 /news
parent529a360cf0ff1a24a3836f69400744f2a2771d06 (diff)
downloadports-df06cc9690fefe6987fa3ef8767f3c5bfd31c2a7.tar.gz
ports-df06cc9690fefe6987fa3ef8767f3c5bfd31c2a7.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/nntpcache/Makefile23
-rw-r--r--news/py-pynzb/Makefile15
2 files changed, 16 insertions, 22 deletions
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index fbb01f6fbe6d..74f99f4b3cd6 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: nntpcache
-# Date created: 6 January 1997
-# Whom: proff@suburbia.net
-#
+# Created by: proff@suburbia.net
# $FreeBSD$
-#
PORTNAME= nntpcache
PORTVERSION= 3.0.2
@@ -28,18 +24,17 @@ CONFIGURE_ARGS= --localstatedir=${SPOOLDIR}
AUTHINFO_EXT= authinfo_pam.ext
USE_RC_SUBR= nntpcached
-OPTIONS= LDAP "OpenLDAP support" off \
- RADIUS "RADIUS support" off \
- SPAMPHOBIA "Spamphobia NoCeM support" off
+OPTIONS_DEFINE= LDAP RADIUS SPAMPHOBIA
+SPAMPHOBIA_DESC= Spamphobia NoCeM support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_RADIUS)
+.if ${PORT_OPTIONS:MRADIUS}
CONFIGURE_ARGS+= --with-authinfo-radius
AUTHINFO_EXT+= authinfo_radius.ext
.endif
-.if defined(WITH_LDAP) || defined(WITH_LDAP2)
+.if ${PORT_OPTIONS:MLDAP) || defined(WITH_LDAP2}
USE_OPENLDAP= yes
CONFIGURE_ARGS+= --with-authinfo-ldap
CPPFLAGS+= -I${PREFIX}/include -I${LOCALBASE}/include
@@ -55,7 +50,7 @@ MAN8= nntpcached.8 newshound.8
PORTDOCS= AUTHORS ChangeLog FAQ FAQ.html HACKING HTML \
INSTALL LICENSING NEWS README README.INN VERSION
-.if defined(WITH_SPAMPHOBIA)
+.if ${PORT_OPTIONS:MSPAMPHOBIA}
REVISEDATE= 20060903
PATCH_SITES+= http://people.freebsd.org/~leeym/:SPAMPHOBIA
PATCHFILES+= ${DISTNAME}-spamphobia-${REVISEDATE}.diff.gz:SPAMPHOBIA
@@ -69,10 +64,10 @@ post-install:
@ ${CP} ${PREFIX}/etc/${PORTNAME}/VERSION ${NNTPSPOOLDIR} && \
${CHMOD} 640 ${NNTPSPOOLDIR}/VERSION
@ ${CHOWN} -R news:news ${NNTPSPOOLDIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@ ${MKDIR} ${DOCSDIR}
@ cd ${WRKSRC} && ${FIND} ${PORTDOCS} \
| ${CPIO_CMD} ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/news/py-pynzb/Makefile b/news/py-pynzb/Makefile
index f8b676568474..56b3a81a5e6f 100644
--- a/news/py-pynzb/Makefile
+++ b/news/py-pynzb/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: pynzb
-# Date created: Wed Apr 7 13:06:51 UTC 2010
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
# $FreeBSD$
PORTNAME= pynzb
@@ -20,12 +17,14 @@ USE_PYTHON= 2.5+
USE_PYDISTUTILS= easy_install
PYDISTUTILS_NOEGGINFO= yes
-OPTIONS= LXML "Add support for py-lxml" Off
+OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
+OPTIONS_DEFINE= LXML
+LXML_DESC= Add support for py-lxml
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_LXML)
+.if ${PORT_OPTIONS:MLXML}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}lxml>=2.2.1:${PORTSDIR}/devel/py-lxml
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>