aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-08-30 00:39:07 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-08-30 00:39:07 +0000
commit4cba7980c204a2478b2deb33489d86b9bb03f3f6 (patch)
tree6b86c2c4b3579bd9117c91abb2cee466611c027a /news
parentd5f501da8c10f86acf2fff813d5f51e5ebc171d2 (diff)
downloadports-4cba7980c204a2478b2deb33489d86b9bb03f3f6.tar.gz
ports-4cba7980c204a2478b2deb33489d86b9bb03f3f6.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/inn-current/Makefile8
-rw-r--r--news/inn-current/files/patch-lib_innconf.c11
-rw-r--r--news/inn-stable/Makefile6
-rw-r--r--news/inn-stable/files/patch-lib_innconf.c11
-rw-r--r--news/inn/Makefile15
-rw-r--r--news/inn/files/patch-lib_innconf.c11
6 files changed, 44 insertions, 18 deletions
diff --git a/news/inn-current/Makefile b/news/inn-current/Makefile
index ebcb645f30a0..51e4d77c1e82 100644
--- a/news/inn-current/Makefile
+++ b/news/inn-current/Makefile
@@ -58,9 +58,9 @@ WITH_BDB_VER= 41
. if (${WITH_BDB_VER} == 3) || (${WITH_BDB_VER} == 4) || (${WITH_BDB_VER} == 41)
LIB_DEPENDS+= db${WITH_BDB_VER}:${PORTSDIR}/databases/db${WITH_BDB_VER}
. elif ${WITH_BDB_VER} == 2
-BROKEN= "Does not compile with db2"
+BROKEN= does not compile with db2
. else
-BROKEN= "Unknown BerkeleyDB version"
+BROKEN= unknown BerkeleyDB version
. endif
CONFIGURE_ENV+= DB_VER=db${WITH_BDB_VER}
CONFIGURE_ARGS+= --with-berkeleydb=${LOCALBASE}
@@ -129,7 +129,7 @@ MAN8= actsync.8 actsyncd.8 archive.8 auth_smb.8 batcher.8 buffchan.8 \
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"
-BROKEN= "Does not compile on ia64"
+BROKEN= does not compile on ${ARCH}
.endif
.if defined(WITH_STANDARD_ETC)
@@ -165,6 +165,8 @@ post-install:
s+!!PREFIX!!+${PREFIX}+g && ${CHMOD} +x ${PREFIX}/etc/rc.d/innd.sh
@${CHOWN} root:news ${PREFIX}/news/bin/auth/passwd/ckpasswd
@${CHMOD} 4755 ${PREFIX}/news/bin/auth/passwd/ckpasswd
+ @${FIND} ${WRKSRC} -name "inn.conf" \
+ | ${XARGS} ${REINPLACE_CMD} -e 's/^pathhost:.*/pathhost: host.example.com/'
@PKG_PREFIX=${PKG_PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} CHECK-CONF ${ETC_DIR}
@(if [ ! -f ${PREFIX}/news/db/history ] ; then \
${ECHO} 'Creating empty history database...' ; \
diff --git a/news/inn-current/files/patch-lib_innconf.c b/news/inn-current/files/patch-lib_innconf.c
new file mode 100644
index 000000000000..05d8eadfb946
--- /dev/null
+++ b/news/inn-current/files/patch-lib_innconf.c
@@ -0,0 +1,11 @@
+--- lib/innconf.c.orig Mon Mar 20 04:14:57 2006
++++ lib/innconf.c Sat Aug 26 00:22:04 2006
+@@ -395,7 +395,7 @@
+
+ if (GetFQDN(innconf->domain) == NULL) {
+ warn("hostname does not resolve or domain not set in inn.conf");
+- okay = false;
++/* okay = false; */
+ }
+ if (innconf->mta == NULL) {
+ warn("must set mta in inn.conf");
diff --git a/news/inn-stable/Makefile b/news/inn-stable/Makefile
index c1e3be72ca7d..b9cf473dfc85 100644
--- a/news/inn-stable/Makefile
+++ b/news/inn-stable/Makefile
@@ -56,9 +56,9 @@ LIB_DEPENDS+= db${WITH_BDB_VER}:${PORTSDIR}/databases/db${WITH_BDB_VER}
.elif (${WITH_BDB_VER} == 42)
LIB_DEPENDS+= db-4.2:${PORTSDIR}/databases/db42
. elif ${WITH_BDB_VER} == 2
-IGNORE= "Does not compile with db2"
+IGNORE= does not compile with db2
. else
-IGNORE= "Unknown BerkeleyDB version"
+IGNORE= unknown BerkeleyDB version
. endif
CONFIGURE_ENV+= DB_VER=db${WITH_BDB_VER}
CONFIGURE_ARGS+= --with-berkeleydb
@@ -174,6 +174,8 @@ post-install:
s+!!PREFIX!!+${PREFIX}+g && ${CHMOD} +x ${PREFIX}/etc/rc.d/innd.sh
@${CHOWN} root:news ${PREFIX}/news/bin/auth/passwd/ckpasswd
@${CHMOD} 4755 ${PREFIX}/news/bin/auth/passwd/ckpasswd
+ @${FIND} ${WRKSRC} -name "inn.conf" \
+ | ${XARGS} ${REINPLACE_CMD} -e 's/^pathhost:.*/pathhost: host.example.com/'
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} CHECK-CONF ${ETC_DIR}
@(if [ ! -f ${PREFIX}/news/db/history ] ; then \
${ECHO} 'Creating empty history database...' ; \
diff --git a/news/inn-stable/files/patch-lib_innconf.c b/news/inn-stable/files/patch-lib_innconf.c
new file mode 100644
index 000000000000..05d8eadfb946
--- /dev/null
+++ b/news/inn-stable/files/patch-lib_innconf.c
@@ -0,0 +1,11 @@
+--- lib/innconf.c.orig Mon Mar 20 04:14:57 2006
++++ lib/innconf.c Sat Aug 26 00:22:04 2006
+@@ -395,7 +395,7 @@
+
+ if (GetFQDN(innconf->domain) == NULL) {
+ warn("hostname does not resolve or domain not set in inn.conf");
+- okay = false;
++/* okay = false; */
+ }
+ if (innconf->mta == NULL) {
+ warn("must set mta in inn.conf");
diff --git a/news/inn/Makefile b/news/inn/Makefile
index 9c8a9346cfee..f8f2d7d3027d 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -45,19 +45,6 @@ CONFIGURE_ARGS+= --mandir=${PREFIX}/man \
--enable-ipv6 \
--with-etc-dir=${ETC_DIR}
-# Attempt to avoid failures later on, when
-# makedbz is executed: we need a valid hostname.
-
-.if exists(/bin/hostname)
-HOSTNAME!= /bin/hostname
-. if ${HOSTNAME} != ""
-HOSTNAME:= ${HOSTNAME:C/[^\.]//g}
-. if ${HOSTNAME} == ""
-IGNORE= requires a fully-qualified hostname in order to build
-. endif
-. endif
-.endif
-
.if defined(WITH_BERKELEYDB)
CONFIGURE_ARGS+= --with-berkeleydb
. if !defined(WITH_BDB_VER)
@@ -185,6 +172,8 @@ post-install:
.endfor
@${CHOWN} root:news ${PREFIX}/news/bin/auth/passwd/ckpasswd
@${CHMOD} 4755 ${PREFIX}/news/bin/auth/passwd/ckpasswd
+ @${FIND} ${WRKSRC} -name "inn.conf" \
+ | ${XARGS} ${REINPLACE_CMD} -e 's/^pathhost:.*/pathhost: host.example.com/'
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} CHECK-CONF ${ETC_DIR}
@(if [ ! -f ${PREFIX}/news/db/history ] ; then \
${ECHO} 'Creating empty history database...' ; \
diff --git a/news/inn/files/patch-lib_innconf.c b/news/inn/files/patch-lib_innconf.c
new file mode 100644
index 000000000000..05d8eadfb946
--- /dev/null
+++ b/news/inn/files/patch-lib_innconf.c
@@ -0,0 +1,11 @@
+--- lib/innconf.c.orig Mon Mar 20 04:14:57 2006
++++ lib/innconf.c Sat Aug 26 00:22:04 2006
+@@ -395,7 +395,7 @@
+
+ if (GetFQDN(innconf->domain) == NULL) {
+ warn("hostname does not resolve or domain not set in inn.conf");
+- okay = false;
++/* okay = false; */
+ }
+ if (innconf->mta == NULL) {
+ warn("must set mta in inn.conf");