aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-10-24 16:42:59 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-10-24 16:42:59 +0000
commitd45fbf3040b3448bc804ff8be8a816d15ea3f92a (patch)
tree73abd51bbc7bd715261a06c070c1e731d552daf9 /news
parent99b077f4d4a67e28e40efdac8b2e5d977e2d7366 (diff)
downloadports-d45fbf3040b3448bc804ff8be8a816d15ea3f92a.tar.gz
ports-d45fbf3040b3448bc804ff8be8a816d15ea3f92a.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/hellanzb/Makefile5
-rw-r--r--news/papercut/Makefile2
-rw-r--r--news/py-pynzb/Makefile5
-rw-r--r--news/py-twistedNews/Makefile6
-rw-r--r--news/py-yenc/Makefile4
-rw-r--r--news/sabnzbdplus/Makefile3
-rw-r--r--news/xpn/Makefile4
7 files changed, 11 insertions, 18 deletions
diff --git a/news/hellanzb/Makefile b/news/hellanzb/Makefile
index 8e86dc991f0a..6b7e7891b066 100644
--- a/news/hellanzb/Makefile
+++ b/news/hellanzb/Makefile
@@ -18,9 +18,8 @@ RUN_DEPENDS= par2:${PORTSDIR}/archivers/par2cmdline \
${PYTHON_PKGNAMEPREFIX}yenc>=0:${PORTSDIR}/news/py-yenc \
mac:${PORTSDIR}/audio/mac
-USE_PYTHON= 2
-USE_PYDISTUTILS=yes
-USES= twisted:run,web
+USE_PYTHON= distutils
+USES= python:2 twisted:run,web
PORTDOCS= CHANGELOG CREDITS README
OPTIONS_DEFINE= DOCS
diff --git a/news/papercut/Makefile b/news/papercut/Makefile
index 2da914393373..38b1def0a760 100644
--- a/news/papercut/Makefile
+++ b/news/papercut/Makefile
@@ -11,7 +11,7 @@ COMMENT= Papercut is a news server written in Python, using a MySQL backend
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MySQLdb
-USE_PYTHON= yes
+USES= python
NO_BUILD= yes
do-configure:
diff --git a/news/py-pynzb/Makefile b/news/py-pynzb/Makefile
index dddb735b4a66..f1ec2b429846 100644
--- a/news/py-pynzb/Makefile
+++ b/news/py-pynzb/Makefile
@@ -13,9 +13,8 @@ COMMENT= Unified API for parsing NZB files
LICENSE= BSD3CLAUSE
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
OPTIONS_DEFINE= LXML
diff --git a/news/py-twistedNews/Makefile b/news/py-twistedNews/Makefile
index 9069b3ab72fa..7519155d452c 100644
--- a/news/py-twistedNews/Makefile
+++ b/news/py-twistedNews/Makefile
@@ -14,9 +14,7 @@ COMMENT= NNTP protocol implementation with client and server
LICENSE= MIT
-USE_PYTHON= 2
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
-USES= tar:bzip2 twisted
+USE_PYTHON= distutils autoplist
+USES= python:2 tar:bzip2 twisted
.include <bsd.port.mk>
diff --git a/news/py-yenc/Makefile b/news/py-yenc/Makefile
index 3220eb983b2d..d874d71dfa8f 100644
--- a/news/py-yenc/Makefile
+++ b/news/py-yenc/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= jlaffaye@FreeBSD.org
COMMENT= yenc decoding module for Python in C
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USES= python
+USE_PYTHON= distutils
.include <bsd.port.mk>
diff --git a/news/sabnzbdplus/Makefile b/news/sabnzbdplus/Makefile
index 3ff7a9f1f8e0..dea8c9fa8d12 100644
--- a/news/sabnzbdplus/Makefile
+++ b/news/sabnzbdplus/Makefile
@@ -64,8 +64,7 @@ LICENSE_NAME_SSMTPLIB= ssmtplib License
LICENSE_FILE_SSMTPLIB= ${WRKSRC}/licenses/License-ssmtplib.txt
LICENSE_PERMS_SSMTPLIB= auto-accept
-USE_PYTHON= yes
-USES= gettext
+USES= gettext python
NO_BUILD= yes
WRKSRC= ${WRKDIR}/SABnzbd-${PORTVERSION}
diff --git a/news/xpn/Makefile b/news/xpn/Makefile
index f791e0b63efe..cee03d62661c 100644
--- a/news/xpn/Makefile
+++ b/news/xpn/Makefile
@@ -15,15 +15,13 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:${PORTSDIR}/x11-toolki
NO_BUILD= yes
-USE_PYTHON= yes
-
FIND_DIRS= -type d
FIND_DATA= -type f -mindepth 2 -not -name "*~"
SUB_FILES= ${PORTNAME}
SUB_LIST= PYTHON_CMD=${PYTHON_CMD} XPN=${XPN}
-USES= gettext
+USES= gettext python
XPN= ${PORTNAME}.py