aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-27 10:00:14 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-27 10:00:14 +0000
commit07af00c73a0a7e2349f1e9a909724f61629f4b5e (patch)
tree42091f2ff1de2402e1e56ced2e11a393d77640df /news
parent4446a15e2529e29d570bbcf7d8eb609888e312f3 (diff)
downloadports-07af00c73a0a7e2349f1e9a909724f61629f4b5e.tar.gz
ports-07af00c73a0a7e2349f1e9a909724f61629f4b5e.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/newspost/Makefile17
1 files changed, 6 insertions, 11 deletions
diff --git a/news/newspost/Makefile b/news/newspost/Makefile
index 9387c86e7d28..dc3b238f5fdd 100644
--- a/news/newspost/Makefile
+++ b/news/newspost/Makefile
@@ -15,26 +15,21 @@ LICENSE= GPLv2
ALL_TARGET= main
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
-MAN1= ${PORTNAME}.1
PORTDOCS= README
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
# Change "cd foo; $(MAKE)" into "$(MAKE) -C foo" to unbreak parallel builds
post-patch:
@${REINPLACE_CMD} -E 's|cd(.+) ; (\$$\(MAKE\))|\2 -C\1|' \
${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/man/man1/${MAN1} ${MANPREFIX}/man/man1
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/man1/*.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>