aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-10-14 17:41:29 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-10-14 17:41:29 +0000
commit3b8e2b9a88eb4a1d383680e44231af641266698e (patch)
tree8cfd68b74e454fd14db9cc3c88bb86d29d07f322 /news
parent701dc5d3b8111dfdd1094ac689d5f483adeb1ece (diff)
downloadports-3b8e2b9a88eb4a1d383680e44231af641266698e.tar.gz
ports-3b8e2b9a88eb4a1d383680e44231af641266698e.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/pan/Makefile1
-rw-r--r--news/pan/files/patch-pan_tasks_socket-impl-gio.cc16
2 files changed, 17 insertions, 0 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index 962fee2862bd..6d793e41d88e 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -8,6 +8,7 @@
PORTNAME= pan
PORTVERSION= 0.116
+PORTREVISION= 1
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/source/
DIST_SUBDIR= gnome2
diff --git a/news/pan/files/patch-pan_tasks_socket-impl-gio.cc b/news/pan/files/patch-pan_tasks_socket-impl-gio.cc
new file mode 100644
index 000000000000..4c7afcc21799
--- /dev/null
+++ b/news/pan/files/patch-pan_tasks_socket-impl-gio.cc
@@ -0,0 +1,16 @@
+===================================================================
+RCS file: /cvs/gnome/pan2/pan/tasks/socket-impl-gio.cc,v
+retrieving revision 1.2
+retrieving revision 1.3
+diff -u -r1.2 -r1.3
+--- pan/tasks/socket-impl-gio.cc.orig 2006/10/06 15:25:53 1.2
++++ pan/tasks/socket-impl-gio.cc 2006/10/13 15:29:34 1.3
+@@ -377,7 +377,7 @@
+ {
+ // see if we've got a partial line buffered up
+ if (_channel->read_buf && _channel->read_buf->len) {
+- _partial_line.assign (_channel->read_buf->str, _channel->read_buf->len);
++ _partial_line.append (_channel->read_buf->str, _channel->read_buf->len);
+ g_string_set_size (_channel->read_buf, 0);
+ }
+ // more to come