aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-07-31 11:56:17 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-07-31 11:56:17 +0000
commita74217e6d9281b3d195ab0ad6e6b9434f63b6d27 (patch)
tree44a97c66747f24c5fab92020a97ab60bb4e93db7 /news
parente4ceaa901bf22ed58f8d80e942449d482ccfbb7e (diff)
downloadports-a74217e6d9281b3d195ab0ad6e6b9434f63b6d27.tar.gz
ports-a74217e6d9281b3d195ab0ad6e6b9434f63b6d27.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/grn/Makefile3
-rw-r--r--news/nzbperl/Makefile9
-rw-r--r--news/p5-News-Article/Makefile3
-rw-r--r--news/p5-News-Newsrc/Makefile3
-rw-r--r--news/p5-POE-Component-Client-NNTP/Makefile9
-rw-r--r--news/p5-POE-Component-Server-NNTP/Makefile3
-rw-r--r--news/plor/Makefile8
7 files changed, 15 insertions, 23 deletions
diff --git a/news/grn/Makefile b/news/grn/Makefile
index c5d370410b05..394c0caabec9 100644
--- a/news/grn/Makefile
+++ b/news/grn/Makefile
@@ -11,8 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A NNTP client for Gnome
USE_BZIP2= yes
-USE_PERL5= yes
-USES= pathfix
+USES= pathfix perl5
USE_GNOME= gnomelibs gnomeprefix
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/news/nzbperl/Makefile b/news/nzbperl/Makefile
index 7432448c2cce..f858a40d12cf 100644
--- a/news/nzbperl/Makefile
+++ b/news/nzbperl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: nzbperl
-# Date created: 20 May 2006
-# Whom: Tim Welch <ports@thepentagon.org>
-#
+# Created by: Tim Welch <ports@thepentagon.org>
# $FreeBSD$
-#
PORTNAME= nzbperl
PORTVERSION= 0.6.8
@@ -24,7 +20,8 @@ RUN_DEPENDS= p5-XML-DOM>=0:${PORTSDIR}/textproc/p5-XML-DOM \
PLIST_FILES= bin/nzbperl
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
.if defined(WITH_SSL)
RUN_DEPENDS+= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
diff --git a/news/p5-News-Article/Makefile b/news/p5-News-Article/Makefile
index 3dced38218cf..1a7478e7deba 100644
--- a/news/p5-News-Article/Makefile
+++ b/news/p5-News-Article/Makefile
@@ -14,7 +14,8 @@ COMMENT= Object for handling Usenet articles in mail or news form
BUILD_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
RUN_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= News::Article.3 News::AutoReply.3 News::FormArticle.3 \
News::FormReply.3
diff --git a/news/p5-News-Newsrc/Makefile b/news/p5-News-Newsrc/Makefile
index aab2e332d1ef..22f66d8fbe73 100644
--- a/news/p5-News-Newsrc/Makefile
+++ b/news/p5-News-Newsrc/Makefile
@@ -13,7 +13,8 @@ COMMENT= Manage newsrc files
BUILD_DEPENDS= p5-Set-IntSpan>=0:${PORTSDIR}/math/p5-Set-IntSpan
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= News::Newsrc.3
diff --git a/news/p5-POE-Component-Client-NNTP/Makefile b/news/p5-POE-Component-Client-NNTP/Makefile
index ec4c784fc6fa..ac5fa3deadaf 100644
--- a/news/p5-POE-Component-Client-NNTP/Makefile
+++ b/news/p5-POE-Component-Client-NNTP/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: POE-Component-Client-NNTP
-# Date created: 17 October 2004
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= POE-Component-Client-NNTP
PORTVERSION= 2.22
@@ -20,7 +16,8 @@ BUILD_DEPENDS= p5-POE>=0.999.9:${PORTSDIR}/devel/p5-POE \
RUN_DEPENDS= p5-POE>=0.999.9:${PORTSDIR}/devel/p5-POE \
p5-POE-Component-Pluggable>=0.03:${PORTSDIR}/devel/p5-POE-Component-Pluggable
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Component::Client::NNTP.3 \
POE::Component::Client::NNTP::Constants.3
diff --git a/news/p5-POE-Component-Server-NNTP/Makefile b/news/p5-POE-Component-Server-NNTP/Makefile
index 81c26cd437cc..c8824e44d06a 100644
--- a/news/p5-POE-Component-Server-NNTP/Makefile
+++ b/news/p5-POE-Component-Server-NNTP/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= p5-POE>=0.38:${PORTSDIR}/devel/p5-POE \
p5-POE-Component-Pluggable>=0.03:${PORTSDIR}/devel/p5-POE-Component-Pluggable \
p5-POE-Component-Client-NNTP>=1.05:${PORTSDIR}/news/p5-POE-Component-Client-NNTP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Component::Server::NNTP.3 \
POE::Component::Server::NNTP::Constants.3
diff --git a/news/plor/Makefile b/news/plor/Makefile
index 5a1ffbb93432..5ec650f86de9 100644
--- a/news/plor/Makefile
+++ b/news/plor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: plor
-# Date Created: 30 Dec 1996
-# Whom: Tim Vanderhoek <ac199@freenet.hamilton.on.ca>
-#
+# Created by: Tim Vanderhoek <ac199@freenet.hamilton.on.ca>
# $FreeBSD$
-#
PORTNAME= plor
PORTVERSION= 0.3.3
@@ -19,7 +15,7 @@ RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_PERL5= yes
+USES= perl5
MAN1= plor.1