aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-31 22:06:04 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-31 22:06:04 +0000
commitb3fdf51e20adb71e006ec7d2d4dff0fd78b198a8 (patch)
treedbdee3fb6accd0eb284b32f8310142224e7e1fa3 /news
parentc45276c2ba1a929e1ec379eb347f5c144ca7637c (diff)
downloadports-b3fdf51e20adb71e006ec7d2d4dff0fd78b198a8.tar.gz
ports-b3fdf51e20adb71e006ec7d2d4dff0fd78b198a8.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/yencode/Makefile9
-rw-r--r--news/yencode/files/patch-lib::Makefile.in37
2 files changed, 43 insertions, 3 deletions
diff --git a/news/yencode/Makefile b/news/yencode/Makefile
index 35a11bac9c2c..3b441ce87204 100644
--- a/news/yencode/Makefile
+++ b/news/yencode/Makefile
@@ -18,12 +18,15 @@ COMMENT= A free (GPL) encoder and decoder for the yEnc Usenet file format
LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
-USE_GETOPT_LONG=yes
+USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
-CPPFLAGS= ${CXXFLAGS} -I${LOCALBASE}/include
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= ydecode.1 yencode.1 ypost.1
MAN5= ypostrc.5
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
.include <bsd.port.mk>
diff --git a/news/yencode/files/patch-lib::Makefile.in b/news/yencode/files/patch-lib::Makefile.in
new file mode 100644
index 000000000000..320118e11668
--- /dev/null
+++ b/news/yencode/files/patch-lib::Makefile.in
@@ -0,0 +1,37 @@
+--- lib/Makefile.in.orig Fri Mar 22 06:52:35 2002
++++ lib/Makefile.in Thu Oct 30 02:50:35 2003
+@@ -97,7 +97,7 @@
+ AM_CFLAGS = -Wall
+ libmisc_a_SOURCES = misc.h \
+ alloca.c xmalloc.c xstrdup.c \
+- getopt1.c getopt.c getopt.h getoptstr.c \
++ getoptstr.c \
+ error.c \
+ input.c \
+ path.c \
+@@ -118,7 +118,7 @@
+
+ libmisc_a_AR = $(AR) cru
+ am_libmisc_a_OBJECTS = alloca.$(OBJEXT) xmalloc.$(OBJEXT) \
+- xstrdup.$(OBJEXT) getopt1.$(OBJEXT) getopt.$(OBJEXT) \
++ xstrdup.$(OBJEXT) \
+ getoptstr.$(OBJEXT) error.$(OBJEXT) input.$(OBJEXT) \
+ path.$(OBJEXT) screen.$(OBJEXT) string.$(OBJEXT) \
+ timer.$(OBJEXT)
+@@ -131,7 +131,6 @@
+ LIBS = @LIBS@
+ depcomp = $(SHELL) $(top_srcdir)/depcomp
+ @AMDEP_TRUE@DEP_FILES = $(DEPDIR)/alloca.Po $(DEPDIR)/error.Po \
+-@AMDEP_TRUE@ $(DEPDIR)/getopt.Po $(DEPDIR)/getopt1.Po \
+ @AMDEP_TRUE@ $(DEPDIR)/getoptstr.Po $(DEPDIR)/input.Po \
+ @AMDEP_TRUE@ $(DEPDIR)/path.Po $(DEPDIR)/screen.Po \
+ @AMDEP_TRUE@ $(DEPDIR)/string.Po $(DEPDIR)/timer.Po \
+@@ -174,8 +173,6 @@
+
+ @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/alloca.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/error.Po@am__quote@
+-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/getopt.Po@am__quote@
+-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/getopt1.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/getoptstr.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/input.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/path.Po@am__quote@