aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-01-08 10:17:50 +0000
committerClement Laforet <clement@FreeBSD.org>2004-01-08 10:17:50 +0000
commit0cdc83928a775d1bbe90c39fd3169edc8e758e7d (patch)
tree4f50cb44492c55ed1e30bb3aab451b348049ce70 /news
parent94399cf1e7c0db506b69595840d077bc28b785a2 (diff)
downloadports-0cdc83928a775d1bbe90c39fd3169edc8e758e7d.tar.gz
ports-0cdc83928a775d1bbe90c39fd3169edc8e758e7d.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/inn-stable/Makefile3
-rw-r--r--news/inn-stable/files/patch-innd::art.c24
2 files changed, 26 insertions, 1 deletions
diff --git a/news/inn-stable/Makefile b/news/inn-stable/Makefile
index d58cf5fbe0ed..3540415d7dd8 100644
--- a/news/inn-stable/Makefile
+++ b/news/inn-stable/Makefile
@@ -7,13 +7,14 @@
PORTNAME= inn
PORTVERSION= ${SNAPSHOT}
+PORTREVISION= 1
CATEGORIES= news ipv6
MASTER_SITES= http://sheepkiller.nerim.net/ports/${PORTNAME}/ \
http://www.cultdeadsheep.org/FreeBSD/ports/download/distfiles/
PKGNAMESUFFIX= -${BRANCH}
DISTNAME= ${PORTNAME}-${BRANCH:U}-${SNAPSHOT}
-MAINTAINER= sheepkiller@cultdeadsheep.org
+MAINTAINER= clement@FreeBSD.org
COMMENT= InterNetNews -- the Internet meets Netnews
BRANCH= stable
diff --git a/news/inn-stable/files/patch-innd::art.c b/news/inn-stable/files/patch-innd::art.c
new file mode 100644
index 000000000000..7943a772f23e
--- /dev/null
+++ b/news/inn-stable/files/patch-innd::art.c
@@ -0,0 +1,24 @@
+--- innd/art.c.orig Sat Jul 12 19:40:34 2003
++++ innd/art.c Thu Jan 8 10:09:34 2004
+@@ -1773,7 +1773,7 @@
+ bool
+ ARTpost(CHANNEL *cp)
+ {
+- char *p, **groups, ControlWord[SMBUF], tmpbuff[32], **hops;
++ char *p, **groups, ControlWord[SMBUF], **hops, *controlgroup;
+ int i, j, *isp, hopcount, oerrno, canpost;
+ NEWSGROUP *ngp, **ngptr;
+ SITE *sp;
+@@ -2184,9 +2184,10 @@
+ * or control. */
+ if (IsControl && Accepted && !ToGroup) {
+ ControlStore = true;
+- FileGlue(tmpbuff, "control", '.', ControlWord);
+- if ((ngp = NGfind(tmpbuff)) == NULL)
++ controlgroup = concat("control.", ControlWord, (char *) 0);
++ if ((ngp = NGfind(controlgroup)) == NULL)
+ ngp = NGfind(ARTctl);
++ free(controlgroup);
+ ngp->PostCount = 0;
+ ngptr = GroupPointers;
+ *ngptr++ = ngp;