aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-03-28 14:58:20 +0000
committerSteve Price <steve@FreeBSD.org>1998-03-28 14:58:20 +0000
commitec82883723b13881b08b552cc2545012de9ca3bd (patch)
treea392ff98814ff9c728322677e0078bc6d4548943 /news
parentee9d82123f33ed865db5baabc8f05360fd1b728a (diff)
downloadports-ec82883723b13881b08b552cc2545012de9ca3bd.tar.gz
ports-ec82883723b13881b08b552cc2545012de9ca3bd.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/unpost/Makefile22
-rw-r--r--news/unpost/distinfo1
-rw-r--r--news/unpost/files/patch-aa24
-rw-r--r--news/unpost/pkg-comment1
-rw-r--r--news/unpost/pkg-descr7
-rw-r--r--news/unpost/pkg-plist2
6 files changed, 57 insertions, 0 deletions
diff --git a/news/unpost/Makefile b/news/unpost/Makefile
new file mode 100644
index 000000000000..7a91f9e2a850
--- /dev/null
+++ b/news/unpost/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: unpoost
+# Version required: 2.3.4
+# Date created: 14 october 1997
+# Whom: volf@oasis.IAEhv.nl
+#
+# $Id$
+#
+
+DISTNAME= unpost-2.3.4
+CATEGORIES= news
+MASTER_SITES= ftp://ftp.rhein.de/pub/unix/news/
+
+MAINTAINER= volf@oasis.IAEhv.nl
+
+MAKEFILE= makefils/linux.mkf
+MAN1= unpost.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/unpost ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/unpost.doc ${PREFIX}/man/man1/unpost.1
+
+.include <bsd.port.mk>
diff --git a/news/unpost/distinfo b/news/unpost/distinfo
new file mode 100644
index 000000000000..bc4b93f85947
--- /dev/null
+++ b/news/unpost/distinfo
@@ -0,0 +1 @@
+MD5 (unpost-2.3.4.tar.gz) = 33e610f6c07737ccc4b7fd7f3cf9a80a
diff --git a/news/unpost/files/patch-aa b/news/unpost/files/patch-aa
new file mode 100644
index 000000000000..ebadf911bed3
--- /dev/null
+++ b/news/unpost/files/patch-aa
@@ -0,0 +1,24 @@
+--- compiler.h.org Fri Nov 14 14:04:42 1997
++++ compiler.h Fri Nov 14 14:06:55 1997
+@@ -70,9 +70,11 @@
+ -----------------------------------------------------------------------------*/
+ #elif defined(GCC_COMPILER)
+
++#ifndef __FreeBSD__
+ extern char *sys_errlist[];
+
+ #define strerror(x) sys_errlist[x]
++#endif
+
+ /* Defines for fopen calls. */
+ #define TXT_APPEND "a"
+@@ -82,7 +84,9 @@
+ #define BIN_WRITE "w"
+ #define BIN_RD_WRT "w+"
+
++#ifndef __FreeBSD__
+ #include <malloc.h>
++#endif
+ #include <unistd.h>
+
+ /*-----------------------------------------------------------------------------
diff --git a/news/unpost/pkg-comment b/news/unpost/pkg-comment
new file mode 100644
index 000000000000..69946c56b2d6
--- /dev/null
+++ b/news/unpost/pkg-comment
@@ -0,0 +1 @@
+Extract binary files from multi-segment uuencoded postings.
diff --git a/news/unpost/pkg-descr b/news/unpost/pkg-descr
new file mode 100644
index 000000000000..8ef31845fe75
--- /dev/null
+++ b/news/unpost/pkg-descr
@@ -0,0 +1,7 @@
+UNPOST is a tool designed primarily to extract binaries from USENET
+binaries postings such as those made to alt.binaries.pictures.misc
+and comp.binaries.ibm.pc. As well as extracting binaries from USENET
+postings, UNPOST can extract binaries from multi-segment uuencoded
+mailings as well, however, to simplify this documentation only
+USENET article postings will be discussed. The principles are the
+same for multi-segment mailings.
diff --git a/news/unpost/pkg-plist b/news/unpost/pkg-plist
new file mode 100644
index 000000000000..bbb7d6650c3f
--- /dev/null
+++ b/news/unpost/pkg-plist
@@ -0,0 +1,2 @@
+bin/unpost
+man/man1/unpost.1.gz