aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-01-10 14:20:12 +0000
committerStefan Eßer <se@FreeBSD.org>2022-01-10 15:15:39 +0000
commitbcaf25a8c8046b094f6b5ab5bc258333bc326ee1 (patch)
tree3930596b8cbea97540270b3d78ffb64373c89593 /news
parentf1661bdbbac2d08cc535e38e41d2bbd3fec025c4 (diff)
downloadports-bcaf25a8c8046b094f6b5ab5bc258333bc326ee1.tar.gz
ports-bcaf25a8c8046b094f6b5ab5bc258333bc326ee1.zip
Fix CONFLICTS entries of multiple ports
There have been lots of missing CONFLICTS_INSTALL entries, either because conflicting ports were added without updating existing ports, due to name changes of generated packages, due to mis-understanding the format and semantics of the conflicts entries, or just due to typoes in package names. This patch is the result of a comparison of all files contained in the official packages with each other. This comparison was based on packages built with default options and may therefore have missed further conflicts with optionally installed files. Where possible, version numbers in conflicts entries have been generalized, some times taking advantage of the fact that a port cannot conflict with itself (due to logic in bsd.port.mk that supresses the pattern match result in that case). A few ports that set the conflicts variables depending on complex conditions (e.g. port options), have been left unmodified, despite probably containing outdated package names. These changes should only affect the installation of locally built ports, not the package building with poudriere. They should give an early indication of the install conflict in cases where currently the pkg command aborts an installation when it detects that an existing file would be overwritten, Approved by: portmgr (implicit)
Diffstat (limited to 'news')
-rw-r--r--news/cnews/Makefile2
-rw-r--r--news/s-news/Makefile2
-rw-r--r--news/trn/Makefile2
-rw-r--r--news/trn4/Makefile2
4 files changed, 5 insertions, 3 deletions
diff --git a/news/cnews/Makefile b/news/cnews/Makefile
index 42419d2823c7..48bcb3bef0fd 100644
--- a/news/cnews/Makefile
+++ b/news/cnews/Makefile
@@ -39,6 +39,8 @@ USES= tar:Z
USE_CSTD= gnu89
CFLAGS+= -Wno-return-type
+CONFLICTS_INSTALL= s-news trn4 # bin/inews
+
DIST_SUBDIR= ${DISTNAME}
NO_WRKSUBDIR= yes
MAKEFILE= makefile
diff --git a/news/s-news/Makefile b/news/s-news/Makefile
index 29489a5834e8..11881197b950 100644
--- a/news/s-news/Makefile
+++ b/news/s-news/Makefile
@@ -11,7 +11,7 @@ COMMENT= Simple news server for hosts with one or two users
LIB_DEPENDS= libgdbm.so:databases/gdbm
-CONFLICTS= leafnode-[1-9]* nntp
+CONFLICTS= cnews nntp trn4 # bin/inews sbin/nntpd
CONFIGURE_ARGS+= \
--with-confdir=${PREFIX}/etc/s-news \
diff --git a/news/trn/Makefile b/news/trn/Makefile
index 50aafc58adeb..f29fda91d6bc 100644
--- a/news/trn/Makefile
+++ b/news/trn/Makefile
@@ -11,7 +11,7 @@ COMMENT= Threaded Read News newsreader
RUN_DEPENDS= munpack:converters/mpack
-CONFLICTS_INSTALL=trn-4.[0-9]*
+CONFLICTS_INSTALL= s-news trn4
USES= ncurses
WRKSRC= ${WRKDIR}/trn-3.6
diff --git a/news/trn4/Makefile b/news/trn4/Makefile
index d6e0e2384328..3ee9c0a48745 100644
--- a/news/trn4/Makefile
+++ b/news/trn4/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/-test/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Version 4.0 of the threaded readnews newsreader
-CONFLICTS_INSTALL=trn-3.[0-9]* cnews s-news
+CONFLICTS_INSTALL= trn cnews s-news
USES= ncurses