aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-11 22:17:07 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-11 22:17:07 +0000
commit87d05287ec147bc36892210c18dcb4cab4aa2ffc (patch)
tree6bb3d1df2b4c68b1d2c69d0bf5da0992df91304e /news
parent975af646f278430e563b72219a2c3055b211eb1a (diff)
downloadports-87d05287ec147bc36892210c18dcb4cab4aa2ffc.tar.gz
ports-87d05287ec147bc36892210c18dcb4cab4aa2ffc.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/leafnode/Makefile4
-rw-r--r--news/leafnode/distinfo4
-rw-r--r--news/leafnode/files/patch-fetchnews.c55
3 files changed, 4 insertions, 59 deletions
diff --git a/news/leafnode/Makefile b/news/leafnode/Makefile
index b7d33d384dce..5d30cd617ee9 100644
--- a/news/leafnode/Makefile
+++ b/news/leafnode/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= leafnode
-PORTVERSION= 1.10.5
-PORTREVISION= 1
+PORTVERSION= 1.10.6
+PORTREVISION= 0
CATEGORIES= news
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED:S/$/:sourceforge/} \
http://osdn.dl.sourceforge.net/sourceforge/${PORTNAME}/:sourceforge \
diff --git a/news/leafnode/distinfo b/news/leafnode/distinfo
index acc2baa09b00..736cc7e3a596 100644
--- a/news/leafnode/distinfo
+++ b/news/leafnode/distinfo
@@ -1,2 +1,2 @@
-MD5 (leafnode-1.10.5.rel.tar.bz2) = b4f65e2df6d1e7cef15041cf5c0d6990
-SIZE (leafnode-1.10.5.rel.tar.bz2) = 385379
+MD5 (leafnode-1.10.6.rel.tar.bz2) = 5280f805fdc3db66e7b168944732f852
+SIZE (leafnode-1.10.6.rel.tar.bz2) = 384293
diff --git a/news/leafnode/files/patch-fetchnews.c b/news/leafnode/files/patch-fetchnews.c
deleted file mode 100644
index 1200aca96503..000000000000
--- a/news/leafnode/files/patch-fetchnews.c
+++ /dev/null
@@ -1,55 +0,0 @@
---- fetchnews.c Fri Sep 3 01:39:44 2004
-+++ fetchnews.c.new Fri Sep 3 01:37:56 2004
-@@ -2225,6 +2225,7 @@
- volatile int rc = 0, skip_servers = 0;
- volatile int anypost = 0, waitchild = 0, quiet;
- struct server *current_server;
-+ volatile int need_refetch = 0;
-
- int option, reply;
- pid_t pid;
-@@ -2380,8 +2381,10 @@
- nntpquit();
- if (!rc)
- rc = 2;
-- if (forceactive)
-+ if (forceactive) {
- error_refetch("caught signal that caused a premature abort.");
-+ need_refetch = 1;
-+ }
- skip_servers = 1; /* in this case, jump the while ... loop */
- } else {
- canjump = 1;
-@@ -2458,8 +2461,10 @@
- /* get list of newsgroups or new newsgroups */
- if (current_server->updateactive) {
- if (nntpactive(current_server, &stamp)) {
-- if (forceactive)
-+ if (forceactive) {
- error_refetch("obtaining the active file failed.");
-+ need_refetch = 1;
-+ }
- rc = 1;
- }
- } else {
-@@ -2477,8 +2482,10 @@
- } else { /* reply = nntpconnect */
- if (verbose)
- printf("%s: connection failed.\n", current_server->name);
-- if (forceactive)
-+ if (forceactive && current_server->updateactive) {
- error_refetch("fetching the active list from a server failed.");
-+ need_refetch = 1;
-+ }
- rc = 2;
- }
- if (!usesupplement)
-@@ -2545,7 +2552,7 @@
- rc = 1;
- }
- } else {
-- if (rc == 0 && updateactive())
-+ if (need_refetch == 0 && updateactive())
- if (killactiveread()) {
- error_refetch("cannot update active.read file.");
- rc = 1;