aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2017-02-01 07:06:19 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2017-02-01 07:06:19 +0000
commitfa85ec07052793d8bdaf9195404290fed4e6d0ab (patch)
tree5e0afe11bdef39c310cfacdc2a91f8a7a9ba90f0 /news
parent18c56793cd81736c8a7bfa33c75405573002a43e (diff)
downloadports-fa85ec07052793d8bdaf9195404290fed4e6d0ab.tar.gz
ports-fa85ec07052793d8bdaf9195404290fed4e6d0ab.zip
- fix owner on suid binaries
- fix option FIDOGATE_RUNAS - add LICENSE - make portlint happier
Notes
Notes: svn path=/head/; revision=432991
Diffstat (limited to 'news')
-rw-r--r--news/fidogate/Makefile18
-rw-r--r--news/fidogate/files/patch-Makefile6
-rw-r--r--news/fidogate/files/patch-config.make10
-rw-r--r--news/fidogate/files/patch-dbz.c6
-rw-r--r--news/fidogate/files/patch-log.c6
-rw-r--r--news/fidogate/files/patch-rfc2ftn.c6
-rw-r--r--news/fidogate/pkg-plist6
7 files changed, 30 insertions, 28 deletions
diff --git a/news/fidogate/Makefile b/news/fidogate/Makefile
index c401e54f6560..1a7595b1d34a 100644
--- a/news/fidogate/Makefile
+++ b/news/fidogate/Makefile
@@ -2,6 +2,7 @@
PORTNAME= fidogate
PORTVERSION= 4.4.10
+PORTREVISION= 1
CATEGORIES= news mail
MASTER_SITES= SF \
ftp://ftp.fu-berlin.de/unix/news/fidogate/
@@ -9,9 +10,14 @@ MASTER_SITES= SF \
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Fido-Internet Gateway and Tosser
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
MAKE_JOBS_UNSAFE= yes
USES= gmake perl5
+MAKE_ARGS= OWNER=${UID} GROUP=$$(id -g)
+PLIST_SUB= FIDOGATE_USER=${FIDOGATE_RUNAS}
FIXDEST= . doc doc/gatebau doc/html scripts/areas \
scripts/maintenance scripts/misc scripts/nodelist \
@@ -23,8 +29,8 @@ DOCLIST= fidogate.texi fidogate.txt gatebau94.txt kludge-rfc.doc \
gatebau/msgid.tex gatebau/msgid.txt
OPTIONS_DEFINE= DOCS EXAMPLES
-GID!= id -g
-MAKE_ARGS= OWNER=${UID} GROUP=${GID}
+
+FIDOGATE_RUNAS?= news
.include <bsd.port.options.mk>
@@ -40,10 +46,6 @@ pre-configure:
${REINPLACE_CMD} -e "s|.{PREFIX}|${PREFIX}|g" \
-e "s|.{LOCALBASE}|${LOCALBASE}|g" \
-e "s|^CC|#CC|" ${WRKSRC}/config.make
-.if defined(FIDOGATE_RUNAS)
- ${REINPLACE_CMD} -e "s|OWNER.*= news|OWNER = ${FIDOGATE_RUNAS}|" \
- ${WRKSRC}/config.make
-.endif
.if !${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e "s|test doc|test|" \
-e "s|cp ANNOUNCE|#cp ANNOUNCE|" \
@@ -53,14 +55,14 @@ pre-configure:
pre-install:
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/fidogate
-.if ${PORT_OPTIONS:MDOCS}
+
+pre-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/html \
${STAGEDIR}${DOCSDIR}/info \
${STAGEDIR}${DOCSDIR}/fido \
${STAGEDIR}${DOCSDIR}/howto \
${STAGEDIR}${DOCSDIR}/misc \
${STAGEDIR}${DOCSDIR}/gatebau
-.endif
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/news/fidogate/files/patch-Makefile b/news/fidogate/files/patch-Makefile
index f73a2461c533..f939fe83dacd 100644
--- a/news/fidogate/files/patch-Makefile
+++ b/news/fidogate/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Sun Oct 17 13:49:26 1999
-+++ Makefile Fri Jan 21 18:04:46 2000
-@@ -9,7 +9,7 @@
+--- Makefile.orig 2003-06-08 21:01:25 UTC
++++ Makefile
+@@ -9,7 +9,7 @@ TOPDIR = .
include $(TOPDIR)/config.make
include $(TOPDIR)/rules.make
diff --git a/news/fidogate/files/patch-config.make b/news/fidogate/files/patch-config.make
index b4f2858448f4..9af666154063 100644
--- a/news/fidogate/files/patch-config.make
+++ b/news/fidogate/files/patch-config.make
@@ -1,5 +1,5 @@
---- config.make.orig 2003-04-15 20:45:20.000000000 +0200
-+++ config.make 2009-07-05 06:31:34.000000000 +0200
+--- config.make.orig 2003-04-15 18:45:20 UTC
++++ config.make
@@ -57,13 +57,13 @@
# variable parameters, can be changed at run-time, DO NOT DELETE ANYTHING!!!
@@ -19,7 +19,7 @@
DEFAULT_V_INBOUND = $(DEFAULT_V_BTBASEDIR)/in
DEFAULT_V_PINBOUND = $(DEFAULT_V_BTBASEDIR)/pin
DEFAULT_V_UUINBOUND = $(DEFAULT_V_BTBASEDIR)/uuin
-@@ -87,7 +87,7 @@
+@@ -87,7 +87,7 @@ DEFAULT_F_NEWSETCDIR = /etc/news
DEFAULT_F_NEWSVARDIR = /var/lib/news
# INN 1.7
#DEFAULT_F_NEWSLIBDIR = /usr/lib/news
@@ -28,7 +28,7 @@
# INN 2.2
#DEFAULT_F_NEWSLIBDIR = /usr/lib
#DEFAULT_F_NEWSSPOOLDIR = /var/spool/news/articles
-@@ -149,7 +149,7 @@
+@@ -149,7 +149,7 @@ DEFAULT_A_UUINBOUND = %U
# The perl interpreter used by subst.pl
@@ -37,7 +37,7 @@
# Directory with sendmail m4 configuration files
# RedHat 6.x
-@@ -158,9 +158,9 @@
+@@ -158,9 +158,9 @@ PERL = /usr/bin/perl
SENDMAIL_CF_DIR = /usr/share/sendmail-cf
# Directories for installing documentation, not used by subst.pl
diff --git a/news/fidogate/files/patch-dbz.c b/news/fidogate/files/patch-dbz.c
index 98aa792b21b9..fb07c6eb309a 100644
--- a/news/fidogate/files/patch-dbz.c
+++ b/news/fidogate/files/patch-dbz.c
@@ -1,6 +1,6 @@
---- src/toss/dbz.c.orig Wed Oct 18 23:53:57 2000
-+++ src/toss/dbz.c Mon Jul 22 19:52:59 2002
-@@ -300,8 +300,10 @@
+--- src/toss/dbz.c.orig 2000-10-18 21:53:57 UTC
++++ src/toss/dbz.c
+@@ -300,8 +300,10 @@ static int debug; /* controlled by dbz
#endif
/* externals used */
diff --git a/news/fidogate/files/patch-log.c b/news/fidogate/files/patch-log.c
index c72efaad4a31..5059853894ec 100644
--- a/news/fidogate/files/patch-log.c
+++ b/news/fidogate/files/patch-log.c
@@ -1,6 +1,6 @@
---- src/common/log.c.orig Sun Feb 16 16:38:56 2003
-+++ src/common/log.c Sat Aug 21 11:10:09 2004
-@@ -69,8 +69,8 @@
+--- src/common/log.c.orig 2004-08-26 20:56:20 UTC
++++ src/common/log.c
+@@ -69,8 +69,8 @@ static int must_openlog = TRUE;
char *strerror(int errnum)
{
#ifndef OS2
diff --git a/news/fidogate/files/patch-rfc2ftn.c b/news/fidogate/files/patch-rfc2ftn.c
index 6115860f5135..0803694862e5 100644
--- a/news/fidogate/files/patch-rfc2ftn.c
+++ b/news/fidogate/files/patch-rfc2ftn.c
@@ -1,6 +1,6 @@
---- src/gate/rfc2ftn.c.orig Sun Aug 22 22:19:12 2004
-+++ src/gate/rfc2ftn.c Sat Oct 7 21:06:14 2006
-@@ -99,7 +99,7 @@
+--- src/gate/rfc2ftn.c.orig 2004-08-22 20:19:12 UTC
++++ src/gate/rfc2ftn.c
+@@ -99,7 +99,7 @@ void usage (void);
static char *o_flag = NULL; /* -o --out-packet-file */
static char *w_flag = NULL; /* -w --write-outbound */
static int W_flag = FALSE; /* -W --write-crash */
diff --git a/news/fidogate/pkg-plist b/news/fidogate/pkg-plist
index e95b45fa8f5d..de6c5965fb66 100644
--- a/news/fidogate/pkg-plist
+++ b/news/fidogate/pkg-plist
@@ -2,7 +2,7 @@ libexec/fidogate/areafix.help
libexec/fidogate/areasbbssync
libexec/fidogate/charset.bin
libexec/fidogate/charset.map
-libexec/fidogate/ffx
+@(%%FIDOGATE_USER%%,news,4755) libexec/fidogate/ffx
libexec/fidogate/ffxmail
libexec/fidogate/ffxnews
libexec/fidogate/ffxqt
@@ -10,7 +10,7 @@ libexec/fidogate/ffxrmail
libexec/fidogate/ftn2ftn
libexec/fidogate/ftn2rfc
libexec/fidogate/ftnaf
-libexec/fidogate/ftnafmail
+@(%%FIDOGATE_USER%%,news,4755) libexec/fidogate/ftnafmail
libexec/fidogate/ftnafpkt
libexec/fidogate/ftnafutil
libexec/fidogate/ftnbsy
@@ -24,7 +24,7 @@ libexec/fidogate/ftninpost
libexec/fidogate/ftninrecomb
libexec/fidogate/ftnlock
libexec/fidogate/ftnlog
-libexec/fidogate/ftnmail
+@(%%FIDOGATE_USER%%,news,4755) libexec/fidogate/ftnmail
libexec/fidogate/ftnoutpkt
libexec/fidogate/ftnpack
libexec/fidogate/ftnroute