aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2017-05-21 21:03:09 +0000
committerJohan van Selst <johans@FreeBSD.org>2017-05-21 21:03:09 +0000
commit1e77c321498048bf2b685e1a5bb7db7da7f11477 (patch)
treeecf120d4524cfbf929c1b07b8f227abd87f0b593 /news
parentb172a04396503188c536804c512e6bf0ede04b98 (diff)
downloadports-1e77c321498048bf2b685e1a5bb7db7da7f11477.tar.gz
ports-1e77c321498048bf2b685e1a5bb7db7da7f11477.zip
Notes
Diffstat (limited to 'news')
-rw-r--r--news/inn/Makefile6
-rw-r--r--news/inn/pkg-plist30
2 files changed, 16 insertions, 20 deletions
diff --git a/news/inn/Makefile b/news/inn/Makefile
index b2dd16b8b9b5..e74ac9943ef6 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -60,7 +60,6 @@ CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man \
UUCP_RNEWS_CONFIGURE_ON=--enable-uucp-rnews
UUCP_RNEWS_RUN_DEPENDS= uucp:net/freebsd-uucp
-SETGID_INEWS_CONFIGURE_ON= --enable-setgid-inews
INNLIB_LONG= 4.0.0
LIBVER_LONG= 3.0.1
@@ -129,6 +128,11 @@ BUILD_DEPENDS+= gpg:security/gnupg
RUN_DEPENDS+= gpg:security/gnupg
.endif
+.if ${PORT_OPTIONS:MSETGID_INEWS}
+PLIST_SUB+= MODE_INEWS="2555"
+.else
+PLIST_SUB+= MODE_INEWS=""
+.endif
PORTDOCS= CONTRIBUTORS HACKING INSTALL LICENSE MANIFEST NEWS README TODO
TO_BE_STRIPPED= bin/actsync bin/archive bin/auth/passwd/auth_krb5 \
diff --git a/news/inn/pkg-plist b/news/inn/pkg-plist
index 3458b8ea4fc5..38b4f999d573 100644
--- a/news/inn/pkg-plist
+++ b/news/inn/pkg-plist
@@ -1,16 +1,12 @@
@owner news
@group news
-@exec mkdir -p %%NEWSBASE%%
+@preexec mkdir -p %%NEWSBASE%%
%%CWDNEWSBASE%%
bin/actmerge
bin/actsync
bin/actsyncd
bin/archive
-@owner root
-@mode 4550
-bin/auth/passwd/ckpasswd
-@mode
-@owner news
+@(root,,4550) bin/auth/passwd/ckpasswd
%%KERBEROS%%bin/auth/passwd/auth_krb5
bin/auth/passwd/radius
bin/auth/resolv/domain
@@ -53,14 +49,10 @@ bin/filter/startup_innd.pl
bin/getlist
bin/grephistory
bin/imapfeed
-bin/inews
+@(,news,%%MODE_INEWS%%) bin/inews
bin/inncheck
bin/innconfval
-@owner root
-@mode 4550
-bin/innbind
-@mode
-@owner news
+@(root,,4550) bin/innbind
bin/innd
bin/inndf
bin/innfeed
@@ -352,12 +344,12 @@ man/man8/writelog.8.gz
@sample %%DBDIR%%/active.times.sample
@sample %%DBDIR%%/newsgroups.sample
@comment --------------------------------------------------------------
-%%WITHOUT_TAGGED_HASH%%@unexec f=history.hash; if cmp -s %%DBDIR%%/$f %%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
-%%WITHOUT_TAGGED_HASH%%@unexec f=history.index; if cmp -s %%DBDIR%%/$f %%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
-%%WITHOUT_TAGGED_HASH%%@unexec rm -f %%EXAMPLESDIR%%/db/history.hash 2> /dev/null || true
-%%WITHOUT_TAGGED_HASH%%@unexec rm -f %%EXAMPLESDIR%%/db/history.index 2> /dev/null || true
-%%WITH_TAGGED_HASH%%@unexec f=history.pag; if cmp -s %%DBDIR%%/$f %%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
-%%WITH_TAGGED_HASH%%@unexec rm -f %%EXAMPLESDIR%%/db/history.pag 2> /dev/null || true
+%%WITHOUT_TAGGED_HASH%%@postunexec f=history.hash; if cmp -s %%DBDIR%%/$f %%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
+%%WITHOUT_TAGGED_HASH%%@postunexec f=history.index; if cmp -s %%DBDIR%%/$f %%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
+%%WITHOUT_TAGGED_HASH%%@postunexec rm -f %%EXAMPLESDIR%%/db/history.hash 2> /dev/null || true
+%%WITHOUT_TAGGED_HASH%%@postunexec rm -f %%EXAMPLESDIR%%/db/history.index 2> /dev/null || true
+%%WITH_TAGGED_HASH%%@postunexec f=history.pag; if cmp -s %%DBDIR%%/$f %%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
+%%WITH_TAGGED_HASH%%@postunexec rm -f %%EXAMPLESDIR%%/db/history.pag 2> /dev/null || true
@sample %%CONFDIR%%/actsync.cfg.sample
@sample %%CONFDIR%%/actsync.ign.sample
@sample %%CONFDIR%%/buffindexed.conf.sample
@@ -404,4 +396,4 @@ man/man8/writelog.8.gz
@dir %%DBDIR%%
@dir %%LOGDIR%%/OLD
@dir %%LOGDIR%%
-@unexec rmdir %%NEWSBASE%% 2>/dev/null ||( echo "===> If you don't plan to use inn later, you can safely remove %%NEWSBASE%%. Deinstall process kept these files intact:" | fmt && for i in $(find %D/news -type f); do echo " - $i"; done)
+@postunexec rmdir %%NEWSBASE%% 2>/dev/null ||( echo "===> If you don't plan to use inn later, you can safely remove %%NEWSBASE%%. Deinstall process kept these files intact:" | fmt && for i in $(find %D/news -type f); do echo " - $i"; done)