aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /news
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
Notes
Diffstat (limited to 'news')
-rw-r--r--news/grn/Makefile2
-rw-r--r--news/klibido/Makefile2
-rw-r--r--news/knews/Makefile4
-rw-r--r--news/knews/files/patch-Imakefile12
-rw-r--r--news/knews/files/patch-png.c22
-rw-r--r--news/lottanzb/Makefile2
-rw-r--r--news/pan/Makefile2
-rw-r--r--news/slrn/Makefile2
-rw-r--r--news/slrnconf/Makefile2
-rw-r--r--news/tin/Makefile2
10 files changed, 36 insertions, 16 deletions
diff --git a/news/grn/Makefile b/news/grn/Makefile
index 1cd3b1a1d4bd..73bb036dc688 100644
--- a/news/grn/Makefile
+++ b/news/grn/Makefile
@@ -7,7 +7,7 @@
PORTNAME= grn
PORTVERSION= 0.0.28
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= news gnome
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/pre-${PORTVERSION}
diff --git a/news/klibido/Makefile b/news/klibido/Makefile
index b36a8eb6bc65..575b67d63304 100644
--- a/news/klibido/Makefile
+++ b/news/klibido/Makefile
@@ -7,7 +7,7 @@
PORTNAME= klibido
PORTVERSION= 0.2.5
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= news
MASTER_SITES= SF
diff --git a/news/knews/Makefile b/news/knews/Makefile
index 4e6c1d6f7fe3..b26be5a1b675 100644
--- a/news/knews/Makefile
+++ b/news/knews/Makefile
@@ -7,7 +7,7 @@
PORTNAME= knews
PORTVERSION= 1.0b.1
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= news
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR=dinoex
@@ -16,7 +16,7 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= A threaded nntp newsreader for X
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
compface:${PORTSDIR}/mail/faces
RUN_DEPENDS= newsp:${PORTSDIR}/print/mp-letter
diff --git a/news/knews/files/patch-Imakefile b/news/knews/files/patch-Imakefile
new file mode 100644
index 000000000000..926c9ba08eaa
--- /dev/null
+++ b/news/knews/files/patch-Imakefile
@@ -0,0 +1,12 @@
+--- src/Imakefile.orig 1998-11-21 16:31:37.000000000 +0100
++++ src/Imakefile 2012-05-06 18:07:58.000000000 +0200
+@@ -35,7 +35,8 @@
+ COMPFACE_LIB =
+ #endif
+
+-INCLUDES = -I../Widgets $(REGEXP_INCLUDES) $(KNEWS_INCLUDES)
++INCLUDES = -I../Widgets $(REGEXP_INCLUDES) $(KNEWS_INCLUDES) -I${LOCALBASE}/include/libpng15
++
+
+ LOCAL_LIBRARIES = \
+ -L../Widgets -lWidgets $(REGEXP_LIB) $(JPEG_LIB) $(PNG_LIB) \
diff --git a/news/knews/files/patch-png.c b/news/knews/files/patch-png.c
index 999e7c7e5007..22eed8a7c1c3 100644
--- a/news/knews/files/patch-png.c
+++ b/news/knews/files/patch-png.c
@@ -1,6 +1,14 @@
--- src/png.c.orig 1998-11-21 15:55:13.000000000 +0100
-+++ src/png.c 2010-09-15 07:51:20.000000000 +0200
-@@ -76,10 +76,16 @@
++++ src/png.c 2012-05-06 13:39:28.000000000 +0200
+@@ -20,6 +20,7 @@
+ #else
+
+ #include <png.h>
++#include <pngpriv.h>
+ #include <setjmp.h>
+
+ static unsigned int p_cmap_inited = False;
+@@ -76,10 +77,16 @@
return fp;
}
@@ -19,7 +27,7 @@
Pixmap pixmap;
FILE *volatile vol_fp = NULL;
void *volatile vol_pic = NULL;
-@@ -92,13 +98,21 @@
+@@ -92,13 +99,21 @@
init_png_cmap();
@@ -46,7 +54,7 @@
ArtTextAddLine(main_widgets.text, "[knews: png error.]",
ascii_font->body_font, global.alert_pixel);
else {
-@@ -108,58 +122,55 @@
+@@ -108,58 +123,55 @@
unsigned int per_line = 0;
unsigned int i, j, pass;
@@ -117,7 +125,7 @@
vol_pn = pn;
} else {
- png_set_dither(&p_str, p_cmap, cmap_size,
-+ png_set_dither(png_ptr, p_cmap, cmap_size,
++ png_set_quantize(png_ptr, p_cmap, cmap_size,
cmap_size, NULL, True);
}
@@ -128,7 +136,7 @@
vol_pic = pic = (unsigned char *)XtMalloc(h * per_line);
-@@ -167,14 +178,14 @@
+@@ -167,14 +179,14 @@
for (i = 0 ; i < pass ; i++) {
row = pic;
for (j = 0 ; j < h ; j++) {
@@ -145,7 +153,7 @@
}
if (!vol_did)
-@@ -204,7 +215,7 @@
+@@ -204,7 +216,7 @@
}
}
diff --git a/news/lottanzb/Makefile b/news/lottanzb/Makefile
index d80439478dc3..7220d6b2f642 100644
--- a/news/lottanzb/Makefile
+++ b/news/lottanzb/Makefile
@@ -8,7 +8,7 @@
PORTNAME= lottanzb
PORTVERSION= 0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= news
MASTER_SITES= http://www.lottanzb.org/releases/ \
http://launchpadlibrarian.net/64247317/ \
diff --git a/news/pan/Makefile b/news/pan/Makefile
index 19254d462512..ea89645b336c 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -8,7 +8,7 @@
PORTNAME= pan
PORTVERSION= 0.135
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/source/
DIST_SUBDIR= gnome2
diff --git a/news/slrn/Makefile b/news/slrn/Makefile
index 3dcaffa5f0f1..b8a38ece4d55 100644
--- a/news/slrn/Makefile
+++ b/news/slrn/Makefile
@@ -7,7 +7,7 @@
PORTNAME= slrn
PORTVERSION= 0.9.9p1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= news ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
ftp://angel.sovam.com/pub/tools/net/news/ \
diff --git a/news/slrnconf/Makefile b/news/slrnconf/Makefile
index 2d93821d3812..e34ad704925d 100644
--- a/news/slrnconf/Makefile
+++ b/news/slrnconf/Makefile
@@ -6,7 +6,7 @@
PORTNAME= slrnconf
PORTVERSION= 0.8.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= news
MASTER_SITES= http://home.arcor.de/kaffeetisch/downloads/
diff --git a/news/tin/Makefile b/news/tin/Makefile
index 36a4716a6937..9ecd4a234c34 100644
--- a/news/tin/Makefile
+++ b/news/tin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tin
PORTVERSION= 2.0.1
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES+= news ipv6
MASTER_SITES= ftp://ftp.tin.org/pub/news/clients/tin/v${PORTVERSION:R}/ \
ftp://ftp.sunet.se/pub/news/readers/tin/v${PORTVERSION:R}/ \