aboutsummaryrefslogtreecommitdiff
path: root/palm/gnome-pilot-conduits/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-03-21 17:59:52 +0000
committerAde Lovett <ade@FreeBSD.org>2000-03-21 17:59:52 +0000
commitb1b8bba31a1fc1d4217d4602e5c94c1fbe303f45 (patch)
tree20ad6de9f5e4dfdd85dc9ed9a11294953d28576a /palm/gnome-pilot-conduits/Makefile
parent824a3601989caf6dff5c918b1cd09229520cee9e (diff)
downloadports-b1b8bba31a1fc1d4217d4602e5c94c1fbe303f45.tar.gz
ports-b1b8bba31a1fc1d4217d4602e5c94c1fbe303f45.zip
Notes
Diffstat (limited to 'palm/gnome-pilot-conduits/Makefile')
-rw-r--r--palm/gnome-pilot-conduits/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/palm/gnome-pilot-conduits/Makefile b/palm/gnome-pilot-conduits/Makefile
new file mode 100644
index 000000000000..2615364c2030
--- /dev/null
+++ b/palm/gnome-pilot-conduits/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gnomepilot-conduits
+# Version required: 0.1
+# Date created: 16th March 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+
+DISTNAME= gnome-pilot-conduits-0.1
+PKGNAME= gnomepilot-conduits-0.1
+CATEGORIES= palm comms gnome
+MASTER_SITES= http://www.gnome.org/gnome-pilot/download/
+
+MAINTAINER= ade@FreeBSD.org
+
+BUILD_DEPENDS= gnome-pilot-config:${PORTSDIR}/palm/gnomepilot
+LIB_DEPENDS= pisock.3:${PORTSDIR}/palm/pilot-link \
+ capplet.1:${PORTSDIR}/sysutils/gnomecontrolcenter
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+LIBTOOLFILES= configure mal-conduit/configure
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" GLIB_CONFIG="${GLIB_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/pilot/include" \
+ LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/pilot/lib"
+
+.include <bsd.port.mk>