aboutsummaryrefslogtreecommitdiff
path: root/palm/makeztxt/files
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-01 15:00:27 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-01 15:00:27 +0000
commit2fb00cea5e283bc5a0315c853028fae9b0cc2667 (patch)
treee3d01326aea1bb2e4bb2ec329ce6a3ef210b55f4 /palm/makeztxt/files
parent302f92989c1ea539480ad05dd0bcc91c8cec833b (diff)
downloadports-2fb00cea5e283bc5a0315c853028fae9b0cc2667.tar.gz
ports-2fb00cea5e283bc5a0315c853028fae9b0cc2667.zip
Notes
Diffstat (limited to 'palm/makeztxt/files')
-rw-r--r--palm/makeztxt/files/patch-Makefile20
-rw-r--r--palm/makeztxt/files/patch-libztxt::ztxt.h10
-rw-r--r--palm/makeztxt/files/patch-libztxt::ztxt_generate_db.c10
-rw-r--r--palm/makeztxt/files/patch-libztxt::ztxt_init.c10
-rw-r--r--palm/makeztxt/files/patch-libztxt::ztxt_list_bookmarks.c10
-rw-r--r--palm/makeztxt/files/patch-libztxt::ztxt_process.c19
-rw-r--r--palm/makeztxt/files/patch-libztxt::ztxt_set.c10
7 files changed, 5 insertions, 84 deletions
diff --git a/palm/makeztxt/files/patch-Makefile b/palm/makeztxt/files/patch-Makefile
index f3282e6da984..0785f9eff2d3 100644
--- a/palm/makeztxt/files/patch-Makefile
+++ b/palm/makeztxt/files/patch-Makefile
@@ -1,26 +1,16 @@
---- Makefile.orig Sat Oct 19 15:38:34 2002
-+++ Makefile Sat Oct 19 15:40:04 2002
-@@ -9,8 +9,8 @@
+--- ./Makefile.orig Mon May 1 14:39:51 2006
++++ ./Makefile Mon May 1 14:40:05 2006
+@@ -9,8 +9,7 @@
LIBS = -lztxt
INCLUDE = -I../common -I.
-CC = gcc
-CFLAGS = -Wall -O2 -pipe $(INCLUDE)
-+CC ?= cc
-+CFLAGS += -Wall $(INCLUDE)
++CFLAGS = -Wall $(INCLUDE)
# GNU make is mandatory
#MAKE = make
-@@ -29,7 +29,7 @@
- # more featureful and faster (on large strings) than POSIX regex.
- # But... maybe you don't have GNU regex.
- # In particular, if compiling with Cygwin, you need this.
--#USEPOSIX = 1
-+USEPOSIX = 1
-
- # DOS, in all its infinite wisdom, decided long ago to differentiate between
- # text files and binary files. Text files get their \n converted to \r\n and
-@@ -44,7 +44,7 @@
+@@ -44,7 +43,7 @@
# If you're on a system that does not have getopt.h or does not have the
# getopt_long() function, comment this out. Regular getopt() will be used.
diff --git a/palm/makeztxt/files/patch-libztxt::ztxt.h b/palm/makeztxt/files/patch-libztxt::ztxt.h
deleted file mode 100644
index ece5f2bf4a7f..000000000000
--- a/palm/makeztxt/files/patch-libztxt::ztxt.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- libztxt/ztxt.h.old Sat Mar 2 07:03:18 2002
-+++ libztxt/ztxt.h Sun Sep 29 15:46:52 2002
-@@ -31,6 +31,7 @@
- #define _ZTXT_H_ 1
-
-
-+#include <sys/types.h>
- #include <regex.h>
- #include "databaseHdrs.h"
- #include <weasel_common.h>
diff --git a/palm/makeztxt/files/patch-libztxt::ztxt_generate_db.c b/palm/makeztxt/files/patch-libztxt::ztxt_generate_db.c
deleted file mode 100644
index bb3f3843ffe7..000000000000
--- a/palm/makeztxt/files/patch-libztxt::ztxt_generate_db.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libztxt/ztxt_generate_db.c.old Sat Mar 2 07:03:18 2002
-+++ libztxt/ztxt_generate_db.c Sun Sep 29 15:51:55 2002
-@@ -30,6 +30,7 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <string.h>
-+#include <sys/types.h>
- #include <netinet/in.h>
- #include <regex.h>
- #include "ztxt.h"
diff --git a/palm/makeztxt/files/patch-libztxt::ztxt_init.c b/palm/makeztxt/files/patch-libztxt::ztxt_init.c
deleted file mode 100644
index 25463ba72d1f..000000000000
--- a/palm/makeztxt/files/patch-libztxt::ztxt_init.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libztxt/ztxt_init.c.old Sat Mar 2 07:03:18 2002
-+++ libztxt/ztxt_init.c Sun Sep 29 15:52:33 2002
-@@ -30,6 +30,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <time.h>
-+#include <sys/types.h>
- #include <netinet/in.h>
- #include "ztxt.h"
-
diff --git a/palm/makeztxt/files/patch-libztxt::ztxt_list_bookmarks.c b/palm/makeztxt/files/patch-libztxt::ztxt_list_bookmarks.c
deleted file mode 100644
index 01a83d076112..000000000000
--- a/palm/makeztxt/files/patch-libztxt::ztxt_list_bookmarks.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libztxt/ztxt_list_bookmarks.c.old Sat Mar 2 07:03:18 2002
-+++ libztxt/ztxt_list_bookmarks.c Sun Sep 29 15:52:10 2002
-@@ -29,6 +29,7 @@
-
- #include <stdio.h>
- #include <string.h>
-+#include <sys/types.h>
- #include <regex.h>
-
- #include "ztxt.h"
diff --git a/palm/makeztxt/files/patch-libztxt::ztxt_process.c b/palm/makeztxt/files/patch-libztxt::ztxt_process.c
deleted file mode 100644
index 6a316a66e6b0..000000000000
--- a/palm/makeztxt/files/patch-libztxt::ztxt_process.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- libztxt/ztxt_process.c.orig Sat Mar 2 07:03:18 2002
-+++ libztxt/ztxt_process.c Sat Aug 14 13:35:00 2004
-@@ -30,6 +30,7 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <string.h>
-+#include <sys/types.h>
- #include <regex.h>
- #include <zlib.h>
- #include "ztxt.h"
-@@ -140,7 +141,7 @@
- break;
-
- case 2:
-- default:
-+ default:;
- /* Just leave the next alone. No linefeed stripping. */
- }
-
diff --git a/palm/makeztxt/files/patch-libztxt::ztxt_set.c b/palm/makeztxt/files/patch-libztxt::ztxt_set.c
deleted file mode 100644
index 3985cc0fb2c6..000000000000
--- a/palm/makeztxt/files/patch-libztxt::ztxt_set.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libztxt/ztxt_set.c.old Sat Mar 2 07:03:18 2002
-+++ libztxt/ztxt_set.c Sun Sep 29 15:52:21 2002
-@@ -28,6 +28,7 @@
- */
-
- #include <string.h>
-+#include <sys/types.h>
- #include <netinet/in.h>
- #include "ztxt.h"
-