aboutsummaryrefslogtreecommitdiff
path: root/palm/pilot-link-devel/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-08-26 15:25:02 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-08-26 15:25:02 +0000
commite88aeb8cf16929500e4f47eb539d6f9b66fa2c63 (patch)
tree6dc74624674736672a1ea6a9d7e77cda95eca239 /palm/pilot-link-devel/Makefile
parent2a013fa858bf73724d86cde8b49d40bccfda33ab (diff)
downloadports-e88aeb8cf16929500e4f47eb539d6f9b66fa2c63.tar.gz
ports-e88aeb8cf16929500e4f47eb539d6f9b66fa2c63.zip
Notes
Diffstat (limited to 'palm/pilot-link-devel/Makefile')
-rw-r--r--palm/pilot-link-devel/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/palm/pilot-link-devel/Makefile b/palm/pilot-link-devel/Makefile
index c9b118d84991..cbe142050468 100644
--- a/palm/pilot-link-devel/Makefile
+++ b/palm/pilot-link-devel/Makefile
@@ -8,15 +8,13 @@
PORTNAME= pilot-link
PORTVERSION= 0.11.8
PORTREVISION= 3
-CATEGORIES= palm comms tk84
+CATEGORIES= palm comms
MASTER_SITES= ${MASTER_SITE_GENTOO}
MASTER_SITE_SUBDIR= distfiles
MAINTAINER= ports@FreeBSD.org
COMMENT= PalmPilot communications utilities (backup/restore/install/debug/...)
-LIB_DEPENDS= tk${TCL_VER:S/.//}:${PORTSDIR}/x11-toolkits/tk${TCL_VER:S/.//}
-
USE_ICONV= yes
USE_GETOPT_LONG=yes
USE_BZIP2= yes
@@ -27,9 +25,20 @@ TCL_VER?= 8.4
CFLAGS+= -I${LOCALBASE}/include
HAS_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-perl5=${PERL5} --with-libiconv=${LOCALBASE} --with-tclinclude=${LOCALBASE}/include/tcl${TCL_VER}/ --with-tcl=${LOCALBASE}/lib/tcl${TCL_VER}/ --program-transform-name=
+CONFIGURE_ARGS+=--with-perl5=${PERL5} --with-libiconv=${LOCALBASE} --program-transform-name=
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+OPTIONS= TCL "Build Tcl/Tk bindings" off
+
.include "${.CURDIR}/manpages.mk"
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_TCL)
+LIB_DEPENDS+= tk${TCL_VER:S/.//}:${PORTSDIR}/x11-toolkits/tk${TCL_VER:S/.//}
+CONFIGURE_ARGS+=--with-tclinclude=${LOCALBASE}/include/tcl${TCL_VER}/ --with-tcl=${LOCALBASE}/lib/tcl${TCL_VER}/
+PLIST_SUB+= WITH_TCL=""
+.else
+PLIST_SUB+= WITH_TCL="@comment "
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>