aboutsummaryrefslogtreecommitdiff
path: root/palm/pilot-link-devel/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-02-01 16:28:50 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-02-01 16:28:50 +0000
commit47be87de4fa1f2069c7c015bdcc312a4f904a4d1 (patch)
tree3caf90fbae52d320292a763c07c329f239ce4038 /palm/pilot-link-devel/Makefile
parent443482caba37f58248fd73fa1e4805720d9edf1d (diff)
downloadports-47be87de4fa1f2069c7c015bdcc312a4f904a4d1.tar.gz
ports-47be87de4fa1f2069c7c015bdcc312a4f904a4d1.zip
Notes
Diffstat (limited to 'palm/pilot-link-devel/Makefile')
-rw-r--r--palm/pilot-link-devel/Makefile42
1 files changed, 23 insertions, 19 deletions
diff --git a/palm/pilot-link-devel/Makefile b/palm/pilot-link-devel/Makefile
index 8cbfd265e449..158f426c2375 100644
--- a/palm/pilot-link-devel/Makefile
+++ b/palm/pilot-link-devel/Makefile
@@ -6,39 +6,43 @@
#
PORTNAME= pilot-link
-PORTVERSION= 0.11.8
-PORTREVISION= 3
+DISTVERSION= 0.12.0-pre4
CATEGORIES= palm comms
-MASTER_SITES= ${MASTER_SITE_GENTOO}
-MASTER_SITE_SUBDIR= distfiles
+MASTER_SITES= http://katerina.frederic.k12.wi.us/mirror/pilot-link/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= PalmPilot communications utilities (backup/restore/install/debug/...)
+MAINTAINER= samm@os2.kiev.ua
+COMMENT= Suite of tools used to connect and sync your Palm handled
USE_ICONV= yes
USE_GETOPT_LONG=yes
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
-USE_PERL5= yes
-TCL_VER?= 8.4
-
-CFLAGS+= -I${LOCALBASE}/include
HAS_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-perl5=${PERL5} --with-libiconv=${LOCALBASE} --program-transform-name=
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+=--with-libiconv=${LOCALBASE}
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS:S/-Werror//}" # clear -Werror from CFLAGS
+
+OPTIONS= PNG "build with png support" off\
+ THREADS "built-in thread safety" on\
-OPTIONS= TCL "Build Tcl/Tk bindings" off
+PLIST_SUB+= PKGCONFIG_DIR=${PKGCONFIG_DIR}
.include "${.CURDIR}/manpages.mk"
.include <bsd.port.pre.mk>
-.if defined(WITH_TCL)
-LIB_DEPENDS+= tk${TCL_VER:S/.//}:${PORTSDIR}/x11-toolkits/tk${TCL_VER:S/.//}
-CONFIGURE_ARGS+=--with-tclinclude=${LOCALBASE}/include/tcl${TCL_VER}/ --with-tcl=${LOCALBASE}/lib/tcl${TCL_VER}/
-PLIST_SUB+= WITH_TCL=""
+post-patch:
+ @${REINPLACE_CMD} -e 's,^pkgconfigdir = .*$$,pkgconfigdir = ${PREFIX}/libdata/pkgconfig,' \
+ ${WRKSRC}/Makefile.in
+
+.if !defined(WITHOUT_THREADS)
+CONFIGURE_ARGS+= --enable-threads
+LDFLAGS+= ${PTHREAD_LIBS}
+.endif
+
+.if defined(WITH_PNG)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+CONFIGURE_ARGS+= --with-libpng=${PREFIX}
.else
-PLIST_SUB+= WITH_TCL="@comment "
+CONFIGURE_ARGS+= --disable-png
.endif
.include <bsd.port.post.mk>