aboutsummaryrefslogtreecommitdiff
path: root/palm/pilot-link/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-09-22 07:45:58 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-09-22 07:45:58 +0000
commit424d45ee0709648bb7fd498d97be8ae8bf9ac23b (patch)
tree2d59164739e2c1c8a23cfdd5c9661396c800d462 /palm/pilot-link/Makefile
parentb1000fb4e63ce8e0c77a5ab6a36fbc6aa849cb56 (diff)
downloadports-424d45ee0709648bb7fd498d97be8ae8bf9ac23b.tar.gz
ports-424d45ee0709648bb7fd498d97be8ae8bf9ac23b.zip
Notes
Diffstat (limited to 'palm/pilot-link/Makefile')
-rw-r--r--palm/pilot-link/Makefile47
1 files changed, 24 insertions, 23 deletions
diff --git a/palm/pilot-link/Makefile b/palm/pilot-link/Makefile
index 8851d52f1e06..c28c8bec947f 100644
--- a/palm/pilot-link/Makefile
+++ b/palm/pilot-link/Makefile
@@ -6,40 +6,41 @@
#
PORTNAME= pilot-link
-PORTVERSION= 0.11.8
-PORTREVISION= 4
+DISTVERSION= 0.12.1
PORTEPOCH= 1
CATEGORIES= palm comms
-MASTER_SITES= ${MASTER_SITE_GENTOO}
-MASTER_SITE_SUBDIR= distfiles
+MASTER_SITES= http://downloads.pilot-link.org/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= PalmPilot communications utilities (backup/restore/install/debug/...)
+MAINTAINER= samm@os2.kiev.ua
+COMMENT= Suite of tools used to connect and sync your Palm handled
+USE_BZIP2= yes
+FETCH_CMD= /usr/bin/fetch -pRr
USE_ICONV= yes
USE_GETOPT_LONG=yes
-USE_BZIP2= yes
+USE_GNOME= gnometarget gnomehack
GNU_CONFIGURE= yes
+CFLAGS+= -I${WRKSRC}/popt -I${LOCALBASE}/include
+CONFIGURE_ARGS+=--with-libiconv=${LOCALBASE} --with-included-popt --enable-conduits \
+ --mandir=${MANPREFIX}/man
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS:S/-Werror//}" # clear -Werror from CFLAGS
USE_LDCONFIG= yes
-USE_PERL5= yes
-TCL_VER?= 8.4
-CFLAGS+= -I${LOCALBASE}/include
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-perl5=${PERL5} --with-libiconv=${LOCALBASE} --program-transform-name=
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+OPTIONS= PNG "build with png support" off \
+ THREADS "built-in thread safety" on
-OPTIONS= TCL "Build Tcl/Tk bindings" off
-
-.include "${.CURDIR}/manpages.mk"
-.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_THREADS)
+CONFIGURE_ARGS+= --enable-threads
+LDFLAGS+= ${PTHREAD_LIBS}
+.endif
-.if defined(WITH_TCL)
-LIB_DEPENDS+= tk${TCL_VER:S/.//}:${PORTSDIR}/x11-toolkits/tk${TCL_VER:S/.//}
-CONFIGURE_ARGS+=--with-tclinclude=${LOCALBASE}/include/tcl${TCL_VER}/ --with-tcl=${LOCALBASE}/lib/tcl${TCL_VER}/
-PLIST_SUB+= WITH_TCL=""
+.if defined(WITH_PNG)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+CONFIGURE_ARGS+= --with-libpng=${PREFIX}
.else
-PLIST_SUB+= WITH_TCL="@comment "
+CONFIGURE_ARGS+= --disable-png
.endif
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/manpages.mk"
+
+.include <bsd.port.mk>