aboutsummaryrefslogtreecommitdiff
path: root/palm/pilot-link/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-02-02 17:11:04 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-02-02 17:11:04 +0000
commit28f9dc291236ced6dd21ca80dd5b629f35d68c60 (patch)
tree2fdd3cadfba3d879cfc35fbbba00145ec95c7f16 /palm/pilot-link/Makefile
parent0acc0ba51101895c8e83c6eaf482bfe02746e614 (diff)
downloadports-28f9dc291236ced6dd21ca80dd5b629f35d68c60.tar.gz
ports-28f9dc291236ced6dd21ca80dd5b629f35d68c60.zip
Notes
Diffstat (limited to 'palm/pilot-link/Makefile')
-rw-r--r--palm/pilot-link/Makefile43
1 files changed, 20 insertions, 23 deletions
diff --git a/palm/pilot-link/Makefile b/palm/pilot-link/Makefile
index 158f426c2375..7ff87df30306 100644
--- a/palm/pilot-link/Makefile
+++ b/palm/pilot-link/Makefile
@@ -6,43 +6,40 @@
#
PORTNAME= pilot-link
-DISTVERSION= 0.12.0-pre4
+PORTVERSION= 0.11.8
+PORTREVISION= 3
+PORTEPOCH= 1
CATEGORIES= palm comms
-MASTER_SITES= http://katerina.frederic.k12.wi.us/mirror/pilot-link/
+MASTER_SITES= ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR= distfiles
-MAINTAINER= samm@os2.kiev.ua
-COMMENT= Suite of tools used to connect and sync your Palm handled
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PalmPilot communications utilities (backup/restore/install/debug/...)
USE_ICONV= yes
USE_GETOPT_LONG=yes
USE_BZIP2= yes
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-libiconv=${LOCALBASE}
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS:S/-Werror//}" # clear -Werror from CFLAGS
+USE_PERL5= yes
+TCL_VER?= 8.4
-OPTIONS= PNG "build with png support" off\
- THREADS "built-in thread safety" on\
+CFLAGS+= -I${LOCALBASE}/include
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-perl5=${PERL5} --with-libiconv=${LOCALBASE} --program-transform-name=
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
-PLIST_SUB+= PKGCONFIG_DIR=${PKGCONFIG_DIR}
+OPTIONS= TCL "Build Tcl/Tk bindings" off
.include "${.CURDIR}/manpages.mk"
.include <bsd.port.pre.mk>
-post-patch:
- @${REINPLACE_CMD} -e 's,^pkgconfigdir = .*$$,pkgconfigdir = ${PREFIX}/libdata/pkgconfig,' \
- ${WRKSRC}/Makefile.in
-
-.if !defined(WITHOUT_THREADS)
-CONFIGURE_ARGS+= --enable-threads
-LDFLAGS+= ${PTHREAD_LIBS}
-.endif
-
-.if defined(WITH_PNG)
-LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
-CONFIGURE_ARGS+= --with-libpng=${PREFIX}
+.if defined(WITH_TCL)
+LIB_DEPENDS+= tk${TCL_VER:S/.//}:${PORTSDIR}/x11-toolkits/tk${TCL_VER:S/.//}
+CONFIGURE_ARGS+=--with-tclinclude=${LOCALBASE}/include/tcl${TCL_VER}/ --with-tcl=${LOCALBASE}/lib/tcl${TCL_VER}/
+PLIST_SUB+= WITH_TCL=""
.else
-CONFIGURE_ARGS+= --disable-png
+PLIST_SUB+= WITH_TCL="@comment "
.endif
.include <bsd.port.post.mk>