aboutsummaryrefslogtreecommitdiff
path: root/palm/pilot-link
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-09-23 08:21:41 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-09-23 08:21:41 +0000
commita8225c13eeecff21a0860855e95d40e88bd455af (patch)
treeb52ae9382f6e664238d8b9136f79d415c5b5df55 /palm/pilot-link
parentfd8db87ed7529b38d0d0dda7f17fa64e20ba7037 (diff)
Notes
Diffstat (limited to 'palm/pilot-link')
-rw-r--r--palm/pilot-link/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/palm/pilot-link/Makefile b/palm/pilot-link/Makefile
index c28c8bec947f..15e84e6212a0 100644
--- a/palm/pilot-link/Makefile
+++ b/palm/pilot-link/Makefile
@@ -9,13 +9,13 @@ PORTNAME= pilot-link
DISTVERSION= 0.12.1
PORTEPOCH= 1
CATEGORIES= palm comms
-MASTER_SITES= http://downloads.pilot-link.org/
+MASTER_SITES= http://www.mirrorservice.org/sites/master.us.finkmirrors.net/distfiles/ \
+ http://katerina.frederic.k12.wi.us/mirror/pilot-link/
MAINTAINER= samm@os2.kiev.ua
COMMENT= Suite of tools used to connect and sync your Palm handled
USE_BZIP2= yes
-FETCH_CMD= /usr/bin/fetch -pRr
USE_ICONV= yes
USE_GETOPT_LONG=yes
USE_GNOME= gnometarget gnomehack
@@ -23,17 +23,26 @@ GNU_CONFIGURE= yes
CFLAGS+= -I${WRKSRC}/popt -I${LOCALBASE}/include
CONFIGURE_ARGS+=--with-libiconv=${LOCALBASE} --with-included-popt --enable-conduits \
--mandir=${MANPREFIX}/man
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS:S/-Werror//}" # clear -Werror from CFLAGS
+CONFIGURE_ENV+= CFLAGS="${CFLAGS:S/-Werror//}" # clear -Werror from CFLAGS
USE_LDCONFIG= yes
OPTIONS= PNG "build with png support" off \
- THREADS "built-in thread safety" on
+ THREADS "built-in thread safety" on \
+ USB "Compile with USB via libusb support (READ MANUAL!)" off
+
+.include <bsd.port.pre.mk>
.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --enable-threads
LDFLAGS+= ${PTHREAD_LIBS}
.endif
+.if defined(WITH_USB)
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+CONFIGURE_ARGS+=--enable-libusb
+CONFIGURE_ENV+="LDFLAGS=${LDFLAGS} -L${PREFIX}/lib -lusb"
+.endif
+
.if defined(WITH_PNG)
LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+= --with-libpng=${PREFIX}
@@ -43,4 +52,4 @@ CONFIGURE_ARGS+= --disable-png
.include "${.CURDIR}/manpages.mk"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>