aboutsummaryrefslogtreecommitdiff
path: root/palm/syncmal
diff options
context:
space:
mode:
authorBill Fenner <fenner@FreeBSD.org>2001-03-22 22:33:13 +0000
committerBill Fenner <fenner@FreeBSD.org>2001-03-22 22:33:13 +0000
commitf18dceeb5fff06a9736ee26cdb13e58ff0609264 (patch)
treed3ee66c2ba0322df44b4fb6f7a4deee436399aea /palm/syncmal
parent11f69929229465741bf83ca387d8bf656366cec3 (diff)
downloadports-f18dceeb5fff06a9736ee26cdb13e58ff0609264.tar.gz
ports-f18dceeb5fff06a9736ee26cdb13e58ff0609264.zip
Notes
Diffstat (limited to 'palm/syncmal')
-rw-r--r--palm/syncmal/Makefile28
-rw-r--r--palm/syncmal/distinfo1
-rw-r--r--palm/syncmal/pkg-comment1
-rw-r--r--palm/syncmal/pkg-descr4
-rw-r--r--palm/syncmal/pkg-plist2
5 files changed, 36 insertions, 0 deletions
diff --git a/palm/syncmal/Makefile b/palm/syncmal/Makefile
new file mode 100644
index 000000000000..cf302b02530e
--- /dev/null
+++ b/palm/syncmal/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: syncmal
+# Date created: March 17, 2001
+# Whom: fenner
+#
+# $FreeBSD$
+#
+
+PORTNAME= syncmal
+PORTVERSION= 0.61
+CATEGORIES= palm
+MASTER_SITES= http://people.atl.mediaone.net/jasonday/code/syncmal/
+DISTNAME= jpilot-${PORTNAME}_${PORTVERSION}${EXTRACTSUFX}
+
+MAINTAINER= fenner@FreeBSD.Org
+
+BUILD_DEPENDS= /nonexistent:${PORTSDIR}/palm/jpilot:patch \
+ /nonexistent:${PORTSDIR}/palm/malsync:patch
+RUN_DEPENDS= jpilot:${PORTSDIR}/palm/jpilot
+
+PREFIX= ${LOCALBASE}/pilot
+USE_GMAKE= YES
+GNU_CONFIGURE= YES
+CONFIGURE_ENV= GTK_CONFIG=${X11BASE}/bin/gtk12-config
+CONFIGURE_ARGS= --with-pilot-prefix=${PREFIX} \
+ --with-plugin-prefix=${PORTSDIR}/palm/jpilot/work/jpilot-0.99 \
+ --with-mal-source=${PORTSDIR}/palm/malsync/work/malsync
+
+.include <bsd.port.mk>
diff --git a/palm/syncmal/distinfo b/palm/syncmal/distinfo
new file mode 100644
index 000000000000..d52915a19723
--- /dev/null
+++ b/palm/syncmal/distinfo
@@ -0,0 +1 @@
+MD5 (jpilot-syncmal_0.61.tar.gz) = 5dd7651107106c1e8d3c3025811aad31
diff --git a/palm/syncmal/pkg-comment b/palm/syncmal/pkg-comment
new file mode 100644
index 000000000000..ee5f0c68528b
--- /dev/null
+++ b/palm/syncmal/pkg-comment
@@ -0,0 +1 @@
+A MAL plugin for jpilot, to synchronize with services like AvantGo
diff --git a/palm/syncmal/pkg-descr b/palm/syncmal/pkg-descr
new file mode 100644
index 000000000000..25ca2b217430
--- /dev/null
+++ b/palm/syncmal/pkg-descr
@@ -0,0 +1,4 @@
+syncmal is a plugin for jpilot which allows syncrhonizing with
+MobileLink services that use malsync, e.g. AvantGo.
+
+WWW: http://people.atl.mediaone.net/jasonday/code/syncmal/syncmal.html
diff --git a/palm/syncmal/pkg-plist b/palm/syncmal/pkg-plist
new file mode 100644
index 000000000000..153556f64952
--- /dev/null
+++ b/palm/syncmal/pkg-plist
@@ -0,0 +1,2 @@
+lib/jpilot/plugins/libsyncmal.la
+lib/jpilot/plugins/libsyncmal.so