aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-10-05 21:36:02 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-10-05 21:36:02 +0000
commit8056faed0e81f5e4a4d137216479c717000d6d2b (patch)
tree87c286b3b3358431c22551b330e067884366b381 /palm
parent49d24ca54851e5a172df15248250aae70b8899bb (diff)
downloadports-8056faed0e81f5e4a4d137216479c717000d6d2b.tar.gz
ports-8056faed0e81f5e4a4d137216479c717000d6d2b.zip
Allow building on head
Notes
Notes: svn path=/head/; revision=370130
Diffstat (limited to 'palm')
-rw-r--r--palm/pilot-link/Makefile3
-rw-r--r--palm/pilot-link/files/patch-popt__popthelp.c11
-rw-r--r--palm/pilot-link/pkg-plist4
3 files changed, 13 insertions, 5 deletions
diff --git a/palm/pilot-link/Makefile b/palm/pilot-link/Makefile
index 0dea1209694c..ffb1df512e66 100644
--- a/palm/pilot-link/Makefile
+++ b/palm/pilot-link/Makefile
@@ -20,7 +20,7 @@ GNU_CONFIGURE= yes
CFLAGS+= -I${WRKSRC}/popt -I${LOCALBASE}/include
CONFIGURE_ARGS+=${ICONV_CONFIGURE_BASE} --with-included-popt --enable-conduits --enable-xsltproc
INSTALL_TARGET= install-strip
-USES= iconv libtool pathfix pkgconfig tar:bzip2
+USES= iconv libtool pathfix pkgconfig readline tar:bzip2
USE_LDCONFIG= yes
OPTIONS_DEFINE= PNG THREADS USB
@@ -49,6 +49,7 @@ CONFIGURE_ARGS+= --disable-png
.endif
post-patch:
+ @${REINPLACE_CMD} '/enable_werror="yes"/d' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|png_voidp_NULL|NULL|g' \
-e 's|png_error_ptr_NULL|NULL|g' \
${WRKSRC}/src/pilot-read-notepad.c \
diff --git a/palm/pilot-link/files/patch-popt__popthelp.c b/palm/pilot-link/files/patch-popt__popthelp.c
new file mode 100644
index 000000000000..ae0fb32d1736
--- /dev/null
+++ b/palm/pilot-link/files/patch-popt__popthelp.c
@@ -0,0 +1,11 @@
+--- popt/popthelp.c.orig 2004-08-25 15:06:39 UTC
++++ popt/popthelp.c
+@@ -683,7 +683,7 @@
+ s[0] = '\0';
+ /*@-branchstate@*/ /* FIX: W2DO? */
+ if (str == NULL) {
+- memset(s, 0, sizeof(s));
++ memset(s, 0, 300);
+ str = s;
+ }
+ /*@=branchstate@*/
diff --git a/palm/pilot-link/pkg-plist b/palm/pilot-link/pkg-plist
index 4d48838a6b13..e7698c73c954 100644
--- a/palm/pilot-link/pkg-plist
+++ b/palm/pilot-link/pkg-plist
@@ -137,7 +137,3 @@ man/man1/pilot-read-screenshot.1.gz
man/man1/pilot-read-todos.1.gz
man/man1/pilot-read-veo.1.gz
man/man7/pilot-link.7.gz
-@dirrm %%DATADIR%%/udev
-@dirrm %%DATADIR%%/prc
-@dirrm %%DATADIR%%/pix
-@dirrm %%DATADIR%%