aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 14:20:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 14:20:25 +0000
commit992586fa0863f8346a19cbcdfbba376c5c4dfd43 (patch)
tree87b239f8431cee200969f89da8739806496b7dad /palm
parentdc0ce8f5839343b4c972ae818337189b1b55d447 (diff)
downloadports-992586fa0863f8346a19cbcdfbba376c5c4dfd43.tar.gz
ports-992586fa0863f8346a19cbcdfbba376c5c4dfd43.zip
Notes
Diffstat (limited to 'palm')
-rw-r--r--palm/barry/Makefile2
-rw-r--r--palm/gnome-pilot/Makefile3
-rw-r--r--palm/jpilot/Makefile2
-rw-r--r--palm/pilot-link/Makefile3
4 files changed, 4 insertions, 6 deletions
diff --git a/palm/barry/Makefile b/palm/barry/Makefile
index b1e57288d0dd..35f0727b93cf 100644
--- a/palm/barry/Makefile
+++ b/palm/barry/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
USE_BZIP2= yes
USE_LDCONFIG= yes
-USE_PKGCONFIG= build
+USES= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= OPENSSL_CFLAGS=-I/usr/include \
OPENSSL_LIBS="-L/lib -lssl -lcrypto"
diff --git a/palm/gnome-pilot/Makefile b/palm/gnome-pilot/Makefile
index 6e5bca736e94..72e8c835abd4 100644
--- a/palm/gnome-pilot/Makefile
+++ b/palm/gnome-pilot/Makefile
@@ -14,10 +14,9 @@ COMMENT= PalmPilot conduit system for GNOME 2
BUILD_DEPENDS= gob2:${PORTSDIR}/devel/gob2
LIB_DEPENDS= pisock.9:${PORTSDIR}/palm/pilot-link
-USES= pathfix
+USES= pathfix pkgconfig
USE_BZIP2= yes
USE_GMAKE= yes
-USE_PKGCONFIG= build
USE_GNOME= gnomeprefix gnomehier gnomepanel intlhack \
ltverhack libgnomeui
USE_GETTEXT= yes
diff --git a/palm/jpilot/Makefile b/palm/jpilot/Makefile
index 0c626a61c8ab..bd0c55fd1566 100644
--- a/palm/jpilot/Makefile
+++ b/palm/jpilot/Makefile
@@ -16,8 +16,8 @@ COMMENT= Desktop Organizer Software for the Palm Pilot
LIB_DEPENDS= pisock.9:${PORTSDIR}/palm/pilot-link
USE_GCC= any
+USES= pkgconfig
USE_GMAKE= yes
-USE_PKGCONFIG= build
USE_GNOME= gnomehier
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/palm/pilot-link/Makefile b/palm/pilot-link/Makefile
index d36fcf8f742b..0a3e220ac0e0 100644
--- a/palm/pilot-link/Makefile
+++ b/palm/pilot-link/Makefile
@@ -13,10 +13,9 @@ COMMENT= Suite of tools used to connect and sync your Palm handled
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-USES= pathfix
+USES= pathfix pkgconfig
USE_BZIP2= yes
USE_ICONV= yes
-USE_PKGCONFIG= build
GNU_CONFIGURE= yes
CFLAGS+= -I${WRKSRC}/popt -I${LOCALBASE}/include
CONFIGURE_ARGS+=--with-libiconv=${LOCALBASE} --with-included-popt --enable-conduits --enable-xsltproc