aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2007-03-01 00:56:46 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2007-03-01 00:56:46 +0000
commit3da03c21abd1adf9981c30ac41bee46bd16573dc (patch)
tree132dac0669c3d6b590ce991b99f49dd7636728a6 /palm
parent1f5b041c977347cdf526ed06c19e5715ccdf33e8 (diff)
downloadports-3da03c21abd1adf9981c30ac41bee46bd16573dc.tar.gz
ports-3da03c21abd1adf9981c30ac41bee46bd16573dc.zip
Notes
Diffstat (limited to 'palm')
-rw-r--r--palm/palm-db-tools/Makefile4
-rw-r--r--palm/palm-db-tools/files/patch-libflatfile-DB.cpp31
-rw-r--r--palm/palm-db-tools/files/patch-libpalm-File.cpp11
3 files changed, 42 insertions, 4 deletions
diff --git a/palm/palm-db-tools/Makefile b/palm/palm-db-tools/Makefile
index d033bfa98065..63b87d90a25e 100644
--- a/palm/palm-db-tools/Makefile
+++ b/palm/palm-db-tools/Makefile
@@ -15,10 +15,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/g}
MAINTAINER= ijliao@FreeBSD.org
COMMENT= Utilities for the PalmOS flat-file database programs
-BROKEN= Does not build
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2007-04-10
-
WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/palm/palm-db-tools/files/patch-libflatfile-DB.cpp b/palm/palm-db-tools/files/patch-libflatfile-DB.cpp
new file mode 100644
index 000000000000..30d8c15dd8aa
--- /dev/null
+++ b/palm/palm-db-tools/files/patch-libflatfile-DB.cpp
@@ -0,0 +1,31 @@
+--- libflatfile/DB.cpp.orig Thu Jun 19 16:37:46 2003
++++ libflatfile/DB.cpp
+@@ -511,7 +511,8 @@
+ f.type = PalmLib::FlatFile::Field::LIST;
+ if (!field(j).argument().empty()) {
+ std::string data = field(j).argument();
+- unsigned int k, pos = 0;
++ unsigned int k;
++ size_t pos = 0;
+ pi_uint16_t itemID = *ptrs[j]; // TR: a list value is stored on 1 byte
+
+ for (k = 0; k < itemID; k++) {
+@@ -716,7 +717,8 @@
+ case PalmLib::FlatFile::Field::LIST:
+ if (!field(i).argument().empty()) {
+ std::string data = field(i).argument();
+- unsigned int pos = 0, next, j = 0;
++ size_t pos = 0, next;
++ unsigned int j = 0;
+ pi_int16_t itemID = -1;
+
+ while ( (next = data.find(charSeperator, pos)) != std::string::npos) {
+@@ -920,7 +922,7 @@
+ if (!field(i).argument().empty()) {
+ std::string data = field(i).argument();
+ std::vector<std::string> items;
+- unsigned int pos = 0, next;
++ size_t pos = 0, next;
+ std::vector<std::string>::iterator iter;
+ size = 2 + 2 * sizeof(pi_uint16_t);
+ while ( (next = data.find(charSeperator, pos)) != std::string::npos) {
diff --git a/palm/palm-db-tools/files/patch-libpalm-File.cpp b/palm/palm-db-tools/files/patch-libpalm-File.cpp
new file mode 100644
index 000000000000..6b2f601b2a6a
--- /dev/null
+++ b/palm/palm-db-tools/files/patch-libpalm-File.cpp
@@ -0,0 +1,11 @@
+--- libpalm/File.cpp.orig Thu Jun 19 16:37:47 2003
++++ libpalm/File.cpp
+@@ -270,7 +270,7 @@
+ }
+
+ if (m_sort_info.raw_size() > 0) {
+- f.write((char *) m_sort_info.raw_size(), m_sort_info.raw_size());
++ f.write((char *) m_sort_info.raw_data(), m_sort_info.raw_size());
+ if (!f)
+ throw PalmLib::error("unable to write sort info block");
+ }