aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-04-19 05:07:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-04-19 05:07:48 +0000
commit4e41411a0ddef1ac1a291231c15b629f4e848826 (patch)
treed3106512b5078842d6379c9adea9bbff5836b24a /palm
parent93cbd318b287433da9b84956d70fcfb1d19318de (diff)
downloadports-4e41411a0ddef1ac1a291231c15b629f4e848826.tar.gz
ports-4e41411a0ddef1ac1a291231c15b629f4e848826.zip
Notes
Diffstat (limited to 'palm')
-rw-r--r--palm/gnome-pilot-conduits/Makefile3
-rw-r--r--palm/gnomepilot-conduits2/Makefile3
2 files changed, 6 insertions, 0 deletions
diff --git a/palm/gnome-pilot-conduits/Makefile b/palm/gnome-pilot-conduits/Makefile
index 423be699ef3a..c75e59449c48 100644
--- a/palm/gnome-pilot-conduits/Makefile
+++ b/palm/gnome-pilot-conduits/Makefile
@@ -24,6 +24,7 @@ USE_X_PREFIX= yes
USE_BISON= yes
USE_GNOME= gnomeprefix gnomehack libgnome
USE_LIBTOOL= yes
+USE_REINPLACE= yes
CONFIGURE_ARGS= --with-pisock=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
@@ -31,5 +32,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' \
+ ${WRKSRC}/mal-conduit/mal/client/unix/MAL31DBConfig.c
.include <bsd.port.mk>
diff --git a/palm/gnomepilot-conduits2/Makefile b/palm/gnomepilot-conduits2/Makefile
index 423be699ef3a..c75e59449c48 100644
--- a/palm/gnomepilot-conduits2/Makefile
+++ b/palm/gnomepilot-conduits2/Makefile
@@ -24,6 +24,7 @@ USE_X_PREFIX= yes
USE_BISON= yes
USE_GNOME= gnomeprefix gnomehack libgnome
USE_LIBTOOL= yes
+USE_REINPLACE= yes
CONFIGURE_ARGS= --with-pisock=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
@@ -31,5 +32,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' \
+ ${WRKSRC}/mal-conduit/mal/client/unix/MAL31DBConfig.c
.include <bsd.port.mk>