aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-08-11 01:27:37 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-08-11 01:27:37 +0000
commit461f3c5adb635525af6de102321df3e6288bfb1c (patch)
tree2025e3327a038c580b6f13bdc201e220e2077bb4 /palm
parent5036b1c6d43d4a6652f933702bfcc8b3553fddfd (diff)
downloadports-461f3c5adb635525af6de102321df3e6288bfb1c.tar.gz
ports-461f3c5adb635525af6de102321df3e6288bfb1c.zip
Notes
Diffstat (limited to 'palm')
-rw-r--r--palm/Makefile1
-rw-r--r--palm/kpilot/Makefile48
-rw-r--r--palm/kpilot/distinfo2
-rw-r--r--palm/kpilot/pkg-descr4
-rw-r--r--palm/kpilot/pkg-plist134
5 files changed, 189 insertions, 0 deletions
diff --git a/palm/Makefile b/palm/Makefile
index 1dcc513f2f69..a64f0dc4ebbf 100644
--- a/palm/Makefile
+++ b/palm/Makefile
@@ -13,6 +13,7 @@
SUBDIR += isilo
SUBDIR += jfconv
SUBDIR += jpilot
+ SUBDIR += kpilot
SUBDIR += libmal
SUBDIR += makeztxt
SUBDIR += malsync
diff --git a/palm/kpilot/Makefile b/palm/kpilot/Makefile
new file mode 100644
index 000000000000..518586e509e0
--- /dev/null
+++ b/palm/kpilot/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: kpilot
+# Date created: June 19 2004
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kpilot
+PORTVERSION= ${KDE_VERSION}
+CATEGORIES= palm kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+PKGNAMEPREFIX= kdepim-
+DISTNAME= kdepim-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Hotsync software for KDE
+
+LIB_DEPENDS+= mal:${PORTSDIR}/palm/libmal \
+ pisock:${PORTSDIR}/palm/pilot-link
+
+CONFLICTS= kdepim-3.1.* kdepim-3.2.[0-3]
+
+USE_KDELIBS_VER=3
+PREFIX= ${KDE_PREFIX}
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/kdepim-${PORTVERSION}
+
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
+ ${ECHO_CMD} "libical libkcal kpilot doc" > ${WRKSRC}/inst-apps
+ ${REINPLACE_CMD} \
+ 's|^SUBDIRS =.*${PORTNAME}.*$$|SUBDIRS =\. ${PORTNAME}|g' \
+ ${WRKSRC}/doc/Makefile.in
+post-configure:
+ ${REINPLACE_CMD} -e 's|^install: install-recursive|install:|g' \
+ ${WRKSRC}/libkcal/Makefile
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.mk>
diff --git a/palm/kpilot/distinfo b/palm/kpilot/distinfo
new file mode 100644
index 000000000000..81c5588eeb22
--- /dev/null
+++ b/palm/kpilot/distinfo
@@ -0,0 +1,2 @@
+MD5 (KDE/kdepim-3.2.3.tar.bz2) = 06d3e5d1ee0cd7f2a55bd26d05ee4987
+SIZE (KDE/kdepim-3.2.3.tar.bz2) = 7711686
diff --git a/palm/kpilot/pkg-descr b/palm/kpilot/pkg-descr
new file mode 100644
index 000000000000..4c359cd02b03
--- /dev/null
+++ b/palm/kpilot/pkg-descr
@@ -0,0 +1,4 @@
+A hotsync client for KDE which integrates with KDE's personal information
+management.
+
+WWW: http://www.slac.com/pilone/kpilot_home/
diff --git a/palm/kpilot/pkg-plist b/palm/kpilot/pkg-plist
new file mode 100644
index 000000000000..36ae73c0e2df
--- /dev/null
+++ b/palm/kpilot/pkg-plist
@@ -0,0 +1,134 @@
+bin/kpalmdoc
+bin/kpilot
+bin/kpilotDaemon
+include/kpilot/kpilotlink.h
+include/kpilot/pilotDatabase.h
+include/kpilot/pilotLocalDatabase.h
+include/kpilot/pilotRecord.h
+include/kpilot/pilotSerialDatabase.h
+include/kpilot/plugin.h
+include/kpilot/syncAction.h
+include/kpilot/uiDialog.h
+lib/kde3/conduit_address.la
+lib/kde3/conduit_address.so
+lib/kde3/conduit_doc.la
+lib/kde3/conduit_doc.so
+lib/kde3/conduit_knotes.la
+lib/kde3/conduit_knotes.so
+lib/kde3/conduit_mal.la
+lib/kde3/conduit_mal.so
+lib/kde3/conduit_popmail.la
+lib/kde3/conduit_popmail.so
+lib/kde3/conduit_sysinfo.la
+lib/kde3/conduit_sysinfo.so
+lib/kde3/conduit_time.la
+lib/kde3/conduit_time.so
+lib/kde3/conduit_todo.la
+lib/kde3/conduit_todo.so
+lib/kde3/conduit_vcal.la
+lib/kde3/conduit_vcal.so
+lib/libkpilot.la
+lib/libkpilot.so
+lib/libkpilot.so.0
+share/applications/kde/kpalmdoc.desktop
+share/applications/kde/kpilot.desktop
+share/applications/kde/kpilotdaemon.desktop
+share/apps/kpilot/icons/crystalsvg/16x16/actions/backup.png
+share/apps/kpilot/icons/crystalsvg/16x16/actions/busysync.png
+share/apps/kpilot/icons/crystalsvg/16x16/actions/fastsync.png
+share/apps/kpilot/icons/crystalsvg/16x16/actions/hotsync.png
+share/apps/kpilot/icons/crystalsvg/16x16/actions/restore.png
+share/apps/kpilot/icons/crystalsvg/16x16/apps/kpalmdoc.png
+share/apps/kpilot/icons/crystalsvg/22x22/actions/backup.png
+share/apps/kpilot/icons/crystalsvg/22x22/actions/busysync.png
+share/apps/kpilot/icons/crystalsvg/22x22/actions/fastsync.png
+share/apps/kpilot/icons/crystalsvg/22x22/actions/hotsync.png
+share/apps/kpilot/icons/crystalsvg/22x22/actions/restore.png
+share/apps/kpilot/icons/crystalsvg/22x22/apps/kpalmdoc.png
+share/apps/kpilot/icons/crystalsvg/32x32/apps/kpalmdoc.png
+share/apps/kpilot/icons/crystalsvg/48x48/apps/kpalmdoc.png
+share/apps/kpilot/kpilot-address.png
+share/apps/kpilot/kpilot-calendar.png
+share/apps/kpilot/kpilot-db.png
+share/apps/kpilot/kpilot-fileinstaller.png
+share/apps/kpilot/kpilot-hotsync.png
+share/apps/kpilot/kpilot-knotes.png
+share/apps/kpilot/kpilot-splash.png
+share/apps/kpilot/kpilot-todo.png
+share/apps/kpilot/kpilotui.rc
+share/apps/kpilot/sysinfoconduit/Template.html
+share/apps/kpilot/sysinfoconduit/Template.txt
+share/doc/HTML/en/kdepim-apidocs/common
+share/doc/HTML/en/kpilot/address-app.png
+share/doc/HTML/en/kpilot/common
+share/doc/HTML/en/kpilot/conduit-knotes.png
+share/doc/HTML/en/kpilot/conduit-popmail-kmail.png
+share/doc/HTML/en/kpilot/conduit-popmail-recv-method.png
+share/doc/HTML/en/kpilot/conduit-popmail-send-as.png
+share/doc/HTML/en/kpilot/conduit-popmail-send-method.png
+share/doc/HTML/en/kpilot/conduit-popmail-sendmail.png
+share/doc/HTML/en/kpilot/conduit-popmail-smtp.png
+share/doc/HTML/en/kpilot/conduit-popmail-top.png
+share/doc/HTML/en/kpilot/conduit-vcal.png
+share/doc/HTML/en/kpilot/file-app.png
+share/doc/HTML/en/kpilot/index.cache.bz2
+share/doc/HTML/en/kpilot/index.docbook
+share/doc/HTML/en/kpilot/main-app.png
+share/doc/HTML/en/kpilot/memo-app.png
+share/doc/HTML/en/kpilot/setup-address.png
+share/doc/HTML/en/kpilot/setup-conduit.png
+share/doc/HTML/en/kpilot/setup-dbspecial.png
+share/doc/HTML/en/kpilot/setup-general.png
+share/doc/HTML/en/kpilot/setup-sync.png
+share/doc/HTML/en/kpilot/toolbar_backup.png
+share/doc/HTML/en/kpilot/toolbar_hotsync.png
+share/icons/crystalsvg/16x16/apps/kpalmdoc.png
+share/icons/crystalsvg/16x16/apps/kpilot.png
+share/icons/crystalsvg/16x16/apps/kpilotDaemon.png
+share/icons/crystalsvg/22x22/apps/kpalmdoc.png
+share/icons/crystalsvg/22x22/apps/kpilot.png
+share/icons/crystalsvg/32x32/apps/kpalmdoc.png
+share/icons/crystalsvg/32x32/apps/kpilot.png
+share/icons/crystalsvg/48x48/apps/kpalmdoc.png
+share/icons/crystalsvg/48x48/apps/kpilot.png
+share/icons/crystalsvg/48x48/apps/kpilotDaemon.png
+share/icons/locolor/16x16/apps/kpilot.png
+share/services/abbrowser_conduit.desktop
+share/services/doc_conduit.desktop
+share/services/knotes-conduit.desktop
+share/services/mal_conduit.desktop
+share/services/popmail-conduit.desktop
+share/services/sysinfo_conduit.desktop
+share/services/time_conduit.desktop
+share/services/todo-conduit.desktop
+share/services/vcal-conduit.desktop
+share/servicetypes/kpilotconduit.desktop
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kpilot/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kpilot/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kpilot/html
+@dirrm share/icons/locolor/16x16/apps
+@dirrm share/icons/locolor/16x16
+@dirrm share/icons/locolor
+@dirrm share/icons/crystalsvg/48x48/apps
+@dirrm share/icons/crystalsvg/32x32/apps
+@dirrm share/icons/crystalsvg/22x22/apps
+@dirrm share/icons/crystalsvg/16x16/apps
+@dirrm share/doc/HTML/en/kpilot
+@dirrm share/doc/HTML/en/kdepim-apidocs/kpilot/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/kpilot
+@dirrm share/doc/HTML/en/kdepim-apidocs
+@dirrm share/apps/kpilot/sysinfoconduit
+@dirrm share/apps/kpilot/icons/crystalsvg/48x48/apps
+@dirrm share/apps/kpilot/icons/crystalsvg/48x48
+@dirrm share/apps/kpilot/icons/crystalsvg/32x32/apps
+@dirrm share/apps/kpilot/icons/crystalsvg/32x32
+@dirrm share/apps/kpilot/icons/crystalsvg/22x22/apps
+@dirrm share/apps/kpilot/icons/crystalsvg/22x22/actions
+@dirrm share/apps/kpilot/icons/crystalsvg/22x22
+@dirrm share/apps/kpilot/icons/crystalsvg/16x16/apps
+@dirrm share/apps/kpilot/icons/crystalsvg/16x16/actions
+@dirrm share/apps/kpilot/icons/crystalsvg/16x16
+@dirrm share/apps/kpilot/icons/crystalsvg
+@dirrm share/apps/kpilot/icons
+@dirrm share/apps/kpilot
+@dirrm include/kpilot