aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2014-06-19 12:57:19 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2014-06-19 12:57:19 +0000
commit6cb35f638b94884dcefc254150b9e9c54e6f3016 (patch)
tree354c6334c8f8666bea5d395342e91c47a92ccb1b /palm
parente811fe34c015dbca33a0fc4fab1f98cf205b1cae (diff)
downloadports-6cb35f638b94884dcefc254150b9e9c54e6f3016.tar.gz
ports-6cb35f638b94884dcefc254150b9e9c54e6f3016.zip
Notes
Diffstat (limited to 'palm')
-rw-r--r--palm/jpilot-picsnvideos/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/palm/jpilot-picsnvideos/Makefile b/palm/jpilot-picsnvideos/Makefile
index 170f98dbe0eb..6bd9ca790294 100644
--- a/palm/jpilot-picsnvideos/Makefile
+++ b/palm/jpilot-picsnvideos/Makefile
@@ -11,9 +11,11 @@ PKGNAMEPREFIX= jpilot-
MAINTAINER= sklauder@trimind.de
COMMENT= JPilot plugin to download photos and videos
+LICENSE= GPLv2
+
RUN_DEPENDS= jpilot:${PORTSDIR}/palm/jpilot
BUILD_DEPENDS= jpilot:${PORTSDIR}/palm/jpilot
-LIB_DEPENDS= gdbm.4:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS= libgdbm.so:${PORTSDIR}/databases/gdbm
GNU_CONFIGURE= yes
@@ -22,16 +24,17 @@ PORTDOCS= README AUTHORS
PLIST_FILES= lib/jpilot/plugins/libpicsnvideos.la \
lib/jpilot/plugins/libpicsnvideos.so
-NO_STAGE= yes
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/configure
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
. for FILE in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
. endfor
.endif