aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-08-01 17:10:36 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-08-01 17:10:36 +0000
commit742ef15456339d991cdbeddf840ff4ea3c77c012 (patch)
treea819bc247ed3c3c237eb5b64cf49dabe3a1bd637 /palm
parent923873eef2e3c87910b2557d639a6c9fc1c921d8 (diff)
downloadports-742ef15456339d991cdbeddf840ff4ea3c77c012.tar.gz
ports-742ef15456339d991cdbeddf840ff4ea3c77c012.zip
Notes
Diffstat (limited to 'palm')
-rw-r--r--palm/synce-libsynce/Makefile2
-rw-r--r--palm/synce-libsynce/distinfo4
-rw-r--r--palm/synce-libsynce/files/patch-lib-files.c21
3 files changed, 24 insertions, 3 deletions
diff --git a/palm/synce-libsynce/Makefile b/palm/synce-libsynce/Makefile
index e06708c99fff..e2f80c6caebd 100644
--- a/palm/synce-libsynce/Makefile
+++ b/palm/synce-libsynce/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= synce-libsynce
-PORTVERSION= 0.9.0
+PORTVERSION= 0.9.1
CATEGORIES= palm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= synce
diff --git a/palm/synce-libsynce/distinfo b/palm/synce-libsynce/distinfo
index e50b2bbd7359..e7e5c2694abb 100644
--- a/palm/synce-libsynce/distinfo
+++ b/palm/synce-libsynce/distinfo
@@ -1,2 +1,2 @@
-MD5 (synce-libsynce-0.9.0.tar.gz) = 497efcbf55453da808041e7f8d55690b
-SIZE (synce-libsynce-0.9.0.tar.gz) = 348860
+MD5 (synce-libsynce-0.9.1.tar.gz) = 3fcffb776a5bedc23458152e5a650348
+SIZE (synce-libsynce-0.9.1.tar.gz) = 356343
diff --git a/palm/synce-libsynce/files/patch-lib-files.c b/palm/synce-libsynce/files/patch-lib-files.c
new file mode 100644
index 000000000000..eca6826ada9a
--- /dev/null
+++ b/palm/synce-libsynce/files/patch-lib-files.c
@@ -0,0 +1,21 @@
+--- lib/files.c.orig Tue May 17 01:42:34 2005
++++ lib/files.c Fri Jul 29 21:26:37 2005
+@@ -45,7 +45,8 @@
+ bool synce_get_directory(char** path)
+ {
+ char buffer[MAX_PATH];
+- char *p;
++ char *p;
++ struct passwd* user;
+
+ /* if there is a preference for config dir set
+ as an environment variable, use it */
+@@ -57,7 +58,7 @@
+ }
+
+ /* XXX: not very thread-safe? */
+- struct passwd* user = getpwuid(getuid());
++ user = getpwuid(getuid());
+
+ if (!path)
+ return false;