aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-29 16:33:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-29 16:33:02 +0000
commit1bcb81b7c9bc03f5cd64a0e85d3a5ee0d8d487cc (patch)
tree8075424c5a79dec64cbfcb0964535e79754bf2ed /palm
parent02f03a1e632aab78035b3ad5daf8b9e9af2c8114 (diff)
downloadports-1bcb81b7c9bc03f5cd64a0e85d3a5ee0d8d487cc.tar.gz
ports-1bcb81b7c9bc03f5cd64a0e85d3a5ee0d8d487cc.zip
Notes
Diffstat (limited to 'palm')
-rw-r--r--palm/Makefile1
-rw-r--r--palm/uppc-kmod/Makefile39
-rw-r--r--palm/uppc-kmod/distinfo1
-rw-r--r--palm/uppc-kmod/pkg-descr6
-rw-r--r--palm/uppc-kmod/pkg-plist2
5 files changed, 49 insertions, 0 deletions
diff --git a/palm/Makefile b/palm/Makefile
index 05d27ac11a96..32a874ac51c5 100644
--- a/palm/Makefile
+++ b/palm/Makefile
@@ -37,5 +37,6 @@
SUBDIR += synce-trayicon
SUBDIR += syncmal
SUBDIR += txt2pdbdoc
+ SUBDIR += uppc-kmod
.include <bsd.port.subdir.mk>
diff --git a/palm/uppc-kmod/Makefile b/palm/uppc-kmod/Makefile
new file mode 100644
index 000000000000..438e44d2d8ca
--- /dev/null
+++ b/palm/uppc-kmod/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: uppc-kmod
+# Date created: 31 August 2003
+# Whom: Sam Lawrance <boris@brooknet.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uppc
+PORTVERSION= 0.4
+CATEGORIES= palm
+MASTER_SITES= http://sam.stral.net/freebsd/
+PKGNAMESUFFIX= -kmod
+
+MAINTAINER= boris@brooknet.com.au
+COMMENT= USB device driver for Windows CE handhelds
+
+MAN4= uppc.4
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_REINPLACE= yes
+
+.if !exists(/usr/src/sys/dev/usb/usb.h)
+BROKEN= "Requires kernel source (/usr/src/sys) to build"
+.endif
+
+post-build:
+ @${REINPLACE_CMD} -e 's|%%INITIAL_INSTALLDIR%%|${PREFIX}/lib|g' ${BUILD_WRKSRC}/uppcsetup
+ @${REINPLACE_CMD} -e 's|%%INITIAL_MODDIR%%|${KMODDIR}|g' ${WRKSRC}/uppcsetup
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/uppc.ko ${PREFIX}/lib
+ ${INSTALL_SCRIPT} ${WRKSRC}/uppcsetup ${PREFIX}/sbin
+ cd ${WRKSRC} && ${INSTALL_MAN} ${MAN4} ${MANPREFIX}/man/man4
+
+post-install:
+ @${ECHO_CMD} " ****************************************************************"
+ @${ECHO_CMD} " * You can run 'uppcsetup' to help configure the device driver. *"
+ @${ECHO_CMD} " ****************************************************************"
+
+.include <bsd.port.mk>
diff --git a/palm/uppc-kmod/distinfo b/palm/uppc-kmod/distinfo
new file mode 100644
index 000000000000..f0a91727e3c1
--- /dev/null
+++ b/palm/uppc-kmod/distinfo
@@ -0,0 +1 @@
+MD5 (uppc-0.4.tar.gz) = 4a1e5bd35b10c2c6c720a302a38e0048
diff --git a/palm/uppc-kmod/pkg-descr b/palm/uppc-kmod/pkg-descr
new file mode 100644
index 000000000000..72bdaa338215
--- /dev/null
+++ b/palm/uppc-kmod/pkg-descr
@@ -0,0 +1,6 @@
+UPPC is a USB device driver that presents a tty style serial interface to
+Windows CE devices like Pocket PCs. This lets programs like those from the
+SynCE project access your device much faster than the standard serial
+interface.
+
+- Sam Lawrance <boris@brooknet.com.au>
diff --git a/palm/uppc-kmod/pkg-plist b/palm/uppc-kmod/pkg-plist
new file mode 100644
index 000000000000..39fb764909c4
--- /dev/null
+++ b/palm/uppc-kmod/pkg-plist
@@ -0,0 +1,2 @@
+lib/uppc.ko
+sbin/uppcsetup