aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-27 14:11:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-27 14:11:53 +0000
commit23d16d25283bee92abc67601729e1dedc991745c (patch)
tree7e88dbb09c8721755c1d6ffd2a5a446fb8368a93 /palm
parent73749bcf85f5c22fa06e45a0d6c90be7cf0452c1 (diff)
downloadports-23d16d25283bee92abc67601729e1dedc991745c.tar.gz
ports-23d16d25283bee92abc67601729e1dedc991745c.zip
Notes
Diffstat (limited to 'palm')
-rw-r--r--palm/Makefile2
-rw-r--r--palm/synce-dccm/Makefile28
-rw-r--r--palm/synce-dccm/distinfo3
-rw-r--r--palm/synce-dccm/files/patch-lib-localsocket.h10
-rw-r--r--palm/synce-dccm/files/patch-lib-tcpconnectedsocket.cpp14
-rw-r--r--palm/synce-dccm/files/patch-lib-tcpsocket.h10
-rw-r--r--palm/synce-dccm/files/patch-lib-udpsocket.cpp11
-rw-r--r--palm/synce-dccm/files/patch-src-vdccm.cpp11
-rw-r--r--palm/synce-dccm/files/patch-src_rapiclient.cpp14
-rw-r--r--palm/synce-dccm/files/patch-src_rapiconnection.cpp15
-rw-r--r--palm/synce-dccm/files/patch-src_rapihandshakeclient.cpp14
-rw-r--r--palm/synce-dccm/files/patch-src_rapiproxyconnection.cpp15
-rw-r--r--palm/synce-dccm/files/patch-src_windowscedevice.cpp15
-rw-r--r--palm/synce-dccm/files/patch-testtools-triggerconnection.cpp10
-rw-r--r--palm/synce-dccm/pkg-descr5
-rw-r--r--palm/synce-dccm/pkg-plist6
-rw-r--r--palm/synce-serial/Makefile2
17 files changed, 2 insertions, 183 deletions
diff --git a/palm/Makefile b/palm/Makefile
index fab6058c939c..deb171fbd504 100644
--- a/palm/Makefile
+++ b/palm/Makefile
@@ -32,7 +32,6 @@
SUBDIR += prc-tools
SUBDIR += romeo
SUBDIR += sitescooper
- SUBDIR += synce-dccm
SUBDIR += synce-gnomevfs
SUBDIR += synce-kde
SUBDIR += synce-librapi2
@@ -41,6 +40,7 @@
SUBDIR += synce-multisync
SUBDIR += synce-serial
SUBDIR += synce-trayicon
+ SUBDIR += synce-vdccm
SUBDIR += txt2pdbdoc
SUBDIR += uppc-kmod
diff --git a/palm/synce-dccm/Makefile b/palm/synce-dccm/Makefile
deleted file mode 100644
index c9b9f496286a..000000000000
--- a/palm/synce-dccm/Makefile
+++ /dev/null
@@ -1,28 +0,0 @@
-# New ports collection makefile for: synce-dccm
-# Date created: 14 June 2003
-# Whom: Sam Lawrance <boris@brooknet.com.au>
-#
-# $FreeBSD$
-
-PORTNAME= synce-dccm
-PORTVERSION= 0.9.3
-CATEGORIES= palm
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= synce
-DISTNAME= synce-vdccm-${PORTVERSION}
-
-MAINTAINER= ports@logvinov.com
-COMMENT= Listener daemon for connections from WinCE devices
-
-BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
-LIB_DEPENDS+= synce.0:${PORTSDIR}/palm/synce-libsynce
-
-GNU_CONFIGURE= yes
-USE_ICONV= yes
-WRKSRC= ${WRKDIR}/vdccm-${PORTVERSION}
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS+= --with-libiconv=${LOCALBASE} \
- --with-libsynce=${LOCALBASE}
-USE_LDCONFIG= yes
-
-.include <bsd.port.mk>
diff --git a/palm/synce-dccm/distinfo b/palm/synce-dccm/distinfo
deleted file mode 100644
index 4627849cf735..000000000000
--- a/palm/synce-dccm/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (synce-vdccm-0.9.3.tar.gz) = 996236320a6b4c9410050c4dc6e53164
-SHA256 (synce-vdccm-0.9.3.tar.gz) = e2e26ff503c242189c3cdc4778db72c38d28c86c0a18f7a1d2fda26801789571
-SIZE (synce-vdccm-0.9.3.tar.gz) = 354000
diff --git a/palm/synce-dccm/files/patch-lib-localsocket.h b/palm/synce-dccm/files/patch-lib-localsocket.h
deleted file mode 100644
index 8c38131e73bc..000000000000
--- a/palm/synce-dccm/files/patch-lib-localsocket.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/localsocket.h.orig Fri Jan 26 03:40:07 2007
-+++ lib/localsocket.h Fri Jan 26 03:40:23 2007
-@@ -24,6 +24,7 @@
- #define LOCALSOCKET_H
-
- #include <string>
-+#include <sys/socket.h>
- #include <sys/un.h>
- #include "netsocket.h"
-
diff --git a/palm/synce-dccm/files/patch-lib-tcpconnectedsocket.cpp b/palm/synce-dccm/files/patch-lib-tcpconnectedsocket.cpp
deleted file mode 100644
index 55ee2ae5e7e6..000000000000
--- a/palm/synce-dccm/files/patch-lib-tcpconnectedsocket.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- lib/tcpconnectedsocket.cpp.orig Thu Jun 29 22:01:48 2006
-+++ lib/tcpconnectedsocket.cpp Fri Jan 26 20:36:48 2007
-@@ -149,8 +149,10 @@
- int TCPConnectedSocket::getMTU()
- {
- int s;
-+ struct protoent *pent;
- socklen_t r = sizeof(int);
-- if (getsockopt(getDescriptor(), SOL_IP, IP_MTU, &s, &r) < 0) {
-+ pent = getprotobyname ("ip");
-+ if (getsockopt(getDescriptor(), ((pent != NULL) ? pent->p_proto : 0), IP_MTU, &s, &r) < 0) {
- s = -1;
- }
-
diff --git a/palm/synce-dccm/files/patch-lib-tcpsocket.h b/palm/synce-dccm/files/patch-lib-tcpsocket.h
deleted file mode 100644
index ca63569939d9..000000000000
--- a/palm/synce-dccm/files/patch-lib-tcpsocket.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/tcpsocket.h.orig Fri Jan 26 03:21:01 2007
-+++ lib/tcpsocket.h Fri Jan 26 03:21:48 2007
-@@ -24,6 +24,7 @@
- #define TCPSOCKET_H
-
- #include <string>
-+#include <sys/socket.h>
- #include <netinet/in.h>
- #include "netsocket.h"
-
diff --git a/palm/synce-dccm/files/patch-lib-udpsocket.cpp b/palm/synce-dccm/files/patch-lib-udpsocket.cpp
deleted file mode 100644
index 52c134c9b4c8..000000000000
--- a/palm/synce-dccm/files/patch-lib-udpsocket.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/udpsocket.cpp.orig Sun May 7 18:49:36 2006
-+++ lib/udpsocket.cpp Fri Jan 26 19:21:19 2007
-@@ -10,6 +10,8 @@
- //
- //
- #include "udpsocket.h"
-+#include <netinet/in.h>
-+#include <sys/socket.h>
- #include <netdb.h>
-
- using namespace std;
diff --git a/palm/synce-dccm/files/patch-src-vdccm.cpp b/palm/synce-dccm/files/patch-src-vdccm.cpp
deleted file mode 100644
index 13cef7eda098..000000000000
--- a/palm/synce-dccm/files/patch-src-vdccm.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/vdccm.cpp.orig Fri Jan 26 19:24:38 2007
-+++ src/vdccm.cpp Fri Jan 26 19:26:01 2007
-@@ -34,7 +34,7 @@
- #include <localserversocket.h>
- #include <synce_log.h>
- #include <iostream>
--#include <wait.h>
-+#include <sys/wait.h>
-
- using namespace synce;
- using namespace std;
diff --git a/palm/synce-dccm/files/patch-src_rapiclient.cpp b/palm/synce-dccm/files/patch-src_rapiclient.cpp
deleted file mode 100644
index 7a24377c0e59..000000000000
--- a/palm/synce-dccm/files/patch-src_rapiclient.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/rapiclient.cpp.orig 2008-04-15 11:35:52.000000000 +0200
-+++ src/rapiclient.cpp 2008-04-15 11:37:50.000000000 +0200
-@@ -20,6 +20,11 @@
- #include <errno.h>
- #include <synce.h>
-
-+#if defined(__FreeBSD__) && defined(__sparc64__)
-+#include <sys/endian.h>
-+#define bswap_16 bswap16
-+#define bswap_32 bswap32
-+#endif
-
- using namespace std;
-
diff --git a/palm/synce-dccm/files/patch-src_rapiconnection.cpp b/palm/synce-dccm/files/patch-src_rapiconnection.cpp
deleted file mode 100644
index 6e71e8857f03..000000000000
--- a/palm/synce-dccm/files/patch-src_rapiconnection.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/rapiconnection.cpp.orig 2008-04-15 11:39:02.000000000 +0200
-+++ src/rapiconnection.cpp 2008-04-15 11:39:14.000000000 +0200
-@@ -22,6 +22,12 @@
- #include "synce_log.h"
- #include <multiplexer.h>
-
-+#if defined(__FreeBSD__) && defined(__sparc64__)
-+#include <sys/endian.h>
-+#define bswap_16 bswap16
-+#define bswap_32 bswap32
-+#endif
-+
- using namespace std;
-
- RapiConnection::RapiConnection(RapiProxyFactory *proxyFactory, string path, RapiServer *rapiServer, string deviceIpAddress) : LocalServerSocket(proxyFactory, path), rapiHandshakeClient(NULL), deviceIpAddress(deviceIpAddress), rapiServer(rapiServer)
diff --git a/palm/synce-dccm/files/patch-src_rapihandshakeclient.cpp b/palm/synce-dccm/files/patch-src_rapihandshakeclient.cpp
deleted file mode 100644
index d95dace5b04a..000000000000
--- a/palm/synce-dccm/files/patch-src_rapihandshakeclient.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/rapihandshakeclient.cpp.orig 2008-04-15 11:38:15.000000000 +0200
-+++ src/rapihandshakeclient.cpp 2008-04-15 11:38:23.000000000 +0200
-@@ -17,6 +17,11 @@
- #include <udpsocket.h>
- #include <synce_log.h>
-
-+#if defined(__FreeBSD__) && defined(__sparc64__)
-+#include <sys/endian.h>
-+#define bswap_16 bswap16
-+#define bswap_32 bswap32
-+#endif
-
- RapiHandshakeClient::RapiHandshakeClient( int fd, TCPServerSocket *tcpServerSocket )
- : RapiClient( fd, tcpServerSocket )
diff --git a/palm/synce-dccm/files/patch-src_rapiproxyconnection.cpp b/palm/synce-dccm/files/patch-src_rapiproxyconnection.cpp
deleted file mode 100644
index 212d721fc8f6..000000000000
--- a/palm/synce-dccm/files/patch-src_rapiproxyconnection.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/rapiproxyconnection.cpp.orig 2008-04-15 11:39:47.000000000 +0200
-+++ src/rapiproxyconnection.cpp 2008-04-15 11:42:37.000000000 +0200
-@@ -19,6 +19,12 @@
-
- #include <iostream>
-
-+#if defined(__FreeBSD__) && defined(__sparc64__)
-+#include <sys/endian.h>
-+#define bswap_16 bswap16
-+#define bswap_32 bswap32
-+#endif
-+
- RapiProxyConnection::RapiProxyConnection(RapiConnection *rapiConnection, RapiProxy *rapiProxy,
- RapiProvisioningClient *rapiProvisioningClient)
- : rapiConnection(rapiConnection),
diff --git a/palm/synce-dccm/files/patch-src_windowscedevice.cpp b/palm/synce-dccm/files/patch-src_windowscedevice.cpp
deleted file mode 100644
index d11c8581e24b..000000000000
--- a/palm/synce-dccm/files/patch-src_windowscedevice.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/windowscedevice.cpp.orig 2008-04-15 11:28:35.000000000 +0200
-+++ src/windowscedevice.cpp 2008-04-15 11:37:11.000000000 +0200
-@@ -29,6 +29,12 @@
-
- #include <devicemanager.h>
-
-+#if defined(__FreeBSD__) && defined(__sparc64__)
-+#include <sys/endian.h>
-+#define bswap_16 bswap16
-+#define bswap_32 bswap32
-+#endif
-+
- using namespace std;
-
- WindowsCEDevice::WindowsCEDevice(int fd, TCPServerSocket *tcpServerSocket)
diff --git a/palm/synce-dccm/files/patch-testtools-triggerconnection.cpp b/palm/synce-dccm/files/patch-testtools-triggerconnection.cpp
deleted file mode 100644
index e06a9fa8720c..000000000000
--- a/palm/synce-dccm/files/patch-testtools-triggerconnection.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- testtools/triggerconnection.cpp.orig Fri Jan 26 19:27:52 2007
-+++ testtools/triggerconnection.cpp Fri Jan 26 19:28:25 2007
-@@ -16,6 +16,7 @@
- #include <unistd.h>
- #include <sys/types.h>
- #include <sys/socket.h>
-+#include <netinet/in.h>
-
-
- int main(int argc, char *argv[])
diff --git a/palm/synce-dccm/pkg-descr b/palm/synce-dccm/pkg-descr
deleted file mode 100644
index 92a7070accf9..000000000000
--- a/palm/synce-dccm/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-SynCE is a project for connecting to devices running Windows CE or Pocket PC.
-Dccm is a daemon that listens for connections from a Windows CE device.
-Once connected, the synce-librapi tools are able to interact with the device.
-
-WWW: http://synce.sourceforge.net/
diff --git a/palm/synce-dccm/pkg-plist b/palm/synce-dccm/pkg-plist
deleted file mode 100644
index cbdc5b6b9a9a..000000000000
--- a/palm/synce-dccm/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-bin/vdccm
-bin/proxyclient
-bin/triggerconnection
-lib/libdescriptor.la
-lib/libdescriptor.so
-lib/libdescriptor.so.0
diff --git a/palm/synce-serial/Makefile b/palm/synce-serial/Makefile
index 6850b3839bdd..68e3ae828439 100644
--- a/palm/synce-serial/Makefile
+++ b/palm/synce-serial/Makefile
@@ -13,7 +13,7 @@ MASTER_SITE_SUBDIR= synce
MAINTAINER= ports@logvinov.com
COMMENT= Wrapper for pppd to initiate communications with Windows Mobile devices
-RUN_DEPENDS= vdccm:${PORTSDIR}/palm/synce-dccm
+RUN_DEPENDS= vdccm:${PORTSDIR}/palm/synce-vdccm
CONFLICTS= synce-hal-[0-9]*