aboutsummaryrefslogtreecommitdiff
path: root/polish/ekg/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-07-10 19:41:30 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-07-10 19:41:30 +0000
commite482e392f687b2248d2975d68327324a858e1273 (patch)
treef00883f68004a81b9e525ad5cc94de309898b666 /polish/ekg/Makefile
parent5183b406511b98ffef72263a3609234aaaa0d4fb (diff)
Notes
Diffstat (limited to 'polish/ekg/Makefile')
-rw-r--r--polish/ekg/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/polish/ekg/Makefile b/polish/ekg/Makefile
index 64f33bea216f..4b230d8bc1e6 100644
--- a/polish/ekg/Makefile
+++ b/polish/ekg/Makefile
@@ -14,9 +14,8 @@ COMMENT= Text-mode Gadu-Gadu client
LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
gadu:${PORTSDIR}/polish/libgadu
-USE_GMAKE= yes
GNU_CONFIGURE= yes
-USES= pathfix pkgconfig
+USES= gmake pathfix pkgconfig
USE_LDCONFIG= yes
CONFIGURE_ARGS= --without-libungif \
@@ -33,16 +32,10 @@ MANCOMPRESSED= no
OPTIONS_DEFINE= ASPELL OPENSSL
OPTIONS_DEFAULT= OPENSSL
-.include <bsd.port.options.mk>
+ASPELL_CONFIGURE_ON= --enable-aspell
+ASPELL_LIB_DEPENDS= aspell:${PORTSDIR}/polish/aspell
-.if ${PORT_OPTIONS:MASPELL}
-LIB_DEPENDS+= aspell:${PORTSDIR}/polish/aspell
-CONFIGURE_ARGS+= --enable-aspell
-.endif
-
-.if ! ${PORT_OPTIONS:MOPENSSL}
-CONFIGURE_ARGS+= --without-openssl
-.endif
+OPENSSL_CONFIGURE_OFF= --without-openssl
post-install:
${STRIP_CMD} ${PREFIX}/bin/ekg