aboutsummaryrefslogtreecommitdiff
path: root/polish/ekg
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-10-04 10:48:50 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-10-04 10:48:50 +0000
commit0c06111c464371ac05e6e30d841fc4e86a2d5700 (patch)
treeaea79b8d9b683f52f70634531007aeb451f8f1ed /polish/ekg
parent60820d612b8a6b4b5700dd02145552bb0d6011f2 (diff)
downloadports-0c06111c464371ac05e6e30d841fc4e86a2d5700.tar.gz
ports-0c06111c464371ac05e6e30d841fc4e86a2d5700.zip
Notes
Diffstat (limited to 'polish/ekg')
-rw-r--r--polish/ekg/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/polish/ekg/Makefile b/polish/ekg/Makefile
index f6c4e4cb03c8..c17b049f9666 100644
--- a/polish/ekg/Makefile
+++ b/polish/ekg/Makefile
@@ -27,17 +27,17 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo ${PTHREAD_LIBS}
CFLAGS+= -I${LOCALBASE}/include
-OPTIONS= ASPELL "Build with ASPELL support" off \
- OPENSSL "Build with OPENSSL support" on
+OPTIONS_DEFINE= ASPELL OPENSSL
+OPTIONS_DEFAULT= OPENSSL
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_ASPELL)
+.if ${PORT_OPTIONS:MASPELL}
LIB_DEPENDS+= aspell.16:${PORTSDIR}/polish/aspell
CONFIGURE_ARGS+= --enable-aspell
.endif
-.if defined(WITHOUT_OPENSSL)
+.if empty(PORT_OPTIONS:MOPENSSL)
CONFIGURE_ARGS+= --without-openssl
.endif
@@ -50,4 +50,4 @@ MANCOMPRESSED= no
post-install:
${STRIP_CMD} ${PREFIX}/bin/ekg
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>