aboutsummaryrefslogtreecommitdiff
path: root/polish/kadu/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-08-22 18:21:11 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-08-22 18:21:11 +0000
commit0f6c33b6ce7768315d30a1551e88cdeae0448147 (patch)
treefeb8911a9bf3d3255d1ce6050dc6dbcff47f24f3 /polish/kadu/Makefile
parent0cf443676aadf771111c9d8e5cb76067907038d8 (diff)
downloadports-0f6c33b6ce7768315d30a1551e88cdeae0448147.tar.gz
ports-0f6c33b6ce7768315d30a1551e88cdeae0448147.zip
Notes
Diffstat (limited to 'polish/kadu/Makefile')
-rw-r--r--polish/kadu/Makefile47
1 files changed, 19 insertions, 28 deletions
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index 5e1c512ba946..0bc90a04bbf2 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -6,51 +6,53 @@
#
PORTNAME= kadu
-PORTVERSION= 0.6.5.4
-PORTREVISION= 1
+PORTVERSION= 0.9.2
PORTEPOCH= 1
CATEGORIES= polish net-im
MASTER_SITES= http://www.kadu.net/download/stable/:kadu \
- http://www.kadu.net/download/additions/:additions \
- http://kadu.net/~arvenil/tabs/download/${PORTVERSION:C/(([0-9]+\.){2}[0-9]+)(.*)/\1/}/:modtab
+ http://www.kadu.net/download/additions/:additions
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:kadu
DIST_SUBDIR= kadu
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
-MAINTAINER= mwisnicki+freebsd@gmail.com
-COMMENT= QT Gadu-Gadu client
+MAINTAINER= pawel@FreeBSD.org
+COMMENT= QT Gadu-Gadu / Jabber client
+
+LICENSE= GPLv2
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= enchant.1:${PORTSDIR}/textproc/enchant \
gadu.3:${PORTSDIR}/polish/libgadu \
+ idn:${PORTSDIR}/dns/libidn \
qca.2:${PORTSDIR}/devel/qca \
sndfile.1:${PORTSDIR}/audio/libsndfile
RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
# TODO enable devel/libexecinfo
-
-BROKEN= does not configure
-
-TABS_MOD_DISTFILE= kadu-tabs-1.2.3.tar.bz2
+# TODO ntrack and ntrack-qt (needs porting) ?
+# TODO separate ports for plugins and themes (possible starting with 0.10)
GG6_EMOTS_DISTFILE= kompatybilne_z_GG6.tar.gz
GG7_EMOTS_DISTFILE= dodatkowe_emoty_GG7.tar.gz
USE_BZIP2= yes
USE_CMAKE= yes
-CMAKE_ARGS= -DENABLE_AUTODOWNLOAD:BOOL=OFF
+USE_XORG= xscrnsaver
+CMAKE_ARGS= -DENABLE_AUTODOWNLOAD:BOOL=OFF \
+ -DKADU_VERSION:STRING="${DISTVERSION}" \
+ -DWITH_ENCHANT=ON
+# Setting KADU_VERSION disables git invocation
CMAKE_USE_PTHREAD= yes
USE_QT_VER= 4
-QT_COMPONENTS= gui dbus network qt3support script webkit xml \
- qmake_build linguist_build moc_build rcc_build uic_build \
- imageformats_run
+QT_COMPONENTS= gui dbus network script webkit xml qmake_build \
+ linguist_build moc_build rcc_build uic_build \
+ imageformats_run sql-sqlite3_run
WANT_GNOME= yes
INSTALLS_ICONS= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_JOBS_UNSAFE= yes
-OPTIONS= GG_EMOTS "Install GG-compatible emoticons" off \
- TABS "Build tabs module" off
+OPTIONS= GG_EMOTS "Install GG-compatible emoticons" off
.include <bsd.port.pre.mk>
@@ -62,14 +64,6 @@ DISTFILES+= ${GG6_EMOTS_DISTFILE}:additions \
PLIST_SUB+= GG_EMOTS="@comment "
.endif
-.if defined(WITH_TABS)
-PLIST_SUB+= TABS_MOD=""
-DISTFILES+= ${TABS_MOD_DISTFILE}:modtab
-KADU_SHARED_MODULES+= tabs
-.else
-PLIST_SUB+= TABS_MOD="@comment "
-.endif
-
KADU_SHARED_MODULES+= spellchecker qt4_sound
KADU_DISABLED_MODULES= alsa_sound amarok1_mediaplayer audacious_mediaplayer mediaplayer
@@ -92,8 +86,5 @@ post-patch:
${MV} kompatybilne_z_GG6 gg6_compatible && \
cd gg6_compatible && ${TAR} -zxf ${_DISTDIR}/${GG7_EMOTS_DISTFILE}
.endif
-.if defined(WITH_TABS)
- @cd ${WRKSRC}/modules && ${TAR} -zxf ${_DISTDIR}/${TABS_MOD_DISTFILE}
-.endif
.include <bsd.port.post.mk>