aboutsummaryrefslogtreecommitdiff
path: root/polish/kadu/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-06-07 22:44:21 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-06-07 22:44:21 +0000
commit2fa62596744270745d9d0540f5bbd839f6b78d23 (patch)
treeb7e5a1ec8ce92178c23aff878c9671b8c96b7b89 /polish/kadu/Makefile
parente496938a05b08a6dc0a4f3562f7615a574354e2e (diff)
downloadports-2fa62596744270745d9d0540f5bbd839f6b78d23.tar.gz
ports-2fa62596744270745d9d0540f5bbd839f6b78d23.zip
Notes
Diffstat (limited to 'polish/kadu/Makefile')
-rw-r--r--polish/kadu/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index 8888a4d2f09c..98e674d981c7 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -52,11 +52,12 @@ USE_QT4= dbus gui network script scripttools webkit xml phonon \
WANT_GNOME= yes
INSTALLS_ICONS= yes
-OPTIONS= GG_EMOTS "Install GG-compatible emoticons" off
+OPTIONS_DEFINE= GG_EMOTS
+GG_EMOTS_DESC= Install GG-compatible emoticons
.include <bsd.port.options.mk>
-.if defined(WITH_GG_EMOTS)
+.if ${PORT_OPTIONS:MGG_EMOTS}
PLIST_SUB+= GG_EMOTS=""
DISTFILES+= ${GG6_EMOTS_DISTFILE}:additions \
${GG7_EMOTS_DISTFILE}:additions
@@ -72,7 +73,7 @@ post-patch:
@${FIND} ${WRKSRC} -exec ${GREP} -q "#!/bin/bash" {} \; \
-exec ${REINPLACE_CMD} -e 's|#!/bin/bash|#!/usr/bin/env bash|g' {} \;
-.if defined(WITH_GG_EMOTS)
+.if ${PORT_OPTIONS:MGG_EMOTS}
@cd ${WRKSRC}/varia/themes/emoticons && \
${TAR} -zxf ${_DISTDIR}/${GG6_EMOTS_DISTFILE} && \
${MV} kompatybilne_z_GG6 gg6_compatible && \