aboutsummaryrefslogtreecommitdiff
path: root/polish/kadu/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2015-07-23 22:04:49 +0000
committerPawel Pekala <pawel@FreeBSD.org>2015-07-23 22:04:49 +0000
commitf58da4412a98fc030d9201ca2065613d80b8ced5 (patch)
treef3452e8dcf235586584b803c4ba9b9b67af2a17e /polish/kadu/Makefile
parenta66fa641c2e115533ce359897368f670ed16891c (diff)
downloadports-f58da4412a98fc030d9201ca2065613d80b8ced5.tar.gz
ports-f58da4412a98fc030d9201ca2065613d80b8ced5.zip
Notes
Diffstat (limited to 'polish/kadu/Makefile')
-rw-r--r--polish/kadu/Makefile22
1 files changed, 8 insertions, 14 deletions
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index 4f0f4a979489..df0ee97cfa6e 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= kadu
-PORTVERSION= 1.5
+PORTVERSION= 2.1
PORTEPOCH= 1
CATEGORIES= polish net-im
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/:kadu \
@@ -22,7 +22,8 @@ BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
pl-libgadu>=1.12.1:${PORTSDIR}/polish/libgadu
LIB_DEPENDS= libmpdclient.so:${PORTSDIR}/audio/libmpdclient \
libsndfile.so:${PORTSDIR}/audio/libsndfile \
- libqca.so:${PORTSDIR}/devel/qca \
+ libinjeqt.so:${PORTSDIR}/devel/injeqt \
+ libqca-qt5.so:${PORTSDIR}/devel/qca-qt5 \
libidn.so:${PORTSDIR}/dns/libidn \
libgadu.so:${PORTSDIR}/polish/libgadu \
libotr.so:${PORTSDIR}/security/libotr \
@@ -33,14 +34,15 @@ LIB_DEPENDS= libmpdclient.so:${PORTSDIR}/audio/libmpdclient \
GG6_EMOTS_DISTFILE= kompatybilne_z_GG6.tar.gz
GG7_EMOTS_DISTFILE= dodatkowe_emoty_GG7.tar.gz
-USES= cmake execinfo pkgconfig tar:bzip2
+USES= cmake compiler:c++11-lib execinfo libarchive pkgconfig tar:bzip2
USE_XORG= xscrnsaver
CMAKE_ARGS= -DKADU_VERSION:STRING="${DISTVERSION}" -DWITH_ENCHANT=ON
# Setting KADU_VERSION disables git invocation
-USE_QT4= dbus gui network phonon script scripttools webkit xml \
- linguist_build moc_build qmake_build rcc_build uic_build \
- imageformats_run sql-sqlite3_run
+USE_QT5= buildtools_build concurrent dbus declarative gui multimedia \
+ network script scripttools webkit x11extras phonon4 \
+ xml linguisttools_build qmake_build imageformats_run \
+ sql-sqlite3_run
LDFLAGS+= -lexecinfo
INSTALLS_ICONS= yes
@@ -53,14 +55,6 @@ GG_EMOTS_DISTFILES= ${GG6_EMOTS_DISTFILE}:additions \
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-USE_GCC= yes
-.endif
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000009
-LIB_DEPENDS+= libarchive.so.13:${PORTSDIR}/archivers/libarchive
-.endif
-
post-install:
.if ${PORT_OPTIONS:MGG_EMOTS}
@${MKDIR} ${WRKSRC}/varia/themes/emoticons