aboutsummaryrefslogtreecommitdiff
path: root/polish/libgadu/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-15 10:37:30 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-15 10:37:30 +0000
commit082e35599c229e86688274abb530ffee0973e12a (patch)
treef4b94642ee84d5be73821a67e82707cdaacb53d7 /polish/libgadu/Makefile
parentb81b2122ada2102e125768b10e8e2bbfc19c682d (diff)
downloadports-082e35599c229e86688274abb530ffee0973e12a.tar.gz
ports-082e35599c229e86688274abb530ffee0973e12a.zip
Notes
Diffstat (limited to 'polish/libgadu/Makefile')
-rw-r--r--polish/libgadu/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/polish/libgadu/Makefile b/polish/libgadu/Makefile
new file mode 100644
index 000000000000..f83a76b0f3d5
--- /dev/null
+++ b/polish/libgadu/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libgadu
+# Date created: 29 December 2005
+# Whom: Aleksander Fafula <alex@BSDGuru.org>
+#
+# $FreeBSD$
+
+PORTNAME= libgadu
+PORTVERSION= 20051229
+CATEGORIES= polish net
+MASTER_SITES= http://bsdguru.org/distfiles/
+
+MAINTAINER= alex@BSDGuru.org
+COMMENT= This library is used by many IMs with Gadu-Gadu support
+
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack pkgconfig
+USE_AUTOTOOLS= aclocal:15 autoheader:259 autoconf:259
+ACLOCAL_ARGS= -I ${WRKSRC}/m4
+
+CONFIGURE_ARGS= --enable-shared --disable-static
+
+INSTALLS_SHLIB= yes
+
+post-install:
+ ${RM} ${PREFIX}/lib/libgadu.so ${PREFIX}/lib/libgadu.so.3
+ ${MV} ${PREFIX}/lib/libgadu.so.3.3 ${PREFIX}/lib/libgadu.so.3
+ ${LN} -s ${PREFIX}/lib/libgadu.so.3 ${PREFIX}/lib/libgadu.so
+
+.include <bsd.port.mk>