aboutsummaryrefslogtreecommitdiff
path: root/polish/libgadu
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-28 17:09:47 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-28 17:09:47 +0000
commit122d8f93ec183b4b2eb5465eba1ff414c45be43e (patch)
treeacbba908f64e47c7a2a21f510358e22407d1c029 /polish/libgadu
parente35cfa602c0eb966ee8694c1173616addfa974aa (diff)
downloadports-122d8f93ec183b4b2eb5465eba1ff414c45be43e.tar.gz
ports-122d8f93ec183b4b2eb5465eba1ff414c45be43e.zip
Notes
Diffstat (limited to 'polish/libgadu')
-rw-r--r--polish/libgadu/Makefile9
-rw-r--r--polish/libgadu/files/patch-Makefile.in27
2 files changed, 30 insertions, 6 deletions
diff --git a/polish/libgadu/Makefile b/polish/libgadu/Makefile
index 8aec406b1c9d..d220275faf7f 100644
--- a/polish/libgadu/Makefile
+++ b/polish/libgadu/Makefile
@@ -6,13 +6,15 @@
PORTNAME= libgadu
PORTVERSION= 20051229
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= polish net
MASTER_SITES= http://bsdguru.org/distfiles/
MAINTAINER= alex@BSDGuru.org
COMMENT= This library is used by many IMs with Gadu-Gadu support
+CONFLICTS= pl-ekg-1.[0-5]* pl-ekg-1.6,2
+
USE_GMAKE= yes
USE_GNOME= gnomehack pkgconfig
USE_AUTOTOOLS= aclocal:15 autoheader:259 autoconf:259
@@ -22,9 +24,4 @@ CONFIGURE_ARGS= --enable-shared --disable-static --without-openssl
INSTALLS_SHLIB= yes
-post-install:
- ${RM} ${PREFIX}/lib/libgadu.so ${PREFIX}/lib/libgadu.so.3
- ${MV} ${PREFIX}/lib/libgadu.so.3.3 ${PREFIX}/lib/libgadu.so.3
- ${LN} -s ${PREFIX}/lib/libgadu.so.3 ${PREFIX}/lib/libgadu.so
-
.include <bsd.port.mk>
diff --git a/polish/libgadu/files/patch-Makefile.in b/polish/libgadu/files/patch-Makefile.in
new file mode 100644
index 000000000000..bf291c8e22e2
--- /dev/null
+++ b/polish/libgadu/files/patch-Makefile.in
@@ -0,0 +1,27 @@
+--- lib/Makefile.in.orig Sat Jun 25 08:41:07 2005
++++ lib/Makefile.in Sun Jul 2 19:41:00 2006
+@@ -27,7 +27,7 @@
+
+ SHAREDMM = libgadu.so
+ SHAREDM = $(SHAREDMM).$(VERSION_MAJOR)
+-SHARED = $(SHAREDM).$(VERSION_MINOR)
++SHARED = $(SHAREDM)
+ STATIC = libgadu.a
+
+ all: @static@ @shared@
+@@ -57,7 +57,6 @@
+
+ $(SHARED): $(LOBJS)
+ $(CC) -shared -Wl,-soname,libgadu.so.$(VERSION_MAJOR) -o $(SHARED) $(LOBJS) $(LIBS) -lc
+- $(LN_S) -f $(SHARED) $(SHAREDM)
+ $(LN_S) -f $(SHARED) $(SHAREDMM)
+
+ #
+@@ -82,7 +81,6 @@
+
+ install-shared: install-common @strip_libgadu_so@
+ $(INSTALL) -m 755 $(SHARED) $(DESTDIR)$(libdir)
+- cd $(DESTDIR)$(libdir) && $(LN_S) -f $(SHARED) $(SHAREDM)
+ cd $(DESTDIR)$(libdir) && $(LN_S) -f $(SHARED) $(SHAREDMM)
+
+ install-static: install-common